summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-08-25 03:54:24 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-08-25 03:58:06 +0200
commit2e4fe45f1a275ec48ff1d678ff7db940cd3471a1 (patch)
treee0ec01fdc9ea6429858a6ff4520ae793314f0575
parentapp-arch/brotli: install man pages (diff)
downloadgentoo-2e4fe45f1a275ec48ff1d678ff7db940cd3471a1.tar.gz
gentoo-2e4fe45f1a275ec48ff1d678ff7db940cd3471a1.tar.bz2
gentoo-2e4fe45f1a275ec48ff1d678ff7db940cd3471a1.zip
app-emacs/dashboard: bump to 1.8.0_pre20220809
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/dashboard/Manifest1
-rw-r--r--app-emacs/dashboard/dashboard-1.8.0_pre20220809.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/dashboard/Manifest b/app-emacs/dashboard/Manifest
index 20e1b7ef9544..2add109ee8eb 100644
--- a/app-emacs/dashboard/Manifest
+++ b/app-emacs/dashboard/Manifest
@@ -1 +1,2 @@
DIST dashboard-1.8.0_pre20220406.tar.gz 191442 BLAKE2B 8b105d8ed9b31e7439cc55b85c9e0bb46739fcb26f9e1e605492a552cbcfe9799794be6239b6c622bfbfc2f850d20f2944f759010eb502bcb75edb570ae7e5b8 SHA512 b3b714bbee034fecbf1172dccd5eebc38373c11a510c532a7b9ba31cac79daafe7e9ccf7c5e622abbdb44817c966f100ec4f7a447e8b0370f9d7e66ff55e45ca
+DIST dashboard-1.8.0_pre20220809.tar.gz 192857 BLAKE2B 22a7be748b3308282deb7e0500269a0aa809c2c6a5e57e984e83ca13803b7e55364e2f5619380444a7daf320c1bc6da26daeb0451efc3c20fc82148e55fa7f3a SHA512 10e2cdd724731b0c5ae195f8a8b3c9ba83a4c6a0d5fba00e7ecc224b22673296ca522642d179449e68d852b06789665e2c5bbfef84dea5e878110ee9e3b23dce
diff --git a/app-emacs/dashboard/dashboard-1.8.0_pre20220809.ebuild b/app-emacs/dashboard/dashboard-1.8.0_pre20220809.ebuild
new file mode 100644
index 000000000000..56c257960eb5
--- /dev/null
+++ b/app-emacs/dashboard/dashboard-1.8.0_pre20220809.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=49e5603cac7d028bfc4c679161a20ca40327956c
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Extensible Emacs dashboard, with sections for bookmarks, projects, agenda and more"
+HOMEPAGE="https://github.com/emacs-dashboard/emacs-dashboard/"
+SRC_URI="https://github.com/emacs-dashboard/emacs-${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${PN}-${H}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # tests not in the repository, require "Eask"
+
+DOCS=( CHANGELOG.md README.org etc )
+PATCHES=( "${FILESDIR}"/${PN}-dashboard-widgets.el-banners.patch )
+
+ELISP_REMOVE=( .dir-locals.el )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${EPREFIX}${SITEETC}/${PN}|" -i dashboard-widgets.el || die
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}"/${PN}
+ doins -r banners
+}