summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois-Xavier Carton <fx.carton91@gmail.com>2018-07-11 05:11:51 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-12 18:58:12 +0200
commit2e50d4f190de34c17a48f19601847331f18292bf (patch)
tree5654d0fd5b523d2fe53449cb3a9c15c037777f78
parentnet-im/qtox: version bump to 1.16.3 (diff)
downloadgentoo-2e50d4f190de34c17a48f19601847331f18292bf.tar.gz
gentoo-2e50d4f190de34c17a48f19601847331f18292bf.tar.bz2
gentoo-2e50d4f190de34c17a48f19601847331f18292bf.zip
net-im/toxic: version bump to 0.8.2
Closes: https://github.com/gentoo/gentoo/pull/9058 Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--net-im/toxic/Manifest2
-rw-r--r--net-im/toxic/metadata.xml2
-rw-r--r--net-im/toxic/toxic-0.8.2.ebuild99
3 files changed, 103 insertions, 0 deletions
diff --git a/net-im/toxic/Manifest b/net-im/toxic/Manifest
index 386106c5dd74..f309599e15ad 100644
--- a/net-im/toxic/Manifest
+++ b/net-im/toxic/Manifest
@@ -1 +1,3 @@
DIST toxic-0.8.0.tar.gz 1145799 BLAKE2B 01dd14d28feac0aadd1e87d8538910601b532e8cb02219091a863502eb80f812a034eecf06f131ff878509dfc1eb40e5f9baf7547180346eeb03bdb7dea4a6ed SHA512 3c59edb61b1bcdbfa3a8391a1a1ceccc6c9c38b49c1709813d60480b180fb39607806116b9dcd1de35ebb02e23e95d78c8191f04a4875e06e27fa43bc9800b33
+DIST toxic-0.8.2.tar.gz 1146526 BLAKE2B 0a1c80313963287e88aa489ecf4614365a3d94c770cdfb3b1f3afd0bf2b70639c35b9c5ce52408647abdaac9822c9529b603ec1883779f5486ff63001d98ff5e SHA512 258e873404315c9a1f59d67f524089afebad88d800116bd9e53c8bc35bd9dd6b66cfcd90db06181f01330ba0a302456510fac5c01fdbfde7d475aa5d6b1070aa
+DIST toxic_patches-0.8.2.tar.gz 3859 BLAKE2B 4a19226cea6c7ce60f599fbd4f74171f26b3812259f0f8997997526bde7beb6fe64b922f25fe77e0ac8f9b185db116d2e626cb889631a1508786b92f9bbc8927 SHA512 737cc53e814567e10ad8b7431be63ab8f99b76bb150490c31e03309c4e51ee34a798d141cbde446cbbc4b5c0145ca468f3456a2af4b966c80792cdccc6562b46
diff --git a/net-im/toxic/metadata.xml b/net-im/toxic/metadata.xml
index 7982519991a9..d4103ec575aa 100644
--- a/net-im/toxic/metadata.xml
+++ b/net-im/toxic/metadata.xml
@@ -14,8 +14,10 @@
</longdescription>
<use>
<flag name="audio">Enables audio calling</flag>
+ <flag name="notification">Enables desktop notifications with libnotify, with sound support.</flag>
<flag name="notifications">Enables desktop notifications with libnotify, with sound support.</flag>
<flag name="qrcode">Enables QR code support</flag>
+ <flag name="sound">Enables audio calling</flag>
<flag name="video">Enables video calling</flag>
</use>
</pkgmetadata>
diff --git a/net-im/toxic/toxic-0.8.2.ebuild b/net-im/toxic/toxic-0.8.2.ebuild
new file mode 100644
index 000000000000..ac48eccb5065
--- /dev/null
+++ b/net-im/toxic/toxic-0.8.2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
+
+inherit python-single-r1 xdg
+
+DESCRIPTION="A curses-based client for Tox"
+HOMEPAGE="https://github.com/JFreegman/toxic"
+SRC_URI="https://github.com/JFreegman/toxic/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/fx-carton/toxic_patches/archive/v${PV}.tar.gz -> ${PN}_patches-${PV}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+X +sound notification +python +qrcode +video"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Not a typo; net-libs/tox only has a 'both or neither' option
+RDEPEND="
+ net-libs/tox:0/0.2
+ dev-libs/libconfig
+ net-misc/curl:0=
+ sys-libs/ncurses:0=
+ notification? ( x11-libs/libnotify )
+ python? ( ${PYTHON_DEPS} )
+ qrcode? ( media-gfx/qrencode:= )
+ sound? (
+ media-libs/openal
+ media-libs/freealut
+ net-libs/tox:0/0.2[av]
+ )
+ video? (
+ media-libs/libvpx:=
+ net-libs/tox:0/0.2[av]
+ x11-libs/libX11
+ )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+PATCHES=(
+ "${WORKDIR}/${PN}_patches-${PV}/${P}-make-qrencode-optional.patch"
+ )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ if [[ ${PV} = 0.8.2 ]]; then
+ sed -i \
+ -e 's/^\(TOXIC_VERSION =\).*$/\1 0.8.2/' \
+ cfg/global_vars.mk || die
+ else
+ die "Remove stale version hack"
+ fi
+ sed -i '/^VIDEO = /s/DISABLE_AV/DISABLE_VI/g' cfg/checks/check_features.mk || die
+ find . '(' -name '*.mk' -o -name 'Makefile' ')' -exec sed -i 's/^\t@/\t/' {} + || die
+}
+
+src_configure() {
+ export USER_CFLAGS="${CFLAGS}"
+ export USER_LDFLAGS="${LDFLAGS}"
+ if ! use sound; then
+ export DISABLE_AV=1
+ export DISABLE_SOUND_NOTIFY=1
+ fi
+ if ! use video; then
+ export DISABLE_VI=1
+ fi
+ if ! use X; then
+ export DISABLE_X11=1
+ fi
+ if ! use notification; then
+ export DISABLE_DESKTOP_NOTIFY=1
+ fi
+ if ! use qrcode; then
+ export DISABLE_QRCODE=1
+ export DISABLE_QRPNG=1
+ fi
+ if use python; then
+ export ENABLE_PYTHON=1
+ fi
+ sed -i \
+ -e "s,/usr/local,${EPREFIX}/usr,g" \
+ cfg/global_vars.mk || die "PREFIX sed failed"
+}
+
+src_install() {
+ default
+ if ! use sound; then
+ rm -r "${ED%/}"/usr/share/${PN}/sounds || die "Could not remove sounds directory"
+ fi
+}