summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-09 21:38:36 +0000
committerSam James <sam@gentoo.org>2021-06-09 21:38:36 +0000
commit2e76cc8b33f566bab28fad6f4efba99b18c03631 (patch)
tree8b2a2f3240910b24304810f74c76d68b4a0e4734
parentdev-ml/ocaml-fileutils: add 0.6.3 (diff)
downloadgentoo-2e76cc8b33f566bab28fad6f4efba99b18c03631.tar.gz
gentoo-2e76cc8b33f566bab28fad6f4efba99b18c03631.tar.bz2
gentoo-2e76cc8b33f566bab28fad6f4efba99b18c03631.zip
dev-lang/ocaml: adjust subslot to be major version
Should be bytecode compatible with non-major version changes. Makes it a lot easier to give dependencies in e.g. camlp4 which needs to be exactly aligned with the OCaml major version. Bug: https://bugs.gentoo.org/794898 Acked-by: Alfredo Tupone <tupone@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-lang/ocaml/ocaml-4.05.0-r5.ebuild (renamed from dev-lang/ocaml/ocaml-4.05.0-r3.ebuild)2
-rw-r--r--dev-lang/ocaml/ocaml-4.05.0-r6.ebuild (renamed from dev-lang/ocaml/ocaml-4.05.0-r4.ebuild)2
-rw-r--r--dev-lang/ocaml/ocaml-4.09.0-r1.ebuild (renamed from dev-lang/ocaml/ocaml-4.09.0.ebuild)2
-rw-r--r--dev-lang/ocaml/ocaml-4.10.2-r1.ebuild (renamed from dev-lang/ocaml/ocaml-4.10.2.ebuild)2
-rw-r--r--dev-lang/ocaml/ocaml-4.11.2-r1.ebuild (renamed from dev-lang/ocaml/ocaml-4.11.2.ebuild)2
-rw-r--r--dev-lang/ocaml/ocaml-4.12.0-r1.ebuild (renamed from dev-lang/ocaml/ocaml-4.12.0.ebuild)2
6 files changed, 6 insertions, 6 deletions
diff --git a/dev-lang/ocaml/ocaml-4.05.0-r3.ebuild b/dev-lang/ocaml/ocaml-4.05.0-r5.ebuild
index 69094b6cb10a..36adb282101c 100644
--- a/dev-lang/ocaml/ocaml-4.05.0-r3.ebuild
+++ b/dev-lang/ocaml/ocaml-4.05.0-r5.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://github.com/ocaml/ocaml/archive/${PV/_/+}.tar.gz -> ${MY_P}.tar.
LICENSE="QPL-1.0 LGPL-2"
# Everytime ocaml is updated to a new version, everything ocaml must be rebuilt,
# so here we go with the subslot.
-SLOT="0/${PV}"
+SLOT="0/$(ver_cut 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE="emacs flambda latex ncurses +ocamlopt spacetime X xemacs"
diff --git a/dev-lang/ocaml/ocaml-4.05.0-r4.ebuild b/dev-lang/ocaml/ocaml-4.05.0-r6.ebuild
index 1fd3049eff5e..ae3120cad728 100644
--- a/dev-lang/ocaml/ocaml-4.05.0-r4.ebuild
+++ b/dev-lang/ocaml/ocaml-4.05.0-r6.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://github.com/ocaml/ocaml/archive/${PV/_/+}.tar.gz -> ${MY_P}.tar.
LICENSE="QPL-1.0 LGPL-2"
# Everytime ocaml is updated to a new version, everything ocaml must be rebuilt,
# so here we go with the subslot.
-SLOT="0/${PV}"
+SLOT="0/$(ver_cut 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE="emacs flambda latex ncurses +ocamlopt spacetime X xemacs"
diff --git a/dev-lang/ocaml/ocaml-4.09.0.ebuild b/dev-lang/ocaml/ocaml-4.09.0-r1.ebuild
index f74988668b87..14dc7a908b0e 100644
--- a/dev-lang/ocaml/ocaml-4.09.0.ebuild
+++ b/dev-lang/ocaml/ocaml-4.09.0-r1.ebuild
@@ -10,7 +10,7 @@ SRC_URI="https://github.com/ocaml/ocaml/archive/${PV}.tar.gz -> ${P}.tar.gz"
DESCRIPTION="Programming language supporting functional, imperative & object-oriented styles"
LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
+SLOT="0/$(ver_cut 1-2)"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE="emacs flambda latex +ocamlopt spacetime xemacs"
diff --git a/dev-lang/ocaml/ocaml-4.10.2.ebuild b/dev-lang/ocaml/ocaml-4.10.2-r1.ebuild
index 208d8612d6a9..e1ca18aa9617 100644
--- a/dev-lang/ocaml/ocaml-4.10.2.ebuild
+++ b/dev-lang/ocaml/ocaml-4.10.2-r1.ebuild
@@ -10,7 +10,7 @@ SRC_URI="https://github.com/ocaml/ocaml/archive/${PV}.tar.gz -> ${P}.tar.gz"
DESCRIPTION="Programming language supporting functional, imperative & object-oriented styles"
LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
+SLOT="0/$(ver_cut 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE="emacs flambda latex +ocamlopt spacetime xemacs"
diff --git a/dev-lang/ocaml/ocaml-4.11.2.ebuild b/dev-lang/ocaml/ocaml-4.11.2-r1.ebuild
index e3298bdfc899..f1ad43dbf997 100644
--- a/dev-lang/ocaml/ocaml-4.11.2.ebuild
+++ b/dev-lang/ocaml/ocaml-4.11.2-r1.ebuild
@@ -10,7 +10,7 @@ SRC_URI="https://github.com/ocaml/ocaml/archive/${PV}.tar.gz -> ${P}.tar.gz"
DESCRIPTION="Programming language supporting functional, imperative & object-oriented styles"
LICENSE="QPL-1.0 LGPL-2"
-SLOT="0/${PV}"
+SLOT="0/$(ver_cut 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE="emacs flambda latex +ocamlopt spacetime xemacs"
diff --git a/dev-lang/ocaml/ocaml-4.12.0.ebuild b/dev-lang/ocaml/ocaml-4.12.0-r1.ebuild
index b045e3d11535..137a6160e458 100644
--- a/dev-lang/ocaml/ocaml-4.12.0.ebuild
+++ b/dev-lang/ocaml/ocaml-4.12.0-r1.ebuild
@@ -10,7 +10,7 @@ SRC_URI="https://github.com/ocaml/ocaml/archive/${PV}.tar.gz -> ${P}.tar.gz"
DESCRIPTION="Programming language supporting functional, imperative & object-oriented styles"
LICENSE="QPL-1.0 LGPL-2"
-SLOT="0/${PV}"
+SLOT="0/$(ver_cut 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE="emacs flambda latex +ocamlopt xemacs"