summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2021-10-03 19:40:42 +0200
committerDavide Pesavento <pesa@gentoo.org>2021-10-03 19:40:42 +0200
commit2ef4270d05ea482710350bd346ddf9fa85dd5941 (patch)
tree0977eff9597ecae40b7abc9414e81889e0f0ba3a
parentdev-python/sip: bump to 6.2.0 final (diff)
downloadgentoo-2ef4270d05ea482710350bd346ddf9fa85dd5941.tar.gz
gentoo-2ef4270d05ea482710350bd346ddf9fa85dd5941.tar.bz2
gentoo-2ef4270d05ea482710350bd346ddf9fa85dd5941.zip
dev-python/PyQt-builder: add 1.11.0
Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
-rw-r--r--dev-python/PyQt-builder/Manifest1
-rw-r--r--dev-python/PyQt-builder/PyQt-builder-1.11.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/PyQt-builder/Manifest b/dev-python/PyQt-builder/Manifest
index 92a7b1888aa2..9feed8b5ebc6 100644
--- a/dev-python/PyQt-builder/Manifest
+++ b/dev-python/PyQt-builder/Manifest
@@ -1 +1,2 @@
DIST PyQt-builder-1.10.3.tar.gz 5725537 BLAKE2B da1abab8fa46da9dee15dedbcf84068b80ce081e87e640fc50642ff6dd15aa3963b9186a32193f3c492c4f141fb7242f13395a539f436575532a5735e3c85720 SHA512 26a01cb2dc4428277cc62da23404433d75f84c61360c35dfd9c440841adbcb1bf39b2211e4e33967ee2730c163dd1585b5fcbd88c6fd7efa2f1f84915a390e2a
+DIST PyQt-builder-1.11.0.tar.gz 5704150 BLAKE2B 4706e8c8663356e7c70b60c19c45db726de6b7b1b05f218aba5a966318cea497219f685f295b9069c0059e88eca053a97717a7a52add7c5ea59820bff2b810ea SHA512 4eeafaa725afeffa5794cc47e733ecfa99887c0f14f461843f4b8c71fbdb2ecf58ba05ca64dbec3e00bb2c192a25e29ee78e93d0bad742becb3379bd357e8e68
diff --git a/dev-python/PyQt-builder/PyQt-builder-1.11.0.ebuild b/dev-python/PyQt-builder/PyQt-builder-1.11.0.ebuild
new file mode 100644
index 000000000000..4d69521c2f08
--- /dev/null
+++ b/dev-python/PyQt-builder/PyQt-builder-1.11.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The PEP 517 compliant PyQt build system"
+HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt-builder/ https://pypi.org/project/PyQt-builder/"
+
+MY_P=${PN}-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+fi
+S=${WORKDIR}/${MY_P}
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/sip-5.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc --no-autodoc
+
+python_prepare_all() {
+ # don't install prebuilt Windows DLLs
+ sed -i -e "s:'dlls/\*/\*',::" setup.py || die
+ rm -r "${PN/-/_}.egg-info" || die
+
+ distutils-r1_python_prepare_all
+}