summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-11 21:19:12 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-11 21:23:35 +0200
commit2f02d77c4aa64bc5df0e2e7d4f1768869adbd165 (patch)
tree894bc034d3df43756196416f0e99d307cc84abdc
parentdev-python/pycares: Add python@ as co-maint. (diff)
downloadgentoo-2f02d77c4aa64bc5df0e2e7d4f1768869adbd165.tar.gz
gentoo-2f02d77c4aa64bc5df0e2e7d4f1768869adbd165.tar.bz2
gentoo-2f02d77c4aa64bc5df0e2e7d4f1768869adbd165.zip
dev-python/terminado: Bump to 0.9.5 (NFC)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/terminado/Manifest1
-rw-r--r--dev-python/terminado/terminado-0.9.5.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/terminado/Manifest b/dev-python/terminado/Manifest
index 49405556f0a7..ceb79d543266 100644
--- a/dev-python/terminado/Manifest
+++ b/dev-python/terminado/Manifest
@@ -1 +1,2 @@
DIST terminado-0.9.4.tar.gz 13934 BLAKE2B 8544d70a7c561005370bbb2b16db593ac9e4453b729b58d641b99066dc1255e294b712958d54a35a92d85e30b918a1122d24e97400b967858b542498d76305b5 SHA512 ab297e60c1adb25b5fbfcd0246db12f5df3acceeac3357af310602da3915345cb2d4fb460cc303cc4b5b5df237e750ce123ac0ed98a9bf7c6e8493783398cbc9
+DIST terminado-0.9.5.tar.gz 13953 BLAKE2B fcd67a5193fe20b17ff815c934fb20cbcb5d5ca29818c7064534017c13db7ab2326f0be00a4cb541ef877bb7d208eb93685fbb0c2ff08b8640cd5befb1c5eab5 SHA512 7b9f9b81bd30d7b5493faf92c2cecc251c68709ab4c8364e5da1aaf42507919563ee368c30d94c30913f116df9113612500473c6bdf5bc673a96ef1d6c7337a4
diff --git a/dev-python/terminado/terminado-0.9.5.ebuild b/dev-python/terminado/terminado-0.9.5.ebuild
new file mode 100644
index 000000000000..f329d3d887b8
--- /dev/null
+++ b/dev-python/terminado/terminado-0.9.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Terminals served to term.js using Tornado websockets"
+HOMEPAGE="https://pypi.org/project/terminado/ https://github.com/jupyter/terminado"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS=""
+
+RDEPEND="
+ dev-python/ptyprocess[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # workaround new readline defaults
+ echo "set enable-bracketed-paste off" > "${T}"/inputrc || die
+ local -x INPUTRC="${T}"/inputrc
+ distutils-r1_src_test
+}