summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-09 10:08:21 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-09 10:08:21 +0100
commit2f59c7835fe3816b58fe2a6120c1f62cc93c16cd (patch)
treebd29432f8a3832fc21f9a926ee1d4747803b0f94
parentdev-ml/jsonm: Bump to 1.0.1 (diff)
downloadgentoo-2f59c7835fe3816b58fe2a6120c1f62cc93c16cd.tar.gz
gentoo-2f59c7835fe3816b58fe2a6120c1f62cc93c16cd.tar.bz2
gentoo-2f59c7835fe3816b58fe2a6120c1f62cc93c16cd.zip
dev-ml/ocamlbuild: Bump to 0.11.0
Package-Manager: Portage-2.3.4, Repoman-2.3.2
-rw-r--r--dev-ml/ocamlbuild/Manifest1
-rw-r--r--dev-ml/ocamlbuild/ocamlbuild-0.11.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/ocamlbuild/Manifest b/dev-ml/ocamlbuild/Manifest
index eb1d547d6494..7abf6bd9d3a9 100644
--- a/dev-ml/ocamlbuild/Manifest
+++ b/dev-ml/ocamlbuild/Manifest
@@ -1 +1,2 @@
DIST ocamlbuild-0.10.1.tar.gz 193263 SHA256 2603be3709634b6191dd00627213cff56f15200f2d0a24e0af58a18a0580b71e SHA512 6d74bdce7fe147bf1a5fd570b569925b36b5f443c7251d1c13a0525e3086417b393a768722bf7d4b23a7e3178b0b3c2511499725c5a755d69783b8d555663e3b WHIRLPOOL 7ab4d455260af64066abd1922d8c5631df6a9541abf3950c919818875346a1f7bc21e5d08e9a93bacb3559373179663daddc89532f79391124972e6bc986f84d
+DIST ocamlbuild-0.11.0.tar.gz 195297 SHA256 1717edc841c9b98072e410f1b0bc8b84444b4b35ed3b4949ce2bec17c60103ee SHA512 14bc44cc63b6c99e711658a1145247bad8263632fbb4550238cef15e226a76b83e51b83575a7a96f16b96ec321dedd0ef23f36166c354838aec1922f58179efd WHIRLPOOL 861bbd807faffc18ab85585777ccb72d10faa0e531879421890751a867ce56af286fdb78b7b48d3c41d26605262d5908ae709aa6f591a2de94c3b5a697ba0929
diff --git a/dev-ml/ocamlbuild/ocamlbuild-0.11.0.ebuild b/dev-ml/ocamlbuild/ocamlbuild-0.11.0.ebuild
new file mode 100644
index 000000000000..f6a3478c9228
--- /dev/null
+++ b/dev-ml/ocamlbuild/ocamlbuild-0.11.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Generic build tool with built-in rules for building OCaml library and programs"
+HOMEPAGE="https://github.com/ocaml/ocamlbuild"
+SRC_URI="https://github.com/ocaml/ocamlbuild/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+ !<dev-ml/findlib-1.6.1-r1
+"
+
+src_configure() {
+ emake -f configure.make Makefile.config \
+ PREFIX="${EPREFIX}/usr" \
+ BINDIR="${EPREFIX}/usr/bin" \
+ LIBDIR="$(ocamlc -where)" \
+ OCAML_NATIVE=$(usex ocamlopt true false) \
+ OCAML_NATIVE_TOOLS=$(usex ocamlopt true false) \
+ NATDYNLINK=$(usex ocamlopt true false)
+}
+
+src_install() {
+ emake CHECK_IF_PREINSTALLED=false DESTDIR="${D}" install
+ dodoc Changes
+}