summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-01 20:39:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-01 23:21:55 +0200
commit2fdb5052e0cf4726eb141fd92a0ca83c2785ca35 (patch)
tree86f0c4bbe3bd5d66f0747ae1a622dcd5052b77ea
parentapp-accessibility/espeakup: Drop 0.71-r1, EAPI5-- (diff)
downloadgentoo-2fdb5052e0cf4726eb141fd92a0ca83c2785ca35.tar.gz
gentoo-2fdb5052e0cf4726eb141fd92a0ca83c2785ca35.tar.bz2
gentoo-2fdb5052e0cf4726eb141fd92a0ca83c2785ca35.zip
kde-apps/konsole: Fix build with GCC-11
Closes: https://bugs.gentoo.org/787179 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/konsole/files/konsole-21.04.0-gcc11.patch25
-rw-r--r--kde-apps/konsole/konsole-21.04.0.ebuild2
2 files changed, 27 insertions, 0 deletions
diff --git a/kde-apps/konsole/files/konsole-21.04.0-gcc11.patch b/kde-apps/konsole/files/konsole-21.04.0-gcc11.patch
new file mode 100644
index 000000000000..0a9e2a4cbc28
--- /dev/null
+++ b/kde-apps/konsole/files/konsole-21.04.0-gcc11.patch
@@ -0,0 +1,25 @@
+From 242213afd9eb9886e04eb9e6e69a4caa9c606363 Mon Sep 17 00:00:00 2001
+From: Kurt Hindenburg <kurt.hindenburg@gmail.com>
+Date: Fri, 30 Apr 2021 17:07:13 -0400
+Subject: [PATCH] Add missing include to fix build on gcc-11
+
+---
+ src/terminalDisplay/TerminalPainter.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/terminalDisplay/TerminalPainter.cpp b/src/terminalDisplay/TerminalPainter.cpp
+index fce10d09..7623602e 100644
+--- a/src/terminalDisplay/TerminalPainter.cpp
++++ b/src/terminalDisplay/TerminalPainter.cpp
+@@ -30,6 +30,8 @@
+ #include <QDebug>
+ #include <QtMath>
+
++#include <optional>
++
+ // we use this to force QPainter to display text in LTR mode
+ // more information can be found in: https://unicode.org/reports/tr9/
+ const QChar LTR_OVERRIDE_CHAR(0x202D);
+--
+GitLab
+
diff --git a/kde-apps/konsole/konsole-21.04.0.ebuild b/kde-apps/konsole/konsole-21.04.0.ebuild
index 701329615e79..387e191ea7f3 100644
--- a/kde-apps/konsole/konsole-21.04.0.ebuild
+++ b/kde-apps/konsole/konsole-21.04.0.ebuild
@@ -51,6 +51,8 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-gcc11.patch ) # bug 787179
+
src_prepare() {
ecm_src_prepare
ecm_punt_bogus_dep KF5 Completion