summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-08 12:06:49 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-08 12:57:42 -0500
commit30411a724d32f0832cf0fce8f264ab619cfaf670 (patch)
tree2677d2bd2995b9cbb4bc92ac1d24d3fcb4d423b1
parentdev-vcs/git-deps: add maintainer-needed (diff)
downloadgentoo-30411a724d32f0832cf0fce8f264ab619cfaf670.tar.gz
gentoo-30411a724d32f0832cf0fce8f264ab619cfaf670.tar.bz2
gentoo-30411a724d32f0832cf0fce8f264ab619cfaf670.zip
dev-python/pygame_sdl2: bump to EAPI 6, add maintainer-needed
Package-Manager: portage-2.2.28
-rw-r--r--dev-python/pygame_sdl2/metadata.xml1
-rw-r--r--dev-python/pygame_sdl2/pygame_sdl2-6.99.6-r1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pygame_sdl2/metadata.xml b/dev-python/pygame_sdl2/metadata.xml
index 0adaee828d62..e85f847e4658 100644
--- a/dev-python/pygame_sdl2/metadata.xml
+++ b/dev-python/pygame_sdl2/metadata.xml
@@ -1,6 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <!-- maintainer-needed -->
<upstream>
<remote-id type="github">renpy/pygame_sdl2</remote-id>
</upstream>
diff --git a/dev-python/pygame_sdl2/pygame_sdl2-6.99.6-r1.ebuild b/dev-python/pygame_sdl2/pygame_sdl2-6.99.6-r1.ebuild
new file mode 100644
index 000000000000..1a67b1683c11
--- /dev/null
+++ b/dev-python/pygame_sdl2/pygame_sdl2-6.99.6-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+inherit distutils-r1
+
+DESCRIPTION="Reimplementation of portions of the pygame API using SDL2"
+HOMEPAGE="https://github.com/renpy/pygame_sdl2"
+SRC_URI="http://www.renpy.org/dl/${PV}/pygame_sdl2-for-renpy-${PV}.tar.bz2"
+
+LICENSE="LGPL-2.1 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/libpng:0
+ media-libs/libsdl2[video]
+ media-libs/sdl2-image[png,jpeg]
+ media-libs/sdl2-mixer
+ media-libs/sdl2-ttf
+ virtual/jpeg:62
+"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/pygame-sdl2-for-renpy-${PV}