summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-24 05:05:49 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-24 05:05:49 +0200
commit304e1c29bfad477223e76ba63c09c17bdd22b699 (patch)
treea8ebcc2c19c8acb4d7a93c247393fe7644f62ef0
parentdev-python/botocore: Bump to 1.18.4 (diff)
downloadgentoo-304e1c29bfad477223e76ba63c09c17bdd22b699.tar.gz
gentoo-304e1c29bfad477223e76ba63c09c17bdd22b699.tar.bz2
gentoo-304e1c29bfad477223e76ba63c09c17bdd22b699.zip
dev-python/boto3: Bump to 1.15.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.15.4.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 2b8f85dc7ac1..99521345c9f1 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.15.0.tar.gz 335099 BLAKE2B 0cdf8cc0007a90671d4d3c66482d834e24860990
DIST boto3-1.15.1.tar.gz 335146 BLAKE2B d2d008dcb2059b120f142aaf588264122d1e84b450ab1fbc938627d1c8cc9bb60d1b80e68bc5e538376b56866156ca901abde747a8f973588b64b962284229c4 SHA512 46e1aabaa975b0215c2ece160b5e584468ba19699f87686c2787404d0a13274f763272cec577f830c6c71cb7f9e10b1c317a1348770f49283257d8cba65c5e3a
DIST boto3-1.15.2.tar.gz 335231 BLAKE2B f1eb144da7afc1cf630cdc1f61880d094186a37d46556ae361da278fd3045a119dcb09c3d08387a019ca88d6502fa8710a5e5733cd9dc9056676ef17853d76e2 SHA512 6866e0d6a50d11495e5f2a33a392b0edbe1ff6625235b26b5d6028f7c2c7089d78febe17b982f65dc2564254800a23409247ac09716b099f09f3751c5b7f47b5
DIST boto3-1.15.3.tar.gz 335286 BLAKE2B 05c9ef757b8d227ae06a22e78d978821ff50da719f122ac025940b2e1ac5728d6bac044d4bfab95c56ac8c363efd7abfe3de2b3fd65d423ab53dbdfc60b910da SHA512 dfecfc075896ce84fd58d0437b84a6a794af69ff3e598b35b43f83b2b5ef57b88f96ef62a0d6505d5fe7fef0401513c8ecf0dfcaa22e4575510acd3ece191901
+DIST boto3-1.15.4.tar.gz 335401 BLAKE2B 42ee1f2cf1e82338ea59a40b95aa5c76abae51aacf325ae845f407ccbc3caf1b3901bca48036889ad6307f96c257259cce39784a3f52ec6ff03c0c6c5633c654 SHA512 14626faa3943b65a215b8f1bce24f217e69421cdfd40caaf7de0fec13ca9b5b25c5e290c27672b2a6bc41316917224209110e2efd5be817de7273f93ae5764ce
diff --git a/dev-python/boto3/boto3-1.15.4.ebuild b/dev-python/boto3/boto3-1.15.4.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.15.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}