summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-01-11 20:47:08 -0500
committerCraig Andrews <candrews@gentoo.org>2020-01-11 20:48:43 -0500
commit3137d83964a18d395483dd75065c750459976fbe (patch)
treebd56ac6527e4fb1f2c34d740076326d642324671
parentapp-text/calibre: Revbump to 4.8.0-r1 for bug 602902 (diff)
downloadgentoo-3137d83964a18d395483dd75065c750459976fbe.tar.gz
gentoo-3137d83964a18d395483dd75065c750459976fbe.tar.bz2
gentoo-3137d83964a18d395483dd75065c750459976fbe.zip
net-p2p/cpuminer-opt: 3.11.3 version bump
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.11.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index c124d19986f1..57b642f22daf 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1,2 +1,3 @@
DIST cpuminer-opt-3.11.1.tar.gz 1924178 BLAKE2B 1ed7f07f89c94e7e15ac370e7873e5b37ec45c5b0132c3a8f2772558eb37666f1db41fbf78311f539d69f2b0858ef91478a9b1b469220e09fe07e20bd0147db3 SHA512 af6a70e0e60d7c6ab904fe29f37ba3f18327d9eb7b9700b53c28ca5d4f6693d124b01a9f382f608f4449f5a412ca57216bac354bc40d1793a1f1d40f7191dd7b
DIST cpuminer-opt-3.11.2.tar.gz 1923535 BLAKE2B 24ee1f4e64771ac1f007fd5934569e53959692f95dfd9fe4a7b38d4d32cbd4d5dd3731a285ad4e9e1e9bbbfd56a86bc9a69de9d5392d6d9a858a816ad031575f SHA512 bdbe99b358e37d8170259e5575f28d0b8c2e7faa6159b389f173e1a74299483ae6c5b2173f7565943f4c36e8e99d436ffbb485e3012f53337599d9dbd004b1b9
+DIST cpuminer-opt-3.11.3.tar.gz 1924724 BLAKE2B 1e0cd26b7400b1d09fcc74bcadedb7da478f8b0be9c4c8ad8ce097e0a4c438068214139e9eb4901f0fa80a3c997ff9bb802788198236aba418703bdfc5edd0f8 SHA512 fd061644b15b5d2e68bca949a67bc6d2eab53e5d309c4e0c6766ccea0e956f49229e385e582144ef2dadf805eeee30a16b7409df3aad3184d68eb03c32ef1258
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.11.3.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.11.3.ebuild
new file mode 100644
index 000000000000..a5d436b3b8b8
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.11.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}