summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-11-16 13:47:23 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-11-16 13:50:34 +0100
commit31410fe914ec4c7e1164e76cfda02090389d8eda (patch)
treee20a1db77f0d661958ccb4abf62985c74de959ef
parentsys-fs/android-file-transfer-linux: Bump to version 4.0 (diff)
downloadgentoo-31410fe914ec4c7e1164e76cfda02090389d8eda.tar.gz
gentoo-31410fe914ec4c7e1164e76cfda02090389d8eda.tar.bz2
gentoo-31410fe914ec4c7e1164e76cfda02090389d8eda.zip
sys-fs/android-file-transfer-linux: Synced live ebuild
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-fs/android-file-transfer-linux/android-file-transfer-linux-9999.ebuild46
1 files changed, 31 insertions, 15 deletions
diff --git a/sys-fs/android-file-transfer-linux/android-file-transfer-linux-9999.ebuild b/sys-fs/android-file-transfer-linux/android-file-transfer-linux-9999.ebuild
index 96cfef233539..3ef7155a7e2c 100644
--- a/sys-fs/android-file-transfer-linux/android-file-transfer-linux-9999.ebuild
+++ b/sys-fs/android-file-transfer-linux/android-file-transfer-linux-9999.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake xdg
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit cmake python-single-r1 xdg
DESCRIPTION="Android File Transfer for Linux"
HOMEPAGE="https://github.com/whoozle/android-file-transfer-linux"
@@ -19,21 +21,44 @@ fi
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="fuse qt5"
+IUSE="fuse libressl python qt5 taglib zune"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
sys-apps/file
sys-libs/readline:0=
fuse? ( sys-fs/fuse:0 )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ ')
+ )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
)
+ taglib? ( media-libs/taglib )
+ zune? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
"
DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
# required to override src_prepare from xdg eclass
src_prepare() {
cmake_src_prepare
@@ -42,23 +67,14 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DBUILD_FUSE="$(usex fuse)"
+ -DBUILD_MTPZ="$(usex zune)"
+ -DBUILD_PYTHON="$(usex python)"
-DBUILD_QT_UI="$(usex qt5)"
-DBUILD_SHARED_LIB="ON"
+ -DBUILD_TAGLIB="$(usex taglib)"
# Upstream recommends to keep this off as libusb is broken
-DUSB_BACKEND_LIBUSB="OFF"
$(usex qt5 '-DDESIRED_QT_VERSION=5' '')
)
cmake_src_configure
}
-
-pkg_preinst() {
- xdg_pkg_preinst
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
-}