summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-10 00:05:04 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-10 00:05:04 +0100
commit315629a9d94bef298b082be0f8fe561f5d0c8132 (patch)
tree859e6723d2f2f3990cdff327e6f34ce7dd49e9ed
parentmedia-gfx/transfig: Fix GCC10 -fno-common (diff)
downloadgentoo-315629a9d94bef298b082be0f8fe561f5d0c8132.tar.gz
gentoo-315629a9d94bef298b082be0f8fe561f5d0c8132.tar.bz2
gentoo-315629a9d94bef298b082be0f8fe561f5d0c8132.zip
dev-libs/liblist: Port to EAPI 7
Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-libs/liblist/liblist-2.4.ebuild39
1 files changed, 20 insertions, 19 deletions
diff --git a/dev-libs/liblist/liblist-2.4.ebuild b/dev-libs/liblist/liblist-2.4.ebuild
index 0133d56da438..928ed1b2bfa5 100644
--- a/dev-libs/liblist/liblist-2.4.ebuild
+++ b/dev-libs/liblist/liblist-2.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit autotools-utils multilib
+inherit autotools
DESCRIPTION="Generic linked-list manipulation routines, plus queues and stacks"
HOMEPAGE="http://ohnopub.net/liblist"
@@ -12,36 +12,37 @@ SRC_URI="ftp://ohnopublishing.net/mirror/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux"
-IUSE="doc examples static-libs"
+IUSE="doc examples"
-RDEPEND="doc? ( media-gfx/transfig
+RDEPEND="
+ doc? (
dev-texlive/texlive-metapost
- virtual/latex-base )"
+ media-gfx/transfig
+ virtual/latex-base
+ )"
DEPEND="${RDEPEND}"
src_configure() {
- local myeconfargs=(
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
- $(use_enable doc docs)
+ econf \
+ --disable-static \
+ $(use_enable doc docs) \
$(use_enable examples)
- )
-
- autotools-utils_src_configure
}
src_install() {
- autotools-utils_src_install
-
- dodoc README
+ default
if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/{*.c,Makefile,README}
- insinto /usr/share/doc/${PF}/examples/cache
- doins examples/cache/{*.c,README}
+ docinto examples
+ dodoc examples/{*.c,Makefile,README}
+ docinto examples/cache
+ dodoc examples/cache/{*.c,README}
fi
docompress -x /usr/share/doc/${PF}/{list.0,paper.dvi,examples}
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}
pkg_postinst() {