summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-29 14:18:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-29 14:18:46 +0200
commit31668103e13f82efd9bedbcd4365f9ea5850596f (patch)
tree7eec3a2e4725f6c658b9df54c85cfb33b5e33029
parentdev-python/werkzeug: Bump to 2.1.0 (diff)
downloadgentoo-31668103.tar.gz
gentoo-31668103.tar.bz2
gentoo-31668103.zip
dev-python/flask: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/flask/Manifest1
-rw-r--r--dev-python/flask/flask-2.1.0.ebuild58
-rw-r--r--dev-python/flask/flask-9999.ebuild19
3 files changed, 72 insertions, 6 deletions
diff --git a/dev-python/flask/Manifest b/dev-python/flask/Manifest
index 9f0e1e8fbd30..ea8224884dfb 100644
--- a/dev-python/flask/Manifest
+++ b/dev-python/flask/Manifest
@@ -2,3 +2,4 @@ DIST Flask-1.1.4.tar.gz 635920 BLAKE2B c1f19e7449177ecf6e901d5932ad25cbe866ff53b
DIST Flask-2.0.1.tar.gz 626851 BLAKE2B 05273edacd6d66237a552410df7ef7ff367e28c273cc89f654eac5ed2eb3d26f71437169905372b398cc6c5c5067dcbea54aa1cab782e03c6186ac9ae3949f4c SHA512 fefed4971f0542b25ba2867919aa54a83b6e3f47e7cee94586543843e7e00ba209ac15d8fe28a3c53981f587aebcf2f3915a49e1a9cd1b729099dccbed3783c2
DIST Flask-2.0.2.tar.gz 628479 BLAKE2B 13555ce0602e685b5fe29ba51e05534263d70440c56c9096e95e0893e010d877154d3d1db1bff47209e6b70e91612a71e8aed149a067465f9e3a11486d843a86 SHA512 341be4e453dd5f682e465af356ff85ffe76f52a62e529e6cd251f95199e73b0f93414af093f899f61721e9bb351f09972a433a55beacc972b5e577b86e003081
DIST Flask-2.0.3.tar.gz 629304 BLAKE2B dae5ffb86b9f57ea95c682be4f858faec6432c877695c06fff40a056cd7eedff25cf120458435b634954f0e65e57ad6c22c3eb6b5ed751b6d7f5d4501358c240 SHA512 b759ada3ab610d4893cd48f6de070c23929ab2e37af863238912fa19246acfb399b1e67576bf6112c9bb56b00002792d28c7538c65b026f31bcc6f64305ae966
+DIST Flask-2.1.0.tar.gz 630852 BLAKE2B 6a67d4c0f67aebf326493d86baefcdfb5d1e1b36a3b6a2e818d8bd92d84267ca8762ee0af3e70254bd4ce53a4f781edc9560e6408adf8ac285b308cdf1103c0f SHA512 8d9da72e3ad7df378a32fc40290e9499bc79eb3167235e8497f8f2753ac2c9da170d34f0ae3e87db99ba8282c887a479a64b680818b668bc13e033e6e5603926
diff --git a/dev-python/flask/flask-2.1.0.ebuild b/dev-python/flask/flask-2.1.0.ebuild
new file mode 100644
index 000000000000..eec62df569de
--- /dev/null
+++ b/dev-python/flask/flask-2.1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
+HOMEPAGE="https://github.com/pallets/flask/"
+MY_PN="Flask"
+MY_P="${MY_PN}-${PV}"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-2.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ test? (
+ >=dev-python/asgiref-3.2[${PYTHON_USEDEP}]
+ !!dev-python/shiboken2
+ )"
+
+distutils_enable_sphinx docs \
+ dev-python/pallets-sphinx-themes \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-tabs \
+ dev-python/sphinxcontrib-log_cabinet
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:httpbin
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask/flask-9999.ebuild b/dev-python/flask/flask-9999.ebuild
index feea1195fdd3..eec62df569de 100644
--- a/dev-python/flask/flask-9999.ebuild
+++ b/dev-python/flask/flask-9999.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
@@ -15,7 +17,7 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
else
SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
S="${WORKDIR}/${MY_P}"
fi
@@ -24,14 +26,19 @@ SLOT="0"
IUSE="examples"
RDEPEND="
- >=dev-python/click-7.1.2[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
dev-python/blinker[${PYTHON_USEDEP}]
>=dev-python/itsdangerous-2.0[${PYTHON_USEDEP}]
>=dev-python/jinja-3.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-2.0[${PYTHON_USEDEP}]"
+ >=dev-python/werkzeug-2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
BDEPEND="
test? (
>=dev-python/asgiref-3.2[${PYTHON_USEDEP}]
+ !!dev-python/shiboken2
)"
distutils_enable_sphinx docs \