summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-08 06:36:25 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-08 06:37:40 +0100
commit31839896169ff8acca56e79ef1841bdadea3d18c (patch)
treebc3cb8b2e9cecc096b7ba1eacd64b64b0e37a4fa
parentdev-python/googleapis-common-protos: Bump to 1.54.0 (diff)
downloadgentoo-31839896169ff8acca56e79ef1841bdadea3d18c.tar.gz
gentoo-31839896169ff8acca56e79ef1841bdadea3d18c.tar.bz2
gentoo-31839896169ff8acca56e79ef1841bdadea3d18c.zip
dev-python/pillow: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pillow/Manifest1
-rw-r--r--dev-python/pillow/pillow-8.3.2.ebuild98
2 files changed, 0 insertions, 99 deletions
diff --git a/dev-python/pillow/Manifest b/dev-python/pillow/Manifest
index 4c0124ee7f42..9b17beaaf8f8 100644
--- a/dev-python/pillow/Manifest
+++ b/dev-python/pillow/Manifest
@@ -1,2 +1 @@
-DIST pillow-8.3.2.tar.gz 48783084 BLAKE2B c63930df3af0270bb092841b3c39a1ea75343ee743f9e4b083a2f6f621ad1e58c7c04c5d6cf4b648fbef2d79d7b5258e27d220cd32dbfff592b5ca70d1f28d64 SHA512 668e97abcd36e42dafa433e8814a0106fe742ab093b12748c13dd9f3f872d18f8b9d44c1a8d4115aa87969a98b53c36ae4783cc3804e2d9a1249eef300555c88
DIST pillow-8.4.0.tar.gz 49364586 BLAKE2B f6a0fbafc0869c952bf88ad96146f27cf70c5680f372763bc9989cc49515bc74886a9d7648114797880ca06defc79e2e50d7ecf36bfa7adbd969450615ac0bd1 SHA512 d395f69ccb37c52a3b6f45836700ffbc3173afae31848cc61d7b47db88ca1594541023beb9a14fd9067aca664e182c7d6e3300ab3e3095c31afe8dcbc6e08233
diff --git a/dev-python/pillow/pillow-8.3.2.ebuild b/dev-python/pillow/pillow-8.3.2.ebuild
deleted file mode 100644
index 31930eb7c91d..000000000000
--- a/dev-python/pillow/pillow-8.3.2.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-PYTHON_REQ_USE='tk?,threads(+)'
-
-inherit distutils-r1 toolchain-funcs virtualx
-
-MY_PN=Pillow
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python Imaging Library (fork)"
-HOMEPAGE="https://python-pillow.org/"
-SRC_URI="https://github.com/python-pillow/Pillow/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-IUSE="examples imagequant +jpeg jpeg2k lcms test tiff tk truetype webp xcb zlib"
-REQUIRED_USE="test? ( jpeg jpeg2k tiff truetype )"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- imagequant? ( media-gfx/libimagequant:0 )
- jpeg? ( virtual/jpeg:0 )
- jpeg2k? ( media-libs/openjpeg:2= )
- lcms? ( media-libs/lcms:2= )
- tiff? ( media-libs/tiff:0=[jpeg,zlib] )
- truetype? ( media-libs/freetype:2= )
- webp? ( media-libs/libwebp:0= )
- xcb? ( x11-libs/libxcb )
- zlib? ( sys-libs/zlib:0= )"
-RDEPEND="${DEPEND}
- dev-python/olefile[${PYTHON_USEDEP}]"
-BDEPEND="
- virtual/pkgconfig
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- || (
- media-gfx/imagemagick[png]
- media-gfx/graphicsmagick[png]
- )
- )
-"
-
-python_configure_all() {
- # It's important that these flags are also passed during the install phase
- # as well. Make sure of that if you change the lines below. See bug 661308.
- DISTUTILS_ARGS=(
- build_ext
- --disable-platform-guessing
- $(use_enable truetype freetype)
- $(use_enable jpeg)
- $(use_enable jpeg2k jpeg2000)
- $(use_enable lcms)
- $(use_enable tiff)
- $(use_enable imagequant)
- $(use_enable webp)
- $(use_enable webp webpmux)
- $(use_enable xcb)
- $(use_enable zlib)
- )
-
- # setup.py sucks at adding the right toolchain paths but it does
- # accept additional ones from INCLUDE and LIB so set these. You
- # wouldn't normally need these at all as the toolchain should look
- # here anyway but this setup.py does stupid things.
- export \
- INCLUDE=${ESYSROOT}/usr/include \
- LIB=${ESYSROOT}/usr/$(get_libdir)
-
- # We have patched in this env var.
- tc-export PKG_CONFIG
-}
-
-python_test() {
- "${EPYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
- # no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
- virtx epytest -p no:relaxed
-}
-
-python_install() {
- python_doheader src/libImaging/*.h
- distutils-r1_python_install
-}
-
-python_install_all() {
- if use examples ; then
- docinto example
- dodoc docs/example/*
- docompress -x /usr/share/doc/${PF}/example
- fi
- distutils-r1_python_install_all
-}