summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-12-12 14:31:09 -0500
committerMatt Turner <mattst88@gentoo.org>2022-12-12 20:22:24 -0500
commit31ca68772ee946656f301d35a941c29590612a5b (patch)
tree80052a16e5c975e4d40e20f570e9960957505097
parentsys-kernel/zen-sources: add 6.0.12 (diff)
downloadgentoo-31ca68772ee946656f301d35a941c29590612a5b.tar.gz
gentoo-31ca68772ee946656f301d35a941c29590612a5b.tar.bz2
gentoo-31ca68772ee946656f301d35a941c29590612a5b.zip
media-video/cheese: Version bump to 43.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-video/cheese/Manifest1
-rw-r--r--media-video/cheese/cheese-43.0.ebuild100
-rw-r--r--media-video/cheese/files/cheese-43.0-buildfix.patch20
3 files changed, 121 insertions, 0 deletions
diff --git a/media-video/cheese/Manifest b/media-video/cheese/Manifest
index fda8b5ce5545..fa260c5eaa37 100644
--- a/media-video/cheese/Manifest
+++ b/media-video/cheese/Manifest
@@ -1 +1,2 @@
DIST cheese-41.1.tar.xz 1092912 BLAKE2B 9bbfbc59868f39b344b1102f819ca647d82e9dee327f1d2a2e6b30fcfd2c59dd5f79236355d7148e01a4b07d80d630406708d2a152535b5732cfb52690f9f402 SHA512 2c0922dda97f4ce701add45977b405eff9ddbc24eb286e9e05a9f9bfbd7998e8e77ef2a8f1bbce9f8349ff522ee3cb6d6566fa5df80d782e6d844bff69a30074
+DIST cheese-43.0.tar.xz 1095328 BLAKE2B 728cf913336f09ae073508d6bf18f7bb0cf4bb0e16ad5d6acd5fb77b75577303b1a2d8820b280a31c15ebdcbf231205881440105c390a0f16681dc5274a74446 SHA512 07ed087490b4024ecbc097c1a62e24fdc0c5c8acac23ba3ed246104655a8b1786faee5caa5e59cfa7b725527b5aedc587b0f99a2b43100497f866966818e345e
diff --git a/media-video/cheese/cheese-43.0.ebuild b/media-video/cheese/cheese-43.0.ebuild
new file mode 100644
index 000000000000..354d62a26bd6
--- /dev/null
+++ b/media-video/cheese/cheese-43.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson vala virtualx xdg
+
+DESCRIPTION="A cheesy program to take pictures and videos from your webcam"
+HOMEPAGE="https://wiki.gnome.org/Apps/Cheese"
+
+LICENSE="GPL-2+"
+SLOT="0/8" # subslot = libcheese soname version
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gtk-doc +introspection test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=media-libs/clutter-1.13.2:1.0[introspection?]
+ media-libs/clutter-gst:3.0
+ >=media-libs/clutter-gtk-0.91.8:1.0
+ x11-libs/gdk-pixbuf:2[jpeg,introspection?]
+ >=dev-libs/glib-2.39.90:2
+ >=gnome-base/gnome-desktop-2.91.6:3=
+ >=media-libs/gstreamer-1.4:1.0[introspection?]
+ >=media-libs/gst-plugins-base-1.4:1.0[ogg,pango,theora,vorbis]
+ >=media-libs/gst-plugins-bad-1.4:1.0
+ >=x11-libs/gtk+-3.13.4:3
+ >=media-libs/libcanberra-0.26[gtk3]
+ x11-libs/libX11
+ sys-apps/dbus
+ media-video/gnome-video-effects
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+
+ media-libs/cogl:1.0=[introspection?]
+
+"
+RDEPEND="${DEPEND}
+ >=media-libs/gst-plugins-good-1.4:1.0
+
+ >=media-plugins/gst-plugins-jpeg-1.4:1.0
+ || (
+ >=media-plugins/gst-plugins-v4l2-1.4:1.0
+ media-video/pipewire[gstreamer,v4l]
+ )
+ >=media-plugins/gst-plugins-vpx-1.4:1.0
+"
+
+BDEPEND="
+ gtk-doc? ( dev-util/gtk-doc )
+ dev-libs/libxslt
+ app-text/docbook-xml-dtd:4.3
+ dev-util/itstool
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ test? ( x11-libs/libXtst )
+ $(vala_depend)
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-43.0-buildfix.patch
+)
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ $(meson_use test tests)
+ -Dman=true
+ )
+
+ meson_src_configure
+
+ # Hack: version.xml is not generated if gtk-doc is not enabled
+ echo ${PV} > docs/reference/version.xml
+}
+
+src_test() {
+ gnome2_environment_reset # Avoid dconf that looks at XDG_DATA_DIRS, which can sandbox fail if flatpak is installed
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/media-video/cheese/files/cheese-43.0-buildfix.patch b/media-video/cheese/files/cheese-43.0-buildfix.patch
new file mode 100644
index 000000000000..25cd98362eb8
--- /dev/null
+++ b/media-video/cheese/files/cheese-43.0-buildfix.patch
@@ -0,0 +1,20 @@
+diff --git a/meson.build b/meson.build
+index 9174b428..c8d489cc 100644
+--- a/meson.build
++++ b/meson.build
+@@ -149,11 +149,7 @@ gnome_video_effects_dep = dependency(
+ # Recommend some runtime GStreamer plugins.
+ gst_inspect = find_program('gst-inspect-1.0', required: false)
+ if gst_inspect.found()
+- foreach plugin: ['camerabin', 'vp8enc', 'webmmux']
+- if run_command(gst_inspect, plugin, check: false).returncode() != 0
+- warning(plugin + ' was not found. It needs to be installed before Cheese is run')
+- endif
+- endforeach
++ warning('unable to check for runtime GStreamer plugin dependencies due to Gentoo\'s sandbox: camerabin, vp8enc, webmmux')
+ else
+ warning('unable to check for runtime GStreamer plugin dependencies')
+ endif
+--
+2.37.4
+