summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-22 22:12:53 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-22 22:33:21 +0100
commit3247453a9b2a104949919e3d57e28b9c91b6b68a (patch)
tree2ee39e1b1818e0aed139b5a0c9b68ceb5e4edac9
parentdev-python/cfn-python-lint: Bump to 0.48.0 (diff)
downloadgentoo-3247453a9b2a104949919e3d57e28b9c91b6b68a.tar.gz
gentoo-3247453a9b2a104949919e3d57e28b9c91b6b68a.tar.bz2
gentoo-3247453a9b2a104949919e3d57e28b9c91b6b68a.zip
dev-python/setuptools: Bump to 54.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-54.2.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index 0437871e994e..3ab3aae592fb 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -2,3 +2,4 @@ DIST setuptools-53.0.0.tar.gz 2050503 BLAKE2B b1ebe5a9776917fe9a21a13a4db613fd05
DIST setuptools-53.1.0.tar.gz 2051159 BLAKE2B f4148df45f5c62acd6acae833619dcae50f131da91ece1a2e1231620d4800294f14dab6c72ca5b2ffd31191c4e3306a869abdba349adcec5746600fc067b340d SHA512 0ca02e9b997623268d8f73b73ee6a4b1ad513802cbc75c74124a85bd5ca7bfaea5cf7cccb706334c0dac2c8a0674a5bc2cea10f44f99f881ad893c8337af3da2
DIST setuptools-54.1.1.tar.gz 2053415 BLAKE2B 59d60e9be5a184e34e8c9e1ccb477eae538836c8fac4862f3365e1abe8beec6cc85490918d413b29831c4d3738ca19cd84ac4a9d30178e45e42c652a0ade5fac SHA512 d2ab5445a9b4de5b5fae8aab6a47131ad41a011fa23fb1e6c07a599bcb27a8f89ea3c5ea9939577d6286bf3f8e2edf0334816ae1a507dba09c46435d063c3379
DIST setuptools-54.1.2.tar.gz 2053508 BLAKE2B 23958ab6bc8ac5681fb4a86217b893f5389be1afc9e71f77a3aaaca469e3f86117e55f9df8f864ae56059ef6aef054a6a5ce8d6670a5ce266de6322b820e68d7 SHA512 b6efe6e92227704a95d4d4a31d033df6df96a430d7e51cb7df80203af56d8f8f64c95deaf194c7cfbfd2111f5bc02be45db2c0383c3209c898c1858821eb4642
+DIST setuptools-54.2.0.tar.gz 2054279 BLAKE2B 2a52e76808fb2bc6df4c59ac7476a9386401180ff6c0d52a5f3d87aedf976a3057cfa0a7ddf2a4497c4c1552d5ebe4810c4bbfa127e1293f950054bddbf7d835 SHA512 b18cd075cf59b8648611eef1874de41199ede6ffe6d7f5047586c6ac8783fe18b9a4f537783e590e7aec127033f612b93925e92f039bd6416a609fcfb262e354
diff --git a/dev-python/setuptools/setuptools-54.2.0.ebuild b/dev-python/setuptools/setuptools-54.2.0.ebuild
new file mode 100644
index 000000000000..533095efb380
--- /dev/null
+++ b/dev-python/setuptools/setuptools-54.2.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+# Set to 'manual' to avoid triggering install QA check
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/jaraco-envs[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-path-3.2.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst )
+
+python_test() {
+ distutils_install_for_testing --via-root
+ local deselect=(
+ # network
+ 'setuptools/tests/test_virtualenv.py::test_pip_upgrade_from_source[None]'
+ setuptools/tests/test_distutils_adoption.py
+ # TODO
+ setuptools/tests/test_easy_install.py::TestSetupRequires::test_setup_requires_with_allow_hosts
+ # this one's unhappy about pytest-xdist but one test is not worth
+ # losing the speed gain
+ setuptools/tests/test_build_meta.py::TestBuildMetaBackend::test_build_sdist_relative_path_import
+ )
+
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" pytest -vv ${deselect[@]/#/--deselect } \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" \
+ setuptools || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}