summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-06-10 14:11:58 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-06-10 14:11:58 -0400
commit3361bc490612a7bd8e1e3cf1393e684b77066466 (patch)
tree9b12f13aab7bf0ca718468cea4fa88edad983f8b
parentdev-util/valgrind: 3.12.0 stable on arm and x86 (diff)
downloadgentoo-3361bc490612a7bd8e1e3cf1393e684b77066466.tar.gz
gentoo-3361bc490612a7bd8e1e3cf1393e684b77066466.tar.bz2
gentoo-3361bc490612a7bd8e1e3cf1393e684b77066466.zip
dev-util/valgrind: remove older versions, bug #618382
Package-Manager: Portage-2.3.5, Repoman-2.3.1
-rw-r--r--dev-util/valgrind/Manifest2
-rw-r--r--dev-util/valgrind/valgrind-3.10.1.ebuild117
-rw-r--r--dev-util/valgrind/valgrind-3.11.0.ebuild102
3 files changed, 0 insertions, 221 deletions
diff --git a/dev-util/valgrind/Manifest b/dev-util/valgrind/Manifest
index 4af5f23e2f11..e54eaa291a1f 100644
--- a/dev-util/valgrind/Manifest
+++ b/dev-util/valgrind/Manifest
@@ -1,3 +1 @@
-DIST valgrind-3.10.1.tar.bz2 10967905 SHA256 fa253dc26ddb661b6269df58144eff607ea3f76a9bcfe574b0c7726e1dfcb997 SHA512 8f3d27637c13b06381b3dd44088244e0cf2f7008f40e46f34322f2a5bfa6373d29ce68ff49f19c48f1a5f139d8be5838b9606206e0ce2599c5f74c0db8ce2642 WHIRLPOOL 3d55f35b02195d9859d9192726ea708277f1d3339005d959baa224822c5b71f5347cdd28c7fd8153c10d1e3282855e853caf9c7192751bebdbbc3444c33d885a
-DIST valgrind-3.11.0.tar.bz2 11910809 SHA256 6c396271a8c1ddd5a6fb9abe714ea1e8a86fce85b30ab26b4266aeb4c2413b42 SHA512 a25f97fa80aef4ad1e86b303886cd7a97aac248820a4c24e3d3dc26567dd7d2d86db237866468fd43885a9fb8534cb0a8e301a3c752fffbc231a2842272999da WHIRLPOOL a881df25e64789954d9bcb44617fd92d832ae9953689c01f8f79d737379c523a6f3a8125283518a6f256770a5c4f204b7b859794cf714abb0a742a69b272ef0e
DIST valgrind-3.12.0.tar.bz2 12788556 SHA256 67ca4395b2527247780f36148b084f5743a68ab0c850cb43e4a5b4b012cf76a1 SHA512 2c083f7c2e74dc58600397726d9d3af7a2cea40fe3d8733149886d1d77867e6c09996e5be1c58dd932f3662acf7363e04eeadbc0f9c8f0dac089e605024229be WHIRLPOOL 136dd4f358bd18165a5801083cc73fc269a84bf491880af9842e789feea62181e16ca4c099db06fb4ffacf0cb0189b1b29d64790cc4202442f6f6b71ce4c6eea
diff --git a/dev-util/valgrind/valgrind-3.10.1.ebuild b/dev-util/valgrind/valgrind-3.10.1.ebuild
deleted file mode 100644
index 37b51b87fa25..000000000000
--- a/dev-util/valgrind/valgrind-3.10.1.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-inherit autotools eutils flag-o-matic toolchain-funcs multilib pax-utils
-
-DESCRIPTION="An open-source memory debugger for GNU/Linux"
-HOMEPAGE="http://www.valgrind.org"
-SRC_URI="http://www.valgrind.org/downloads/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* amd64 arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="mpi"
-
-DEPEND="mpi? ( virtual/mpi )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- # Correct hard coded doc location
- sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die
-
- # Don't force multiarch stuff on OSX, bug #306467
- sed -i -e 's:-arch \(i386\|x86_64\)::g' Makefile.all.am || die
-
- # Respect CFLAGS, LDFLAGS
- epatch "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
-
- # Changing Makefile.all.am to disable SSP
- epatch "${FILESDIR}"/${PN}-3.7.0-fno-stack-protector.patch
-
- # Yet more local labels, this time for ppc32 & ppc64
- epatch "${FILESDIR}"/${PN}-3.6.0-local-labels.patch
-
- # Don't build in empty assembly files for other platforms or we'll get a QA
- # warning about executable stacks.
- epatch "${FILESDIR}"/${PN}-3.10.1-non-exec-stack.patch
-
- # glibc 2.19 fix
- epatch "${FILESDIR}"/${PN}-3.9.0-glibc-2.19.patch
-
- # valgrind works fine on linux-4, bug #543648
- epatch "${FILESDIR}"/${PN}-3.10.1-linux-4.patch
-
- # glibc 2.21 fix. Bug #554808.
- epatch "${FILESDIR}"/${PN}-3.10.1-glibc-2.21.patch
-
- # glibc 2.22 fix. Bug #580092
- epatch "${FILESDIR}"/${PN}-3.10.1-glibc-2.22.patch
-
- # Allow users to test their own patches
- epatch_user
-
- # Regenerate autotools files
- eautoreconf
-}
-
-src_configure() {
- local myconf
-
- # Respect ar, bug #468114
- tc-export AR
-
- # -fomit-frame-pointer "Assembler messages: Error: junk `8' after expression"
- # while compiling insn_sse.c in none/tests/x86
- # -fpie valgrind seemingly hangs when built with pie on
- # amd64 (bug #102157)
- # -fstack-protector more undefined references to __guard and __stack_smash_handler
- # because valgrind doesn't link to glibc (bug #114347)
- # -m64 -mx32 for multilib-portage, bug #398825
- # -ggdb3 segmentation fault on startup
- filter-flags -fomit-frame-pointer
- filter-flags -fpie
- filter-flags -fstack-protector
- filter-flags -m64 -mx32
- replace-flags -ggdb3 -ggdb2
-
- if use amd64 || use ppc64; then
- ! has_multilib_profile && myconf="${myconf} --enable-only64bit"
- fi
-
- # Force bitness on darwin, bug #306467
- use x86-macos && myconf="${myconf} --enable-only32bit"
- use x64-macos && myconf="${myconf} --enable-only64bit"
-
- # Don't use mpicc unless the user asked for it (bug #258832)
- if ! use mpi; then
- myconf="${myconf} --without-mpicc"
- fi
-
- econf ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS FAQ.txt NEWS README*
-
- pax-mark m "${ED}"/usr/$(get_libdir)/valgrind/*-*-linux
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- # fix install_names on shared libraries, can't turn them into bundles,
- # as dyld won't load them any more then, bug #306467
- local l
- for l in "${ED}"/usr/lib/valgrind/*.so ; do
- install_name_tool -id "${EPREFIX}"/usr/lib/valgrind/${l##*/} "${l}"
- done
- fi
-}
-
-pkg_postinst() {
- elog "Valgrind will not work if glibc does not have debug symbols."
- elog "To fix this you can add splitdebug to FEATURES in make.conf"
- elog "and remerge glibc. See:"
- elog "https://bugs.gentoo.org/show_bug.cgi?id=214065"
- elog "https://bugs.gentoo.org/show_bug.cgi?id=274771"
- elog "https://bugs.gentoo.org/show_bug.cgi?id=388703"
-}
diff --git a/dev-util/valgrind/valgrind-3.11.0.ebuild b/dev-util/valgrind/valgrind-3.11.0.ebuild
deleted file mode 100644
index 064f668d01b7..000000000000
--- a/dev-util/valgrind/valgrind-3.11.0.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-inherit autotools eutils flag-o-matic toolchain-funcs multilib pax-utils
-
-DESCRIPTION="An open-source memory debugger for GNU/Linux"
-HOMEPAGE="http://www.valgrind.org"
-SRC_URI="http://www.valgrind.org/downloads/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="mpi"
-
-DEPEND="mpi? ( virtual/mpi )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- # Correct hard coded doc location
- sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die
-
- # Don't force multiarch stuff on OSX, bug #306467
- sed -i -e 's:-arch \(i386\|x86_64\)::g' Makefile.all.am || die
-
- # Respect CFLAGS, LDFLAGS
- epatch "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
-
- # Changing Makefile.all.am to disable SSP
- epatch "${FILESDIR}"/${PN}-3.7.0-fno-stack-protector.patch
-
- # Yet more local labels, this time for ppc32 & ppc64
- epatch "${FILESDIR}"/${PN}-3.6.0-local-labels.patch
-
- # Don't build in empty assembly files for other platforms or we'll get a QA
- # warning about executable stacks.
- epatch "${FILESDIR}"/${PN}-3.11.0-non-exec-stack.patch
-
- # Allow users to test their own patches
- epatch_user
-
- # Regenerate autotools files
- eautoreconf
-}
-
-src_configure() {
- local myconf
-
- # Respect ar, bug #468114
- tc-export AR
-
- # -fomit-frame-pointer "Assembler messages: Error: junk `8' after expression"
- # while compiling insn_sse.c in none/tests/x86
- # -fstack-protector more undefined references to __guard and __stack_smash_handler
- # because valgrind doesn't link to glibc (bug #114347)
- # -m64 -mx32 for multilib-portage, bug #398825
- # -ggdb3 segmentation fault on startup
- filter-flags -fomit-frame-pointer
- filter-flags -fstack-protector
- filter-flags -m64 -mx32
- replace-flags -ggdb3 -ggdb2
-
- if use amd64 || use ppc64; then
- ! has_multilib_profile && myconf="${myconf} --enable-only64bit"
- fi
-
- # Force bitness on darwin, bug #306467
- use x86-macos && myconf="${myconf} --enable-only32bit"
- use x64-macos && myconf="${myconf} --enable-only64bit"
-
- # Don't use mpicc unless the user asked for it (bug #258832)
- if ! use mpi; then
- myconf="${myconf} --without-mpicc"
- fi
-
- econf ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS FAQ.txt NEWS README*
-
- pax-mark m "${ED}"/usr/$(get_libdir)/valgrind/*-*-linux
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- # fix install_names on shared libraries, can't turn them into bundles,
- # as dyld won't load them any more then, bug #306467
- local l
- for l in "${ED}"/usr/lib/valgrind/*.so ; do
- install_name_tool -id "${EPREFIX}"/usr/lib/valgrind/${l##*/} "${l}"
- done
- fi
-}
-
-pkg_postinst() {
- elog "Valgrind will not work if glibc does not have debug symbols."
- elog "To fix this you can add splitdebug to FEATURES in make.conf"
- elog "and remerge glibc. See:"
- elog "https://bugs.gentoo.org/show_bug.cgi?id=214065"
- elog "https://bugs.gentoo.org/show_bug.cgi?id=274771"
- elog "https://bugs.gentoo.org/show_bug.cgi?id=388703"
-}