summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2018-01-05 13:47:34 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2018-01-05 13:47:58 -0500
commit33d8979b7c7a2d634f66221aac3a616dc831ccc7 (patch)
tree9cb8fa0d1b8d2aed7c1794d48d9499cb18c9898d
parentapp-emulation/wine: Test LINGUAS rather than linguas_* USE flags. (diff)
downloadgentoo-33d8979b7c7a2d634f66221aac3a616dc831ccc7.tar.gz
gentoo-33d8979b7c7a2d634f66221aac3a616dc831ccc7.tar.bz2
gentoo-33d8979b7c7a2d634f66221aac3a616dc831ccc7.zip
app-crypt/libu2f-server: bump to 1.1.0, introduce a subslot
Package-Manager: Portage-2.3.13, Repoman-2.3.3
-rw-r--r--app-crypt/libu2f-server/Manifest1
-rw-r--r--app-crypt/libu2f-server/files/libu2f-server-1.1.0-disable-help2man-gengetopt-checks.patch37
-rw-r--r--app-crypt/libu2f-server/libu2f-server-1.1.0.ebuild51
-rw-r--r--app-crypt/libu2f-server/metadata.xml3
4 files changed, 92 insertions, 0 deletions
diff --git a/app-crypt/libu2f-server/Manifest b/app-crypt/libu2f-server/Manifest
index 456be3961ce3..0c6a1457ec05 100644
--- a/app-crypt/libu2f-server/Manifest
+++ b/app-crypt/libu2f-server/Manifest
@@ -1 +1,2 @@
DIST libu2f-server-1.0.1.tar.xz 268648 BLAKE2B 9c6c2e5bafb2a95fcc5c2773de49b4db197ee6283e90cf0e4e62ff3982bdde8a51635cd9771e4dd35d27c71634367197d3b01b9c26d8a3847fccf1daf676f04b SHA512 51020722f49f787c793808b667e91923bde46e9137bfe5065106f83bcdb678e8d11cca12cb605d9622cafc15a9794c9080cf08e2a704293a791ab6f27ac47f47
+DIST libu2f-server-1.1.0.tar.xz 269128 BLAKE2B 084b177a878e8216f2ee5af9eeee11e691edcd12b7ed1b1c57f74bcc45f0418a0d44a9e72423c41b4104aa9f69807a0289172d08d21d168c6be5b36ee8c70bc3 SHA512 ebdb7c8c20727f37f4e31d8f16df7966603374f78478ada723a7b9bec1b0b0622caf6d12a65067ac8651f6088aaad61b2ad6ed51b9d6ef0dc45f031c974d8ff9
diff --git a/app-crypt/libu2f-server/files/libu2f-server-1.1.0-disable-help2man-gengetopt-checks.patch b/app-crypt/libu2f-server/files/libu2f-server-1.1.0-disable-help2man-gengetopt-checks.patch
new file mode 100644
index 000000000000..2dbe28b5aa68
--- /dev/null
+++ b/app-crypt/libu2f-server/files/libu2f-server-1.1.0-disable-help2man-gengetopt-checks.patch
@@ -0,0 +1,37 @@
+Reverted, removed the second hunk about dev-libs/check, and further
+adjusted. The tarball already contains the man page and gengetopt
+generated command line parsing, so these checks are useless to us.
+
+From fbd340d1c777e23b66ef27ce1c03c4eb3bafc511 Mon Sep 17 00:00:00 2001
+From: Thordur Bjornsson <thorduri@yubico.com>
+Date: Thu, 12 Jan 2017 14:28:31 +0100
+Subject: [PATCH] auto: Check for help2man/gengetopt, and bail out if not
+ found.
+
+Both are required to build.
+
+While here, if `--enable-tests` passed, check for `check` and
+if not found, bail out as well.
+---
+ configure.ac | 11 +++++++++--
+ 1 file changed, 9 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index ad409a2..6decb78 100644
+--- b/configure.ac
++++ a/configure.ac
+@@ -43,14 +43,7 @@
+ LT_INIT([win32-dll])
+
+ AM_MISSING_PROG(HELP2ADOC, help2adoc, $missing_dir)
+ AM_MISSING_PROG(HELP2MAN, help2man, $missing_dir)
+-if ! which help2man >/dev/null ; then
+- AC_MSG_ERROR([help2man missing])
+-fi
+-if ! which gengetopt >/dev/null ; then
+- AC_MSG_ERROR([gengetopt missing])
+-fi
+-
+ gl_LD_VERSION_SCRIPT
+
+ PKG_CHECK_MODULES([LIBJSON], [json-c], [], [
diff --git a/app-crypt/libu2f-server/libu2f-server-1.1.0.ebuild b/app-crypt/libu2f-server/libu2f-server-1.1.0.ebuild
new file mode 100644
index 000000000000..b2ada443d400
--- /dev/null
+++ b/app-crypt/libu2f-server/libu2f-server-1.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Yubico Universal 2nd Factor (U2F) server C Library"
+HOMEPAGE="https://developers.yubico.com/libu2f-server/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0/0.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl static-libs test"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+ dev-libs/hidapi[${MULTILIB_USEDEP}]
+ dev-libs/json-c:=[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-libs/check[${MULTILIB_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1.0-disable-help2man-gengetopt-checks.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+ touch man/u2f-server.1 || die # do not rebuild the man page
+}
+
+multilib_src_configure() {
+ myeconfargs=(
+ --disable-h2a # tarball already contains the manpage
+ $(use_enable static-libs static)
+ $(use_enable test tests)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-crypt/libu2f-server/metadata.xml b/app-crypt/libu2f-server/metadata.xml
index 2d0a0e34de1c..2c6ea3e58924 100644
--- a/app-crypt/libu2f-server/metadata.xml
+++ b/app-crypt/libu2f-server/metadata.xml
@@ -9,4 +9,7 @@
<email>gokturk@gentoo.org</email>
<name>Göktürk Yüksek</name>
</maintainer>
+ <slots>
+ <subslots>Reflects ABI compatibility for libu2f-server.so</subslots>
+ </slots>
</pkgmetadata>