summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-12-22 10:47:01 +0100
committerJeroen Roovers <jer@gentoo.org>2019-12-22 10:48:04 +0100
commit34113dd9d30673c1bae70ee2866324e5abbef926 (patch)
tree820507858d9e4a8b6ef19d3d1a06bb62e14eb395
parentx11-themes/gkrellm-themes: Use consolidated tarball from upstream. (diff)
downloadgentoo-34113dd9d30673c1bae70ee2866324e5abbef926.tar.gz
gentoo-34113dd9d30673c1bae70ee2866324e5abbef926.tar.bz2
gentoo-34113dd9d30673c1bae70ee2866324e5abbef926.zip
Revert "dev-util/redo: Update PYTHON_COMPAT"
>>> Compiling source in /home/jer/portage/net-libs/wvstreams-99999/work/wvstreams-99999 ... Traceback (most recent call last): File "/usr/bin/redo", line 8, in <module> import redo.cmd_redo File "/usr/bin/../lib/redo/cmd_redo.py", line 51 print version.TAG ^ SyntaxError: Missing parentheses in call to 'print'. Did you mean print(version.TAG)? This reverts commit 79802ff71e24c576f500de4ea9c6e9c94200e623. Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--dev-util/redo/redo-0.42.ebuild (renamed from dev-util/redo/redo-0.42-r1.ebuild)4
-rw-r--r--dev-util/redo/redo-99999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/dev-util/redo/redo-0.42-r1.ebuild b/dev-util/redo/redo-0.42.ebuild
index e31dd3b2e368..a979123b762f 100644
--- a/dev-util/redo/redo-0.42-r1.ebuild
+++ b/dev-util/redo/redo-0.42.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="sqlite"
inherit multilib multiprocessing python-single-r1
@@ -40,7 +40,7 @@ src_install() {
./do -j$(makeopts_jobs) \
install || die
- python_fix_shebang --force "${D}"
+ python_fix_shebang "${D}"
sed -i \
-e 's|/lib/|/'"$(get_libdir)"'/|g' \
diff --git a/dev-util/redo/redo-99999.ebuild b/dev-util/redo/redo-99999.ebuild
index 0e2e3fc04077..30c70257c019 100644
--- a/dev-util/redo/redo-99999.ebuild
+++ b/dev-util/redo/redo-99999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="sqlite"
inherit git-r3 multilib multiprocessing python-single-r1
@@ -40,7 +40,7 @@ src_install() {
./do -j$(makeopts_jobs) \
install || die
- python_fix_shebang --force "${ED}"
+ python_fix_shebang "${D}"
sed -i \
-e 's|/lib/|/'"$(get_libdir)"'/|g' \