summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2021-09-14 01:27:44 +0200
committerTobias Klausmann <klausman@gentoo.org>2021-09-14 22:15:04 +0200
commit3434fdb7c1eba3721771dece9523b70d9775bbe1 (patch)
treebd104f8f7aacb0ebb57926327e77ad501b72170d
parentdev-db/timescaledb: Bump to 2.4.1 (diff)
downloadgentoo-3434fdb7c1eba3721771dece9523b70d9775bbe1.tar.gz
gentoo-3434fdb7c1eba3721771dece9523b70d9775bbe1.tar.bz2
gentoo-3434fdb7c1eba3721771dece9523b70d9775bbe1.zip
net-ftp/atftp: version bump to 0.7.5
Version 0.7.5 (Bugfix, Security Fix Release) fix many bugs, fix denial-of-service buffer overflow CVE-2021-41054 new feature: add an option to prevent the Sorcerer's Apprentice Syndrome Closes: https://bugs.gentoo.org/813079 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
-rw-r--r--net-ftp/atftp/Manifest1
-rw-r--r--net-ftp/atftp/atftp-0.7.5.ebuild66
-rw-r--r--net-ftp/atftp/files/atftp-0.7.5-CFLAGS.patch32
3 files changed, 99 insertions, 0 deletions
diff --git a/net-ftp/atftp/Manifest b/net-ftp/atftp/Manifest
index 787aa4f6ca33..1002d6b53aa7 100644
--- a/net-ftp/atftp/Manifest
+++ b/net-ftp/atftp/Manifest
@@ -1 +1,2 @@
DIST atftp-0.7.4.tar.gz 249699 BLAKE2B 8aa30df1cc92982b0e718cd9bcc68cf397e29f6abb795cf9fdfd0b9942d9a7dd16beafb24d69d7339f9ab4cbda16404eadf40096a8dfdb684fbc7ec1c7f81c9f SHA512 f9ff9b72b7d1d659d4ca00d990c28b9da8dea0228e66610ee2d17a3959fcd142998a7539f8ea68effdfe830d2f5e68c154a2911afb9cad52acd24a6a642d76a4
+DIST atftp-0.7.5.tar.gz 253626 BLAKE2B aa0a0311d29fd52b77f8ae021407221f815a39fe85cabac36ee18dce8918a5b0accda455e2df5fecf34f09e93e583bfbc86162b60a7237bd6d34b0c658ec2970 SHA512 457101136e59f7a1657ce591e9ea678ab9091a59219d41b6c522fad4a3555c5cbcb8c9e0c3267fd871940d99b5f8673ab4ce5ec9737dee52f017e5c80a4e59d7
diff --git a/net-ftp/atftp/atftp-0.7.5.ebuild b/net-ftp/atftp/atftp-0.7.5.ebuild
new file mode 100644
index 000000000000..001bba2e8253
--- /dev/null
+++ b/net-ftp/atftp/atftp-0.7.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Advanced TFTP implementation client/server"
+HOMEPAGE="https://sourceforge.net/projects/atftp/"
+SRC_URI="mirror://sourceforge/atftp/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="selinux tcpd readline pcre"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ readline? ( sys-libs/readline:0= )
+ pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}
+ !net-ftp/tftp-hpa
+ !net-ftp/uftpd
+ selinux? ( sec-policy/selinux-tftp )"
+BDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-CFLAGS.patch"
+)
+
+src_prepare() {
+ append-cppflags -D_REENTRANT -DRATE_CONTROL
+ # fix #561720 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable tcpd libwrap) \
+ $(use_enable readline libreadline) \
+ $(use_enable pcre libpcre) \
+ --enable-mtftp
+}
+
+src_test() {
+ cd "${S}"/test || die
+ TEMPDIR=. ./test.sh || die
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/atftp.init atftp
+ newconfd "${FILESDIR}"/atftp.confd atftp
+
+ systemd_dounit "${FILESDIR}"/atftp.service
+ systemd_install_serviced "${FILESDIR}"/atftp.service.conf
+
+ dodoc README* BUGS FAQ Changelog INSTALL TODO
+ dodoc "${S}"/docs/*
+
+ docinto test
+ cd "${S}"/test || die
+ dodoc load.sh mtftp.conf pcre_pattern.txt test.sh test_suite.txt
+}
diff --git a/net-ftp/atftp/files/atftp-0.7.5-CFLAGS.patch b/net-ftp/atftp/files/atftp-0.7.5-CFLAGS.patch
new file mode 100644
index 000000000000..4f68d97f800f
--- /dev/null
+++ b/net-ftp/atftp/files/atftp-0.7.5-CFLAGS.patch
@@ -0,0 +1,32 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -69,29 +69,6 @@
+ dnl Check for AIX
+ AC_AIX
+
+-CFLAGS="$CFLAGS -g -Wall -D_REENTRANT"
+-
+-if test x$debug = xtrue; then
+- CFLAGS="$CFLAGS -O0 -DDEBUG"
+-else
+- if test -n "$auto_cflags"; then
+- if test -n "$GCC"; then
+- CFLAGS="$CFLAGS -g -O2 -Wall -Wno-implicit"
+- else
+- case "$host_os" in
+- *hpux*) CFLAGS="$CFLAGS +O3"
+- ;;
+- *ultrix* | *osf*) CFLAGS="$CFLAGS -O -Olimit 2000"
+- ;;
+- *) CFLAGS="$CFLAGS -O2"
+- ;;
+- esac
+- fi
+- else
+- CFLAGS="$CFLAGS -O2"
+- fi
+-fi
+-
+ case "$CC" in
+ gcc*|clang*) CFLAGS="$CFLAGS -std=gnu89"
+ ;;