summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-01-26 15:07:48 -0500
committerMike Gilbert <floppym@gentoo.org>2016-01-26 15:10:07 -0500
commit34a1ddd2aebdbd949c5caf22d7350a84b8267971 (patch)
tree295ebab01c8340a6b7258ae02a25086cdb7832ac
parentmate-base/mate-settings-daemon: Drop old (diff)
downloadgentoo-34a1ddd2aebdbd949c5caf22d7350a84b8267971.tar.gz
gentoo-34a1ddd2aebdbd949c5caf22d7350a84b8267971.tar.bz2
gentoo-34a1ddd2aebdbd949c5caf22d7350a84b8267971.zip
Revert "dev-python/six: Drop forced dependency on setuptools"
This reverts commit a15786aa5f40452b1270fa04d4ffdbc8e034b29c. This change is bound to cause egg-info file/directory conflicts. Also, upstream requires setuptools unconditionally as of 2016-01-20. https://bitbucket.org/gutworth/six/commits/1c793cff Bug: https://bugs.gentoo.org/572792
-rw-r--r--dev-python/six/six-1.10.0.ebuild3
-rw-r--r--dev-python/six/six-1.9.0-r1.ebuild3
-rw-r--r--dev-python/six/six-9999.ebuild7
3 files changed, 8 insertions, 5 deletions
diff --git a/dev-python/six/six-1.10.0.ebuild b/dev-python/six/six-1.10.0.ebuild
index c0986d639ce8..cb6a767b3815 100644
--- a/dev-python/six/six-1.10.0.ebuild
+++ b/dev-python/six/six-1.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -18,6 +18,7 @@ KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc
IUSE="doc test"
DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx )
test? ( >=dev-python/pytest-2.2.0[${PYTHON_USEDEP}] )"
diff --git a/dev-python/six/six-1.9.0-r1.ebuild b/dev-python/six/six-1.9.0-r1.ebuild
index 67dc3a828bf6..6ab55582e454 100644
--- a/dev-python/six/six-1.9.0-r1.ebuild
+++ b/dev-python/six/six-1.9.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -18,6 +18,7 @@ KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh
IUSE="doc test"
DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
diff --git a/dev-python/six/six-9999.ebuild b/dev-python/six/six-9999.ebuild
index 72c67837d924..1807e5e4f34e 100644
--- a/dev-python/six/six-9999.ebuild
+++ b/dev-python/six/six-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=6
+EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
inherit distutils-r1 mercurial
@@ -19,6 +19,7 @@ KEYWORDS=""
IUSE="doc test"
DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx )
test? ( >=dev-python/pytest-2.2.0[${PYTHON_USEDEP}] )"