summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-10 22:13:58 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-10 22:13:58 +0200
commit3527c2bcdb9f7904147b8dd2273371cf814165a0 (patch)
tree001bbbe99f17f5e7f7475317b97ef88e42109b71
parentdev-python/xmlschema: Remove old (diff)
downloadgentoo-3527c2bcdb9f7904147b8dd2273371cf814165a0.tar.gz
gentoo-3527c2bcdb9f7904147b8dd2273371cf814165a0.tar.bz2
gentoo-3527c2bcdb9f7904147b8dd2273371cf814165a0.zip
dev-python/tox: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tox/Manifest1
-rw-r--r--dev-python/tox/tox-3.25.1.ebuild69
2 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index ddbe203c201a..a71fd5ecd623 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1,2 +1 @@
-DIST tox-3.25.1.gh.tar.gz 307697 BLAKE2B 2c778df22388b101e6e68423636c9753f0e6faac2360184fd6b9022dc3bbb5662840cf24e7907dd4c652f6401723be3be35bcdeb0f290f9839325babf5ec776d SHA512 e0443cb72378fc18c9bc001413261d9bac2d6f89bb0ebff618a3848ffd5b02c80902cefbd90f7b0d0e3119f1df3cd22b46be23077db0ee90c03a9780ba4b248b
DIST tox-3.26.0.gh.tar.gz 308035 BLAKE2B 745d1aef11c230971a7b6b1df919440c2be1b9b0f726ab314e1a27fe6fa72b568efc8e336058249721028cc18d2c3453e4806079abb8099baa608bf6b1e98ad7 SHA512 8c2635a640bcc221735f59da633b3ae696d97c076280400f6086703c2e00d8dbad943073e0c63618e5e041199dfebd010a16a00b1498ca9ea8e884648ed40ae5
diff --git a/dev-python/tox/tox-3.25.1.ebuild b/dev-python/tox/tox-3.25.1.ebuild
deleted file mode 100644
index cb4f9d1950f3..000000000000
--- a/dev-python/tox/tox-3.25.1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="virtualenv-based automation of test activities"
-HOMEPAGE="
- https://tox.readthedocs.io/
- https://github.com/tox-dev/tox/
- https://pypi.org/project/tox/
-"
-SRC_URI="
- https://github.com/tox-dev/tox/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/filelock[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
- dev-python/py[${PYTHON_USEDEP}]
- >=dev-python/six-1.14[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- >=dev-python/flaky-3.4.0[${PYTHON_USEDEP}]
- >=dev-python/freezegun-0.3.11[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # broken without Internet
- tests/unit/session/test_provision.py::test_provision_non_canonical_dep
- tests/integration/test_provision_int.py::test_provision_interrupt_child
-
- # expects python2 to exist
- tests/unit/interpreters/test_interpreters.py::test_tox_get_python_executable
- )
-
- [[ ${EPYTHON} != pypy3 ]] && EPYTEST_DESELECT+=(
- # capfd doesn't seem to work for some non-obvious reason
- tests/unit/test_z_cmdline.py::TestSession::test_summary_status
- tests/unit/session/test_provision.py::test_provision_bad_requires
-
- # TODO?
- tests/unit/interpreters/test_interpreters.py::test_find_alias_on_path
- )
-
- epytest --no-network
-}