summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-23 05:33:34 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-23 06:36:29 +0200
commit353fdc47ede6634a3aff9d9657585d8dd865790a (patch)
treef6b3fd5b589aeafca4c09cbf582f4fb6ceef5a46
parentsys-apps/util-linux: update mount_setattr patch to new upstream version (diff)
downloadgentoo-353fdc47ede6634a3aff9d9657585d8dd865790a.tar.gz
gentoo-353fdc47ede6634a3aff9d9657585d8dd865790a.tar.bz2
gentoo-353fdc47ede6634a3aff9d9657585d8dd865790a.zip
dev-python/botocore: Bump to 1.29.138
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.138.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index f1e38e26339d..52605315b093 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.29.129.gh.tar.gz 11476185 BLAKE2B b2601ecd28263e44f4830ccad24402e6c5f62127cd5abbe75fd270bb05fabcc10dee24e6ba8e37629232929990b1f6bd9870eead303642564342da60c3386bda SHA512 c38a8797f7c728755406e334094e0183fd69eb1a7c68e41b065d5d2c999948714390a647c68d0373c1d8a7b6d9d91fd950b10527ee88bca08788921903ff9535
DIST botocore-1.29.133.gh.tar.gz 11484789 BLAKE2B ce1acc51ffada796e594090e7b4d73029df362459a562116ad9dabc56b926f7beec5644e5ce7d175e8901eac28420b57b758be266aa61582cac7e4b91b794e05 SHA512 62631be4f9bf07803e193a8a7ff3b04a806d6dc7668317765b853bba1f1c66cf49c8345f7640f829622c3c8ce96c775bf00bbfa943ff175a6c9a479a888e85db
DIST botocore-1.29.137.gh.tar.gz 11508178 BLAKE2B 2f74fd2f3923672a4fcd501f1c5ba48cd09965ea0f70689bd6559a4c4a6fe8921f783ef86f28ac57893c8b1366d8fca2fc79f0216747e04142ed33880f07fe39 SHA512 b800a1b73170b5fcbbf1b17477bb8f04b19f5f250a68bbb3b993b0e058d8df870eddf932f79d94eaa3255b976ce136adbdd5b359757cd79f2cfe2a16b3cfa2f4
+DIST botocore-1.29.138.gh.tar.gz 11516247 BLAKE2B eb8195ff412de996fcdd9cb2f44f20476b1418f328016721099ed7dc2a7159a5bbc819f752ea2188c46edb0d701a0481f7823cb50d0da5712d61f7b9a5f0799e SHA512 02bf92e2481aa27796186f8c457ce1e3d833bcf5d647dab3fe6347760106ccc8f73a3c7d55700ad72fc0210e8229c905e617a8d65a63542eaadab01e1c798bb3
diff --git a/dev-python/botocore/botocore-1.29.138.ebuild b/dev-python/botocore/botocore-1.29.138.ebuild
new file mode 100644
index 000000000000..3ced99abe4ff
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.138.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ # urllib3-2 compatibility, mock relies on implementation details
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_no_response_from_server
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_returned
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_sends_307
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_sends_connection_header
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_handles_expect_100_with_different_reason_phrase
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_state_reset_on_connection_close
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}