summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-18 00:00:29 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-18 00:00:29 +0200
commit357c38901c566bcb465e4c6292159110301e81a2 (patch)
tree808146a4fd28186f893d12fe2e0870ebae329e56
parentdev-python/boto3: Bump to 1.18.44 (diff)
downloadgentoo-357c38901c566bcb465e4c6292159110301e81a2.tar.gz
gentoo-357c38901c566bcb465e4c6292159110301e81a2.tar.bz2
gentoo-357c38901c566bcb465e4c6292159110301e81a2.zip
app-admin/awscli: Bump to 1.20.44
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.20.44.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 60913566a3a8..e8e736073556 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST awscli-1.20.40.tar.gz 2071857 BLAKE2B b2511d610c13b4ddf8b1f5c6442f0939072ee
DIST awscli-1.20.41.tar.gz 2071927 BLAKE2B 4d7ec9e3c2af3f44cbce9459ef12c8191ae72b3313e266a2ac8f39cd2197129ae66893152c6077326c8315d4098608cb11019ad3cc19fdd057508db4f6c3a0d8 SHA512 6d022575d2bded2245bb17e8605e929a8ff2e91e79f907e21a0eaaf027e2fb657b96573531226cd63a34b0a0523a6747c7c4f9652ee10b09fd8b6d09e9c8fc9c
DIST awscli-1.20.42.tar.gz 2072504 BLAKE2B 5f6f38f8c96350b670c15cd6cfdd1556cbbfab95b7bfec5ff3ac9a96b56d733bb112b18f04d5d5ce9674a0ebb3d41e7b7f1ad81881c486f99463ce22270e0574 SHA512 29daa2c526b7605fbd1c588b00906f3cdf159570a543cc9c442e28af9f98725b8a0a8f9d61110e90f56744dea6a6abf92f052b85695f3a84bddabb24eff650f6
DIST awscli-1.20.43.tar.gz 2073056 BLAKE2B e4d3301022083db4b4dd59ce9d0acc5b2ef2ba2359236bebb11b024dcf681deedbd0df8a7cf143503318dc66a9d69305fefc97dc3407bdb77985fd0854ba7915 SHA512 5fb9a6f18a04640bdee94b80aa5b5893dbcc9316c06f543ec8491fef3db4394d6d1aa2cf35972cec04e6c8c74c9111fab71d007b63c4a3152aad80b099d5c43e
+DIST awscli-1.20.44.tar.gz 2073627 BLAKE2B 906e03139bde50724348b445750bcc2b286fe33c0ba8873e0373bfc4f62124a25a400821cd8d3608f3f52fe8a3649218c5c10bebad8a5887b131088aab80220d SHA512 58a7232e1708791cf4d9149aab6afebca50e422a0cdf10215aed9ea1e4f71daeb64253bcc12c4934737fe2f5688dc50e6cf8fde1335c99338804590030b0973c
diff --git a/app-admin/awscli/awscli-1.20.44.ebuild b/app-admin/awscli/awscli-1.20.44.ebuild
new file mode 100644
index 000000000000..ff429f8d3a3e
--- /dev/null
+++ b/app-admin/awscli/awscli-1.20.44.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install nose
+
+PATCHES=(
+ "${FILESDIR}"/awscli-1.19.47-py39.patch
+)
+
+python_test() {
+ distutils_install_for_testing
+ # integration tests require AWS credentials and Internet access
+ nosetests -v tests/{functional,unit} ||
+ die "Tests failed for ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}