summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Lin <jeffrey@icurse.nl>2020-05-30 22:28:56 -0400
committerRobin H. Johnson <robbat2@gentoo.org>2020-05-30 21:16:38 -0700
commit360c4b4e56af60943ca2b7eaee6ec72d322d7df5 (patch)
treea764e2fef7dc49a9cbd8b446451aa09772afd5da
parentnet-fs/samba: Keyword 4.12.3 alpha, #711488 (diff)
downloadgentoo-360c4b4e56af60943ca2b7eaee6ec72d322d7df5.tar.gz
gentoo-360c4b4e56af60943ca2b7eaee6ec72d322d7df5.tar.bz2
gentoo-360c4b4e56af60943ca2b7eaee6ec72d322d7df5.zip
dev-util/github-cli: add bash completion, manpages
Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl> (cherry picked from commit 05a59f8c3ed2991f4999c4936dbf5fc0565b7b60) Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-rw-r--r--dev-util/github-cli/github-cli-0.9.0-r1.ebuild (renamed from dev-util/github-cli/github-cli-0.9.0.ebuild)8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-util/github-cli/github-cli-0.9.0.ebuild b/dev-util/github-cli/github-cli-0.9.0-r1.ebuild
index 61c48d3dee4c..40cf4d76c403 100644
--- a/dev-util/github-cli/github-cli-0.9.0.ebuild
+++ b/dev-util/github-cli/github-cli-0.9.0-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit go-module
+inherit bash-completion-r1 go-module
DESCRIPTION="GitHub CLI"
HOMEPAGE="https://github.com/cli/cli"
@@ -294,4 +294,10 @@ src_compile() {
src_install() {
dobin bin/gh
dodoc README.md
+
+ make manpages
+ doman share/man/man1/gh*.1
+
+ bin/gh completion -s bash > gh
+ dobashcomp gh
}