summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-07 10:50:32 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-07 10:50:32 +0200
commit3611521d6e305ae16db58c8e83a4da105caa13e6 (patch)
treedda6318e23f2ce0b0affce59fc08fe22428cb86c
parentdev-python/h11: Enable pypy3 (diff)
downloadgentoo-3611521d6e305ae16db58c8e83a4da105caa13e6.tar.gz
gentoo-3611521d6e305ae16db58c8e83a4da105caa13e6.tar.bz2
gentoo-3611521d6e305ae16db58c8e83a4da105caa13e6.zip
dev-python/h11: Fix PEP517 mode
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/h11/h11-0.13.0-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/h11/h11-0.13.0-r1.ebuild b/dev-python/h11/h11-0.13.0-r1.ebuild
new file mode 100644
index 000000000000..d10ad991d9b2
--- /dev/null
+++ b/dev-python/h11/h11-0.13.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python implementation of HTTP/1.1 inspired by hyper-h2"
+HOMEPAGE="https://github.com/python-hyper/h11/ https://pypi.org/project/h11/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests pytest