summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-01 15:38:55 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-01 15:38:55 +0200
commit36d97374008e969e9d2594a0562becb9044e97ef (patch)
treecdcd715d1e8e9be50373a30f05fda197d95e3e62
parentdev-python/pyaes: Enable py3.12 (diff)
downloadgentoo-36d97374008e969e9d2594a0562becb9044e97ef.tar.gz
gentoo-36d97374008e969e9d2594a0562becb9044e97ef.tar.bz2
gentoo-36d97374008e969e9d2594a0562becb9044e97ef.zip
dev-python/pybtex: Modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pybtex/pybtex-0.24.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pybtex/pybtex-0.24.0-r1.ebuild b/dev-python/pybtex/pybtex-0.24.0-r1.ebuild
new file mode 100644
index 000000000000..07a78a1137b3
--- /dev/null
+++ b/dev-python/pybtex/pybtex-0.24.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="BibTeX-compatible bibliography processor"
+HOMEPAGE="
+ https://pybtex.org/
+ https://pypi.org/project/pybtex/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/latexcodec[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}/${PN}-0.22.2-fix-test-installation.patch" )