summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-21 20:12:11 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-21 21:11:42 +0200
commit36e4f2ad72808b5dee77f42df9b239dea33a5928 (patch)
treee3a2b437fa7e9e0dfb22005560f86866d81d70de
parentapp-text/ghostscript-gpl: add parallel build patch to 9.54.0-r1 (diff)
downloadgentoo-36e4f2ad72808b5dee77f42df9b239dea33a5928.tar.gz
gentoo-36e4f2ad72808b5dee77f42df9b239dea33a5928.tar.bz2
gentoo-36e4f2ad72808b5dee77f42df9b239dea33a5928.zip
dev-python/google-api-python-client: Bump to 2.22.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.22.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 1b3c35b5a91a..9cbdaff79d89 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -3,3 +3,4 @@ DIST google-api-python-client-2.18.0.tar.gz 26442309 BLAKE2B 84f0cadeed015e9e0ca
DIST google-api-python-client-2.19.1.tar.gz 26659303 BLAKE2B b1b5064c39b7e0d31e7ee01a7556a9ea6feaac1782d6714e50a32f0dfafedcab59628a1ff32774c426136d7ab796a1a6baf1f9ce7fbd1d233149c3a62648f280 SHA512 85272cd0741caed6ff76b930a69a67f1683886df82681b49f3069243dd40ef3f12febc7c1004ecf230d96bae005a8725d502032a9c85eb1bf9e4ee37af7018b9
DIST google-api-python-client-2.20.0.tar.gz 26723285 BLAKE2B 3c0cb64ea8c58fe20356cd097676bc7741ea454e61d9dc8807689fe2296c3ddd0da1cb208a639e8b47a981437dea39de9a7c26b669c7dc27a79a0c5ca4a6c463 SHA512 bed0b1a0e0c5384c80e337339e9c5526e0cd5b2d39a3bd69fec1c65a3fed5bf26e6f4f983daed7663d2cd6c47b8a2a7ad54395f8e5dada2b49c15d98a9ff04dd
DIST google-api-python-client-2.21.0.tar.gz 26754841 BLAKE2B e09b48d80d72e56656b366bd60972cde91d0c705ffe94b61d168e808e575a42f1dbbefdaf21ead1e57bab54a1b2453ba39ed5ae1d2ee616a5ba1418acc9f7534 SHA512 c572e5eab313e01ae94b026e32cf40fb479154942168cc09f2b74f184383ff5fc27cc5c0ae48c34d8ddbd8abe8840520a62a43708bd601341d5b32460f5f07df
+DIST google-api-python-client-2.22.0.tar.gz 26831856 BLAKE2B da93f1bca651cc01819c5f5ab43a6c767662db7eb85efb9aa08d2f9b54bc9efcc7622bff3207604ffafea9c88de8a393f5084c225078d896da5fdee1f2e56350 SHA512 427ead4173ed14b2df0560e35c5ff48a98d4abb5d449c26f84d9e7bb169bf46402eaaea0dab7988dbefd5ceee975b19a160cd797d2169030bb5bf1a54accda11
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.22.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.22.0.ebuild
new file mode 100644
index 000000000000..2bf8009bdc63
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.22.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-4[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ find tests -name '*.py' -exec \
+ sed -i -e 's:unittest2 as ::' {} + || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local deselect=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ distutils_install_for_testing
+ epytest tests ${deselect[@]/#/--deselect }
+}