summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-05-26 23:59:43 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-05-27 00:37:13 +0200
commit3716139e6ba759660468b696b0b2cca3dce1d157 (patch)
treeac96eb2ef23837fd66c08175801efd36eee09538
parentsys-cluster/legion: version bump (diff)
downloadgentoo-3716139e6ba759660468b696b0b2cca3dce1d157.tar.gz
gentoo-3716139e6ba759660468b696b0b2cca3dce1d157.tar.bz2
gentoo-3716139e6ba759660468b696b0b2cca3dce1d157.zip
dev-python/biplist: version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-python/biplist/Manifest1
-rw-r--r--dev-python/biplist/biplist-1.0.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/biplist/Manifest b/dev-python/biplist/Manifest
index 302ae54c0c4c..a63922f27570 100644
--- a/dev-python/biplist/Manifest
+++ b/dev-python/biplist/Manifest
@@ -1 +1,2 @@
DIST biplist-1.0.1.tar.gz 16251 SHA256 41843579a531958bf0df88b471cf8d446723e640c73c469374e4ac313c33b6a8 SHA512 017bbea254f74d2c647322044a7b9a6006a0d69ecd44d1cd0281a3f30b38fd0feeef1b07272b9495440d3cd4434e2d4802681959b4185e2c354999884605a657 WHIRLPOOL d533fcfb05f52682bd309128463adb876a99d803c86118bdf92a90e6155b56a012b7bc60b7e1a309bca7169a560d500b2508e7b43bd5272f6780bc209ca96eb3
+DIST biplist-1.0.2.tar.gz 16246 SHA256 d2f974dd0972a70af6b8ff3b50ad165982bdba49ad8bcc47a58b28b9cc20ec34 SHA512 2418d24b2d9e36aad76ac6626e82b8f60f0c167636142a054b02de3437d117fa1ccfeb9c104801fe106fec2d7a31c2bdeaab27fd519f1bce3bdf8a3b90b42c27 WHIRLPOOL 02f0ba8a2e1209be947ff5a283e194b354c600a4d4bb32f23003c452ce100ed3483d41bfd2b4b3c2510744c5c530f59a0301613663debb7b22bbe2ffe9852f0d
diff --git a/dev-python/biplist/biplist-1.0.2.ebuild b/dev-python/biplist/biplist-1.0.2.ebuild
new file mode 100644
index 000000000000..9fdaa94da67f
--- /dev/null
+++ b/dev-python/biplist/biplist-1.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A binary plist parser/generator for Python"
+HOMEPAGE="https://pypi.python.org/pypi/biplist/ https://github.com/wooster/biplist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )"
+
+python_test() {
+ # This failure still occurs, after 18 momths
+ # https://github.com/wooster/biplist/issues/8
+ nosetests || die "Tests failed under ${EPYTHON}"
+}