summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2016-03-15 22:54:57 +0100
committerTiziano Müller <dev-zero@gentoo.org>2016-03-15 22:55:48 +0100
commit37235adcb5836ae5dae998e98777d74c31f801a0 (patch)
tree6af6b9efdcb36786d7a74cd35c8a3bc06168bc80
parentnet-irc/irssi: Add test restriction, bug #577404 (diff)
downloadgentoo-37235adcb5836ae5dae998e98777d74c31f801a0.tar.gz
gentoo-37235adcb5836ae5dae998e98777d74c31f801a0.tar.bz2
gentoo-37235adcb5836ae5dae998e98777d74c31f801a0.zip
dev-python/flask-restful: rev-bump for py-3.5 support and EAPI-6
Package-Manager: portage-2.2.28
-rw-r--r--dev-python/flask-restful/flask-restful-0.3.5-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/flask-restful/flask-restful-0.3.5-r1.ebuild b/dev-python/flask-restful/flask-restful-0.3.5-r1.ebuild
new file mode 100644
index 000000000000..5b6f387f8b82
--- /dev/null
+++ b/dev-python/flask-restful/flask-restful-0.3.5-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple framework for creating REST APIs"
+HOMEPAGE="http://flask-restful.readthedocs.org/ https://github.com/twilio/flask-restful/"
+SRC_URI="https://github.com/twilio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples paging test"
+
+RDEPEND="
+ >=dev-python/aniso8601-0.82[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ paging? ( >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_compile_all() {
+ cd docs || die
+ emake man $(usex doc html "")
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && dodoc -r examples
+ local DOCS=( AUTHORS.md CHANGES.md CONTRIBUTING.md README.md )
+
+ doman docs/_build/man/*
+ distutils-r1_python_install_all
+}