summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-01-31 21:47:09 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-01-31 21:47:09 +0700
commit375125ddda97fd30eac4542a97f67c50949fa49d (patch)
tree8b653fadd69c2467de692a7587930de17a30be9d
parentnet-wireless/airtraf: Fix CFLAGS=-fno-common (diff)
downloadgentoo-375125ddda97fd30eac4542a97f67c50949fa49d.tar.gz
gentoo-375125ddda97fd30eac4542a97f67c50949fa49d.tar.bz2
gentoo-375125ddda97fd30eac4542a97f67c50949fa49d.zip
sci-mathematics/form: bump to 4.2.1
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
-rw-r--r--sci-mathematics/form/Manifest1
-rw-r--r--sci-mathematics/form/form-4.2.1.ebuild82
-rw-r--r--sci-mathematics/form/metadata.xml7
3 files changed, 88 insertions, 2 deletions
diff --git a/sci-mathematics/form/Manifest b/sci-mathematics/form/Manifest
index 0d47550f4bcc..b6fd32665e08 100644
--- a/sci-mathematics/form/Manifest
+++ b/sci-mathematics/form/Manifest
@@ -1,2 +1,3 @@
DIST form-4.1.tar.gz 1260530 BLAKE2B ec279a069ea096089e9180541888f3212c6406311745a73cfd3f2e6da74f2fc88a93eea6d0d4af838fac6583e1eed5562455a40aca4cf502602552929453dfee SHA512 39ab2fa1e448d6d5e427cc2c92285cc27f84724addffc378f3b799fc2b3f6381b8dceb87cb980062b980885d8d81591c5c7ff7b0dbeae7b6d9a3cf0b03d58aae
DIST form-4.2.0.tar.gz 1386285 BLAKE2B 3f50fe992df2c5b0e36b278de4e65a353a75c4b2c57be0c55f9973a8177577ed76ee40f8628b13ae9c2b7d73f38a7b4710b96db38639faa8ff002f42a8ec32f8 SHA512 7566b89c1c1b74da58da92426f5e4beee271d4273df6cbe1d1de1a17377125b745103852c363dfe8ff1b0e9cb9ba4c84187406e8f77b23f5198fd592f5dfe341
+DIST form-4.2.1.tar.gz 1444257 BLAKE2B 27ac9ee1412e6f478324b170e37e6e31822b74f902a5739d5fa00558aa4c9f7a977bd5fe3d6982313f1232a774c592d44af07fec8a290266c31bf3a100e87d1a SHA512 5569ae3e487194b0d082f4a032fb4b8d57238218d92d9b04d5f51db2a73e065eb1efdc26011bda46723e902fa3f324010ca2f8e91ba9a077e87b0a07b40cf594
diff --git a/sci-mathematics/form/form-4.2.1.ebuild b/sci-mathematics/form/form-4.2.1.ebuild
new file mode 100644
index 000000000000..c42c2a499f2c
--- /dev/null
+++ b/sci-mathematics/form/form-4.2.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Symbolic Manipulation System"
+HOMEPAGE="https://www.nikhef.nl/~form/ https://github.com/vermaseren/form/"
+SRC_URI="https://github.com/vermaseren/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="devref doc doxygen gmp mpi threads zlib"
+
+RDEPEND="
+ gmp? ( dev-libs/gmp:0= )
+ mpi? ( virtual/mpi )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ devref? ( dev-texlive/texlive-latex )
+ doc? ( dev-texlive/texlive-latex )
+ doxygen? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+ sed -i 's/LINKFLAGS = -s/LINKFLAGS =/' sources/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-scalar \
+ --enable-largefile \
+ --disable-debug \
+ --disable-static-link \
+ --with-api=posix \
+ $(use_with gmp ) \
+ $(use_enable mpi parform ) \
+ $(use_enable threads threaded ) \
+ $(use_with zlib ) \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}"
+}
+
+src_compile() {
+ default
+ if use devref; then
+ pushd doc/devref > /dev/null || die "doc/devref does not exist"
+ LANG=C emake pdf
+ popd > /dev/null
+ fi
+ if use doc; then
+ pushd doc/manual > /dev/null || die "doc/manual does not exist"
+ LANG=C emake pdf
+ popd > /dev/null
+ fi
+ if use doxygen; then
+ pushd doc/doxygen > /dev/null || die "doc/doxygen does not exist"
+ emake html
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ default
+ if use devref; then
+ insinto /usr/share/doc/${PF}
+ doins doc/devref/devref.pdf
+ fi
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/manual/manual.pdf
+ fi
+ if use doxygen; then
+ dohtml -r doc/doxygen/html/*
+ fi
+}
diff --git a/sci-mathematics/form/metadata.xml b/sci-mathematics/form/metadata.xml
index 046e2a6564f3..e75e527199ad 100644
--- a/sci-mathematics/form/metadata.xml
+++ b/sci-mathematics/form/metadata.xml
@@ -6,10 +6,13 @@
<name>Gentoo Mathematics Project</name>
</maintainer>
<longdescription lang="en">
-A system which can efficiently manipulate huge formulas limited only by available disk space.
-</longdescription>
+ A system which can efficiently manipulate huge formulas limited only by available disk space.
+ </longdescription>
<use>
<flag name="devref">Build and install developers reference</flag>
<flag name="doxygen">Build and install API documentation</flag>
</use>
+ <upstream>
+ <remote-id type="github">vermaseren/form</remote-id>
+ </upstream>
</pkgmetadata>