summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-04-01 10:25:50 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-04-01 10:38:37 +0300
commit3858627785970eb844e3f7758690dca7a6d32653 (patch)
tree8491df529800c71e28c78df432bbc6a5d8cf746a
parentprofiles/features/musl/package.mask: mask sys-auth/libnss-compat on musl (diff)
downloadgentoo-3858627785970eb844e3f7758690dca7a6d32653.tar.gz
gentoo-3858627785970eb844e3f7758690dca7a6d32653.tar.bz2
gentoo-3858627785970eb844e3f7758690dca7a6d32653.zip
sys-process/uksmd: remove dependency on pf-sources
- KSM can be applied manually to any kernel-sources. Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sys-process/uksmd/uksmd-0_pre20190726-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-process/uksmd/uksmd-0_pre20190726-r2.ebuild b/sys-process/uksmd/uksmd-0_pre20190726-r2.ebuild
new file mode 100644
index 000000000000..91de2f16cdb5
--- /dev/null
+++ b/sys-process/uksmd/uksmd-0_pre20190726-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+MY_COMMIT="42f4ff8eb09011bf1a199938aa2afe23040d7faf"
+MY_P="${PN}-${MY_COMMIT}"
+
+DESCRIPTION="Userspace KSM helper daemon"
+HOMEPAGE="https://gitlab.com/post-factum/uksmd"
+SRC_URI="https://gitlab.com/post-factum/uksmd/-/archive/${MY_COMMIT}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-process/procps:="
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~KSM"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/${P}-respect-cflags-ldflags.patch" )
+
+src_install() {
+ default
+ einstalldocs
+
+ newinitd "${FILESDIR}/uksmd.init" uksmd
+ systemd_dounit distro/uksmd.service
+}