summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-12 12:27:47 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-12 15:27:44 +0100
commit38623bac6b069dbac89671121f04dbb51150f1d2 (patch)
tree6aef489944ec70b713e8f5e3f73b4767cf61d93e
parentnet-misc/networkmanager-vpnc: Drop old (diff)
downloadgentoo-38623bac6b069dbac89671121f04dbb51150f1d2.tar.gz
gentoo-38623bac6b069dbac89671121f04dbb51150f1d2.tar.bz2
gentoo-38623bac6b069dbac89671121f04dbb51150f1d2.zip
dev-cpp/glibmm: Version bump, fix build failure with gcc-4.7 (bug #566426 by Émeric Maschino)
Package-Manager: portage-2.2.24
-rw-r--r--dev-cpp/glibmm/Manifest1
-rw-r--r--dev-cpp/glibmm/files/glibmm-2.46.2-use-noexcept.patch29
-rw-r--r--dev-cpp/glibmm/files/glibmm-2.46.2-use-noexcept2.patch15
-rw-r--r--dev-cpp/glibmm/glibmm-2.46.2.ebuild81
4 files changed, 126 insertions, 0 deletions
diff --git a/dev-cpp/glibmm/Manifest b/dev-cpp/glibmm/Manifest
index bd140427ae9a..5dbb62f1fb19 100644
--- a/dev-cpp/glibmm/Manifest
+++ b/dev-cpp/glibmm/Manifest
@@ -1,2 +1,3 @@
DIST glibmm-2.44.0.tar.xz 6102664 SHA256 1b0ac0425d24895507c0e0e8088a464c7ae2d289c47afa1c11f63278fc672ea8 SHA512 4a932b127ce0ed0798cef3555fdd1ca1632fc10720b74f9a39626989c216542807d76ae67ebc980049b65b1c163d236fc9875506ca2d80584c724394bbb8bfd7 WHIRLPOOL d1fad56af4487e661398ec3be006c528c5c6c1cba0181ad08725f14cb94bbbfe2f9c20870722b90ebca61a51e9959eee89b1f92a7f00f99bc3a573b123360197
DIST glibmm-2.46.1.tar.xz 6470952 SHA256 9647e596c1081d2ea202bd3da2824ec2ea359498fa86eb59a55b1b307dd8c4aa SHA512 4209264ec40e8894d3b4876f65af1458b6a15e22e3069058bf7f32854b5150a1890359cee878d29de94f609e423dc6f8467cffbbecf4a30d5810c890ad40b981 WHIRLPOOL 909a283d06e45e6d4077f0058eaa884acc268a93d97d80009f81cd91f3b8e73dd0016e7071797a1e9e95775752673fd6b47e295c58338052a0976054278964e7
+DIST glibmm-2.46.2.tar.xz 6471124 SHA256 7221a01a768c1cce2bb994cb6ebfe634246dba4788f910484d04e3b0d903a3c8 SHA512 f6748c6833c5733784ade3a28bcb72131bc5f1d291250094b51cf3676974f80f1d1616cb77c7b77b59fbdcd15cc692210caf27ecf1eaa5a3498042499a060ff1 WHIRLPOOL 9038724f9f9a63415126cbaf8946f31cea11d082c69d2c53bf24ec17f11e2266ca7a8ffa480f02a8a7706626cf5bb8fb4624615272a476b3cca0dec096d1be55
diff --git a/dev-cpp/glibmm/files/glibmm-2.46.2-use-noexcept.patch b/dev-cpp/glibmm/files/glibmm-2.46.2-use-noexcept.patch
new file mode 100644
index 000000000000..085441d96679
--- /dev/null
+++ b/dev-cpp/glibmm/files/glibmm-2.46.2-use-noexcept.patch
@@ -0,0 +1,29 @@
+From 6c7c14875d0f1d249abcccb0033297c8d48619dc Mon Sep 17 00:00:00 2001
+From: Murray Cumming <murrayc@murrayc.com>
+Date: Sun, 29 Nov 2015 21:32:46 +0100
+Subject: Gio::Application: Destructor: Use noexcept in the implementation too.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Bug #758798 (Émeric MASCHINO)
+---
+ gio/src/application.ccg | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gio/src/application.ccg b/gio/src/application.ccg
+index 9fb5866..c7488ac 100644
+--- a/gio/src/application.ccg
++++ b/gio/src/application.ccg
+@@ -278,7 +278,7 @@ Application::Application(const Glib::ustring& application_id, ApplicationFlags f
+
+ }
+
+-Application::~Application()
++Application::~Application() noexcept
+ {
+ // Delete all OptionArgCallbackData instances that belong to this application.
+ std::lock_guard<std::mutex> lock(option_arg_callback_data_mutex);
+--
+cgit v0.11.2
+
diff --git a/dev-cpp/glibmm/files/glibmm-2.46.2-use-noexcept2.patch b/dev-cpp/glibmm/files/glibmm-2.46.2-use-noexcept2.patch
new file mode 100644
index 000000000000..c6c38ff5a568
--- /dev/null
+++ b/dev-cpp/glibmm/files/glibmm-2.46.2-use-noexcept2.patch
@@ -0,0 +1,15 @@
+Gio::Application: Destructor: Use noexcept in the implementation too.
+
+Bug #566426 (https://bugs.gentoo.org/show_bug.cgi?id=566426)
+
+--- a/gio/giomm/application.cc 2015-09-22 11:13:25.000000000 +0200
++++ b/gio/giomm/application.cc 2015-12-08 21:54:44.914338546 +0100
+@@ -284,7 +284,7 @@ Application::Application(const Glib::ust
+
+ }
+
+-Application::~Application()
++Application::~Application() noexcept
+ {
+ // Delete all OptionArgCallbackData instances that belong to this application.
+ Glib::Threads::Mutex::Lock lock(option_arg_callback_data_mutex);
diff --git a/dev-cpp/glibmm/glibmm-2.46.2.ebuild b/dev-cpp/glibmm/glibmm-2.46.2.ebuild
new file mode 100644
index 000000000000..7cd6563876f3
--- /dev/null
+++ b/dev-cpp/glibmm/glibmm-2.46.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 multilib-minimal
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc debug examples test"
+
+RDEPEND="
+ >=dev-libs/libsigc++-2.6.0:2[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.46.0:2[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+# dev-cpp/mm-common needed for eautoreconf
+
+src_prepare() {
+ # Gio::Application: Destructor: Use noexcept in the implementation too
+ # (from 'master')
+ epatch "${FILESDIR}"/${PN}-2.46.2-use-noexcept{,2}.patch
+
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 1 failed"
+ fi
+
+ # don't build examples - we want to install example sources, not binaries
+ sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 2 failed"
+
+ # Test fails with IPv6 but not v4, upstream bug #720073
+# sed -e 's:giomm_tls_client/test::' \
+# -i tests/Makefile.{am,in} || die
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" gnome2_src_configure \
+ $(use_enable debug debug-refcounting) \
+ $(multilib_native_use_enable doc documentation) \
+ --enable-deprecated-api
+}
+
+multilib_src_test() {
+ cd tests
+ default
+
+ for i in */test; do
+ ${i} || die "Running tests failed at ${i}"
+ done
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if ! use doc && ! use examples; then
+ rm -fr "${ED}usr/share/doc/glibmm*"
+ fi
+
+ if use examples; then
+ find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
+ dodoc -r examples
+ fi
+}