summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-10 17:10:58 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-10 17:11:57 +0200
commit38ff9414211e0b8aaa7fad6780284821d15c120d (patch)
tree6da788e0e16605a34c87a932d50414a6b2763d5a
parentnet-analyzer/metasploit: well, it installs now, doesn't run, but it installs (diff)
downloadgentoo-38ff9414211e0b8aaa7fad6780284821d15c120d.tar.gz
gentoo-38ff9414211e0b8aaa7fad6780284821d15c120d.tar.bz2
gentoo-38ff9414211e0b8aaa7fad6780284821d15c120d.zip
app-text/poppler: Bump to version 0.54.0
Adjusted live ebuild accordingly. Permission kindly granted by mrueg. Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--app-text/poppler/Manifest1
-rw-r--r--app-text/poppler/files/poppler-0.53.0-respect-cflags.patch52
-rw-r--r--app-text/poppler/poppler-0.54.0.ebuild136
-rw-r--r--app-text/poppler/poppler-9999.ebuild11
4 files changed, 198 insertions, 2 deletions
diff --git a/app-text/poppler/Manifest b/app-text/poppler/Manifest
index 97ab4a06bb0..635441aa528 100644
--- a/app-text/poppler/Manifest
+++ b/app-text/poppler/Manifest
@@ -1,3 +1,4 @@
DIST poppler-0.45.0.tar.xz 1674464 SHA256 96dd1a6024bcdaa4530a3b49687db3d5c24ddfd072ccb37c6de0e42599728798 SHA512 b703bed35da3572801834740bf61d59b6a3ee3b88bc1b3181bde3472264be4f6b89ceacb56179d7093329946abd6ba2501acfaf209d4f543352ff9fd38c47f1b WHIRLPOOL 687b1ba816dbff1b0a69cb05914dd7fb161bfd8c0fa4e26b77bb0ad26e27f7d7d94085a1022716a8d7a7563145f0acead9fccbbd332959d0216b81b27f3632e8
DIST poppler-0.51.0.tar.xz 1691504 SHA256 e997c9ad81a8372f2dd03a02b00692b8cc479c220340c8881edaca540f402c1f SHA512 f2e49cc8587396e38ac9125fa662bcb472eb0b9c9e0ce57135d72ad1792d55db858c7d00b8322b52ac3fe0cd97eacd2d570d3e579367c4acf2f04051f723c5c5 WHIRLPOOL 5e625db67411d1a3b9da4fbd78c82cfef03b78dd03854f3d1ab394b2bc0f6afe3f27983ee03d67ab03d28b29f94375332ef03d6c2263750125579f99428fd819
DIST poppler-0.52.0.tar.xz 1692144 SHA256 528b661738839f9a25f6e580fcd2d5db007e0a1948580c6489f0062798ca1992 SHA512 8047af6cb6b1daff12f26463addbaaf532ef1f5c5185bc37eba6bc110438bc88687115bfec2802d738612fbc0c51ca5f7a5182989a23e30a05e9dab7ae4f5a52 WHIRLPOOL 024ae2ce4a68bbf77a6147fd73488cef3363f8a2d87eb11feb6148d2d22b2e04bac315e6b4ecfa8583c4e027f1f599343b1f93dce3efef80d4d8fecb200ae35f
+DIST poppler-0.54.0.tar.xz 1698392 SHA256 10cca9a67cc2e6f4f9024192b1067c444218bf94430891f43dc819d78536ca31 SHA512 1967cebdcc24c6a4ffc2ebea6940fafe315040afe5c8d797521897fe6ba851704af0e90122d3213d10d1dede7594b14198e6592c0666f4091e866c10cd104b43 WHIRLPOOL d33a7b315b4fe9c5b9c4746277ff2234269080e23fdd61f1fc7d7a3960beecfa30900fa8874890b5442ecefc105314b46f1f8bb0da661ad7770b5ce2b082a31a
diff --git a/app-text/poppler/files/poppler-0.53.0-respect-cflags.patch b/app-text/poppler/files/poppler-0.53.0-respect-cflags.patch
new file mode 100644
index 00000000000..3fdd9c20382
--- /dev/null
+++ b/app-text/poppler/files/poppler-0.53.0-respect-cflags.patch
@@ -0,0 +1,52 @@
+diff --git a/cmake/modules/PopplerMacros.cmake b/cmake/modules/PopplerMacros.cmake
+index 8e3ef399..5c20bf63 100644
+--- a/cmake/modules/PopplerMacros.cmake
++++ b/cmake/modules/PopplerMacros.cmake
+@@ -98,45 +98,14 @@ if(NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CONFIGURATION_TYPES)
+ set(CMAKE_BUILD_TYPE RelWithDebInfo)
+ endif(NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CONFIGURATION_TYPES)
+
+-if(CMAKE_COMPILER_IS_GNUCXX)
+ if (NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS "5.0.0")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wsuggest-override" )
+ endif()
+
+- # set the default compile warnings
+ set(DEFAULT_COMPILE_WARNINGS_NO)
+ set(DEFAULT_COMPILE_WARNINGS_YES "-Wall -Wcast-align -fno-exceptions -fno-check-new -fno-common")
+ set(DEFAULT_COMPILE_WARNINGS_KDE "-Wno-long-long -Wundef -D_XOPEN_SOURCE=600 -D_BSD_SOURCE -Wcast-align -Wconversion -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common")
+
+- set(CMAKE_CXX_FLAGS "-Wnon-virtual-dtor -Woverloaded-virtual ${CMAKE_CXX_FLAGS}")
+- set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O2 -g")
+- set(CMAKE_CXX_FLAGS_RELEASE "-O2 -DNDEBUG")
+- set(CMAKE_CXX_FLAGS_DEBUG "-g -O2 -fno-reorder-blocks -fno-schedule-insns -fno-inline")
+- set(CMAKE_CXX_FLAGS_DEBUGFULL "-g3 -fno-inline")
+- set(CMAKE_CXX_FLAGS_PROFILE "-g3 -fno-inline -ftest-coverage -fprofile-arcs")
+- set(CMAKE_C_FLAGS "-std=c99")
+- set(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -g")
+- set(CMAKE_C_FLAGS_RELEASE "-O2 -DNDEBUG")
+- set(CMAKE_C_FLAGS_DEBUG "-g -O2 -fno-reorder-blocks -fno-schedule-insns -fno-inline")
+- set(CMAKE_C_FLAGS_DEBUGFULL "-g3 -fno-inline")
+- set(CMAKE_C_FLAGS_PROFILE "-g3 -fno-inline -ftest-coverage -fprofile-arcs")
+-
+- poppler_check_link_flag("-Wl,--as-needed" GCC_HAS_AS_NEEDED)
+- if(GCC_HAS_AS_NEEDED)
+- set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--as-needed")
+- set(CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--as-needed")
+- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--as-needed")
+- endif(GCC_HAS_AS_NEEDED)
+-endif (CMAKE_COMPILER_IS_GNUCXX)
+-
+-if(CMAKE_C_COMPILER MATCHES "icc")
+- set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O2 -g")
+- set(CMAKE_CXX_FLAGS_RELEASE "-O2 -DNDEBUG")
+- set(CMAKE_CXX_FLAGS_DEBUG "-O2 -g -0b0 -noalign")
+- set(CMAKE_CXX_FLAGS_DEBUGFULL "-g -Ob0 -noalign")
+- set(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -g")
+- set(CMAKE_C_FLAGS_RELEASE "-O2 -DNDEBUG")
+- set(CMAKE_C_FLAGS_DEBUG "-O2 -g -Ob0 -noalign")
+- set(CMAKE_C_FLAGS_DEBUGFULL "-g -Ob0 -noalign")
+-endif(CMAKE_C_COMPILER MATCHES "icc")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Woverloaded-virtual")
+
++ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99")
diff --git a/app-text/poppler/poppler-0.54.0.ebuild b/app-text/poppler/poppler-0.54.0.ebuild
new file mode 100644
index 00000000000..289730d1abc
--- /dev/null
+++ b/app-text/poppler/poppler-0.54.0.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils toolchain-funcs xdg-utils
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.freedesktop.org/git/${PN}/${PN}"
+ SLOT="0/9999"
+else
+ SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ SLOT="0/67" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+fi
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="https://poppler.freedesktop.org/"
+
+LICENSE="GPL-2"
+IUSE="cairo cjk curl cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png qt4 qt5 tiff +utils"
+
+# No test data provided
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=media-libs/fontconfig-2.6.0
+ >=media-libs/freetype-2.3.9
+ sys-libs/zlib
+ cairo? (
+ dev-libs/glib:2
+ >=x11-libs/cairo-1.10.0
+ introspection? ( >=dev-libs/gobject-introspection-1.32.1:= )
+ )
+ curl? ( net-misc/curl )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( media-libs/openjpeg:2= )
+ lcms? ( media-libs/lcms:2 )
+ nss? ( >=dev-libs/nss-3.19:0 )
+ png? ( media-libs/libpng:0= )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtxml:5
+ )
+ tiff? ( media-libs/tiff:0 )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ cjk? ( >=app-text/poppler-data-0.4.7 )
+"
+
+DOCS=(AUTHORS NEWS README README-XPDF TODO)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.26.0-qt5-dependencies.patch"
+ "${FILESDIR}/${PN}-0.28.1-fix-multilib-configuration.patch"
+ "${FILESDIR}/${PN}-0.53.0-respect-cflags.patch"
+ "${FILESDIR}/${PN}-0.33.0-openjpeg2.patch"
+ "${FILESDIR}/${PN}-0.40-FindQt4.patch"
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Clang doesn't grok this flag, the configure nicely tests that, but
+ # cmake just uses it, so remove it if we use clang
+ if [[ ${CC} == clang ]] ; then
+ sed -i -e 's/-fno-check-new//' cmake/modules/PopplerMacros.cmake || die
+ fi
+
+ if ! grep -Fq 'cmake_policy(SET CMP0002 OLD)' CMakeLists.txt ; then
+ sed '/^cmake_minimum_required/acmake_policy(SET CMP0002 OLD)' \
+ -i CMakeLists.txt || die
+ else
+ einfo "policy(SET CMP0002 OLD) - workaround can be removed"
+ fi
+}
+
+src_configure() {
+ xdg_environment_reset
+ local mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT4_TESTS=OFF
+ -DBUILD_QT5_TESTS=OFF
+ -DBUILD_CPP_TESTS=OFF
+ -DENABLE_SPLASH=ON
+ -DENABLE_ZLIB=ON
+ -DENABLE_ZLIB_UNCOMPRESS=OFF
+ -DENABLE_XPDF_HEADERS=ON
+ -DENABLE_LIBCURL="$(usex curl)"
+ -DENABLE_CPP="$(usex cxx)"
+ -DENABLE_UTILS="$(usex utils)"
+ -DSPLASH_CMYK=OFF
+ -DUSE_FIXEDPOINT=OFF
+ -DUSE_FLOAT=OFF
+ -DWITH_Cairo="$(usex cairo)"
+ -DWITH_GObjectIntrospection="$(usex introspection)"
+ -DWITH_JPEG="$(usex jpeg)"
+ -DWITH_NSS3="$(usex nss)"
+ -DWITH_PNG="$(usex png)"
+ -DWITH_Qt4="$(usex qt4)"
+ $(cmake-utils_use_find_package qt5 Qt5Core)
+ -DWITH_TIFF="$(usex tiff)"
+ )
+ if use jpeg2k; then
+ mycmakeargs+=(-DENABLE_LIBOPENJPEG=openjpeg2)
+ else
+ mycmakeargs+=(-DENABLE_LIBOPENJPEG=)
+ fi
+ if use lcms; then
+ mycmakeargs+=(-DENABLE_CMS=lcms2)
+ else
+ mycmakeargs+=(-DENABLE_CMS=)
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # live version doesn't provide html documentation
+ if use cairo && use doc && [[ ${PV} != 9999 ]]; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/*
+ fi
+}
diff --git a/app-text/poppler/poppler-9999.ebuild b/app-text/poppler/poppler-9999.ebuild
index b0f1d1b7e7d..4f1e5562753 100644
--- a/app-text/poppler/poppler-9999.ebuild
+++ b/app-text/poppler/poppler-9999.ebuild
@@ -12,7 +12,7 @@ if [[ "${PV}" == "9999" ]] ; then
else
SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- SLOT="0/66" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+ SLOT="0/67" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
fi
DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
@@ -64,7 +64,7 @@ DOCS=(AUTHORS NEWS README README-XPDF TODO)
PATCHES=(
"${FILESDIR}/${PN}-0.26.0-qt5-dependencies.patch"
"${FILESDIR}/${PN}-0.28.1-fix-multilib-configuration.patch"
- "${FILESDIR}/${PN}-0.28.1-respect-cflags.patch"
+ "${FILESDIR}/${PN}-0.53.0-respect-cflags.patch"
"${FILESDIR}/${PN}-0.33.0-openjpeg2.patch"
"${FILESDIR}/${PN}-0.40-FindQt4.patch"
)
@@ -77,6 +77,13 @@ src_prepare() {
if [[ ${CC} == clang ]] ; then
sed -i -e 's/-fno-check-new//' cmake/modules/PopplerMacros.cmake || die
fi
+
+ if ! grep -Fq 'cmake_policy(SET CMP0002 OLD)' CMakeLists.txt ; then
+ sed '/^cmake_minimum_required/acmake_policy(SET CMP0002 OLD)' \
+ -i CMakeLists.txt || die
+ else
+ einfo "policy(SET CMP0002 OLD) - workaround can be removed"
+ fi
}
src_configure() {