summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-07-18 01:13:16 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-07-25 15:03:58 +0200
commit3919e1b5f826612ff664ca29aab01e937047864f (patch)
tree63ce30df4f628303acf843aa1a781727f0d85c6d
parentmedia-video/mpv: verbump to 0.18.1 (diff)
downloadgentoo-3919e1b5f826612ff664ca29aab01e937047864f.tar.gz
gentoo-3919e1b5f826612ff664ca29aab01e937047864f.tar.bz2
gentoo-3919e1b5f826612ff664ca29aab01e937047864f.zip
media-video/mpv: backport build, memleak, AV sync fixes for 0.18.0
We'll keep 0.18.0 longer than usual as 0.18.1 changed how volume levels work in a partially incompatible way. This causes problems at least in smplayer, see Gentoo bug 588584. Package-Manager: portage-2.3.0 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--media-video/mpv/files/0.18.0/mpv-0.18.0-fix-doc-build.patch23
-rw-r--r--media-video/mpv/files/0.18.0/mpv-0.18.0-fix-fbo-resize-memleak.patch27
-rw-r--r--media-video/mpv/files/0.18.0/mpv-0.18.0-fix-height-alignment-on-xv.patch1
-rw-r--r--media-video/mpv/files/0.18.0/mpv-0.18.0-fix-initial-av-sync.patch42
-rw-r--r--media-video/mpv/mpv-0.18.0-r1.ebuild305
5 files changed, 397 insertions, 1 deletions
diff --git a/media-video/mpv/files/0.18.0/mpv-0.18.0-fix-doc-build.patch b/media-video/mpv/files/0.18.0/mpv-0.18.0-fix-doc-build.patch
new file mode 100644
index 000000000000..26c8f72d4dae
--- /dev/null
+++ b/media-video/mpv/files/0.18.0/mpv-0.18.0-fix-doc-build.patch
@@ -0,0 +1,23 @@
+commit 4a4a9f330281ad11eb39a013bf7308063767bab8
+Author: Martin Herkt <lachs0r@srsfckn.biz>
+Date: Fri Jul 15 12:57:12 2016 +0200
+
+man: fix PDF build error
+
+ReportLab really doesn’t like breaking inline literals, so insert an
+explicit line break.
+
+Fixes #3338
+
+diff --git a/DOCS/man/options.rst b/DOCS/man/options.rst
+index 9a251ae..74d17a6 100644
+--- a/DOCS/man/options.rst
++++ b/DOCS/man/options.rst
+@@ -588,6 +588,7 @@ Video
+ :videotoolbox: requires ``--vo=opengl`` (OS X 10.8 and up only)
+ :videotoolbox-copy: copies video back into system RAM (OS X 10.8 and up only)
+ :dxva2: requires ``--vo=opengl:backend=angle`` or
++
+ ``--vo=opengl:backend=dxinterop`` (Windows only)
+ :dxva2-copy: copies video back to system RAM (Windows only)
+ :d3d11va: requires ``--vo=opengl:backend=angle`` (Windows only)
diff --git a/media-video/mpv/files/0.18.0/mpv-0.18.0-fix-fbo-resize-memleak.patch b/media-video/mpv/files/0.18.0/mpv-0.18.0-fix-fbo-resize-memleak.patch
new file mode 100644
index 000000000000..9407f15283d5
--- /dev/null
+++ b/media-video/mpv/files/0.18.0/mpv-0.18.0-fix-fbo-resize-memleak.patch
@@ -0,0 +1,27 @@
+commit 3abf9c9204e2fcbc1910deb102efab4ab9d8c149
+Author: Niklas Haas <git@nand.wakku.to>
+Date: Wed Jun 8 17:32:40 2016 +0200
+
+vo_opengl: don't constantly resize the output FBO
+
+Commit 883d3114 seems to have (accidentally?) dropped the FBOTEX_FUZZY
+from the output_fbo resize, which means that current master will keep
+resizing and resizing the FBO as you change the window size, introducing
+severe memory leaking after a while. (Not sure why that would cause
+memory leaks, but I blame nvidia)
+
+Either way, it's bad for performance too, so it's worth fixing.
+
+diff --git a/video/out/opengl/video.c b/video/out/opengl/video.c
+index bd1eb89..6c7646b 100644
+--- a/video/out/opengl/video.c
++++ b/video/out/opengl/video.c
+@@ -2791,7 +2791,7 @@ void gl_video_render_frame(struct gl_video *p, struct vo_frame *frame, int fbo)
+ {
+ fbotex_change(&p->output_fbo, p->gl, p->log,
+ p->vp_w, abs(p->vp_h),
+- p->opts.fbo_format, 0);
++ p->opts.fbo_format, FBOTEX_FUZZY);
+ dest_fbo = p->output_fbo.fbo;
+ p->output_fbo_valid = true;
+ }
diff --git a/media-video/mpv/files/0.18.0/mpv-0.18.0-fix-height-alignment-on-xv.patch b/media-video/mpv/files/0.18.0/mpv-0.18.0-fix-height-alignment-on-xv.patch
index 550b493b40f0..5033157251fb 100644
--- a/media-video/mpv/files/0.18.0/mpv-0.18.0-fix-height-alignment-on-xv.patch
+++ b/media-video/mpv/files/0.18.0/mpv-0.18.0-fix-height-alignment-on-xv.patch
@@ -11,7 +11,6 @@ makes sense, so it can't certainly be considered server misbehavior.
Do 2 things against this: allow if the server returns a larger image (we
just crop it then), and also allocate a properly aligned image in the
first place.
----
diff --git a/video/out/vo_xv.c b/video/out/vo_xv.c
index 1e7ae7c..a5a4728 100644
diff --git a/media-video/mpv/files/0.18.0/mpv-0.18.0-fix-initial-av-sync.patch b/media-video/mpv/files/0.18.0/mpv-0.18.0-fix-initial-av-sync.patch
new file mode 100644
index 000000000000..c2cacc3bff7a
--- /dev/null
+++ b/media-video/mpv/files/0.18.0/mpv-0.18.0-fix-initial-av-sync.patch
@@ -0,0 +1,42 @@
+commit 614efea3e67a435f3330820c3dc8b402535641e8
+Author: wm4 <wm4@nowhere>
+Date: Fri Jul 1 15:51:34 2016 +0200
+
+ad_lavc: work around braindead ffmpeg behavior
+
+The libavcodec wmapro decoder will skip some bytes at the start of the
+first packet and return each time. It will not return any audio data in
+this state.
+
+Our own code as well as libavcodec's new API handling
+(avcodec_send_packet() etc.) discard the PTS on the first return, which
+means the PTS is never known for the first packet. This results in a
+"Failed audio resync." message.
+
+Fixy it by remember the PTS in next_pts. This field is used only if the
+decoder outputs no PTS, and is updated after each frame - and thus
+should be safe to set.
+
+(Possibly this should be fixed in libavcodec new API handling by not
+setting the PTS to NOPTS as long as no real data has been output. It
+could even interpolate the PTS if the timebase is known.)
+
+Fixes the failure message seen in #3297.
+
+diff --git a/audio/decode/ad_lavc.c b/audio/decode/ad_lavc.c
+index f48993f..0316f6b 100644
+--- a/audio/decode/ad_lavc.c
++++ b/audio/decode/ad_lavc.c
+@@ -186,6 +186,12 @@ static int decode_packet(struct dec_audio *da, struct demux_packet *mpkt,
+ struct priv *priv = da->priv;
+ AVCodecContext *avctx = priv->avctx;
+
++ // If the decoder discards the timestamp for some reason, we use the
++ // interpolated PTS. Initialize it so that it works for the initial
++ // packet as well.
++ if (mpkt && priv->next_pts == MP_NOPTS_VALUE)
++ priv->next_pts = mpkt->pts;
++
+ int in_len = mpkt ? mpkt->len : 0;
+
+ AVPacket pkt;
diff --git a/media-video/mpv/mpv-0.18.0-r1.ebuild b/media-video/mpv/mpv-0.18.0-r1.ebuild
new file mode 100644
index 000000000000..a8338dd7e804
--- /dev/null
+++ b/media-video/mpv/mpv-0.18.0-r1.ebuild
@@ -0,0 +1,305 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+PYTHON_REQ_USE='threads(+)'
+
+WAF_PV=1.8.12
+
+inherit fdo-mime gnome2-utils pax-utils python-any-r1 toolchain-funcs waf-utils
+
+DESCRIPTION="Media player based on MPlayer and mplayer2"
+HOMEPAGE="https://mpv.io/"
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://github.com/mpv-player/mpv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+ DOCS=( RELEASE_NOTES )
+else
+ EGIT_REPO_URI="git://github.com/mpv-player/mpv.git"
+ inherit git-r3
+fi
+SRC_URI+=" https://waf.io/waf-${WAF_PV}"
+DOCS+=( README.md )
+
+# See Copyright in sources and Gentoo bug 506946. Waf is BSD, libmpv is ISC.
+LICENSE="GPL-2+ BSD ISC"
+SLOT="0"
+IUSE="aqua +alsa archive bluray cdda +cli coreaudio doc drm dvb dvd +egl +enca
+ encode gbm +iconv jack jpeg lcms +libass libav libcaca libguess libmpv lua
+ luajit openal +opengl oss pulseaudio raspberry-pi rubberband samba -sdl
+ selinux test uchardet v4l vaapi vdpau vf-dlopen wayland +X xinerama
+ +xscreensaver +xv zsh-completion"
+
+REQUIRED_USE="
+ || ( cli libmpv )
+ aqua? ( opengl )
+ egl? ( || ( gbm X wayland ) )
+ enca? ( iconv )
+ gbm? ( drm egl )
+ lcms? ( || ( opengl egl ) )
+ libguess? ( iconv )
+ luajit? ( lua )
+ uchardet? ( iconv )
+ v4l? ( || ( alsa oss ) )
+ vaapi? ( || ( gbm X wayland ) )
+ vdpau? ( X )
+ wayland? ( egl )
+ xinerama? ( X )
+ xscreensaver? ( X )
+ xv? ( X )
+ zsh-completion? ( cli )
+"
+
+COMMON_DEPEND="
+ !libav? ( >=media-video/ffmpeg-2.4:0=[encode?,threads,vaapi?,vdpau?] )
+ libav? ( >=media-video/libav-11:0=[encode?,threads,vaapi?,vdpau?] )
+ sys-libs/zlib
+ alsa? ( >=media-libs/alsa-lib-1.0.18 )
+ archive? ( >=app-arch/libarchive-3.0.0:= )
+ bluray? ( >=media-libs/libbluray-0.3.0 )
+ cdda? ( dev-libs/libcdio-paranoia )
+ drm? ( x11-libs/libdrm )
+ dvb? ( virtual/linuxtv-dvb-headers )
+ dvd? (
+ >=media-libs/libdvdnav-4.2.0
+ >=media-libs/libdvdread-4.1.0
+ )
+ egl? ( media-libs/mesa[egl,gbm(-)?,wayland(-)?] )
+ iconv? (
+ virtual/libiconv
+ enca? ( app-i18n/enca )
+ libguess? ( >=app-i18n/libguess-1.0 )
+ uchardet? ( dev-libs/uchardet )
+ )
+ jack? ( virtual/jack )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( >=media-libs/lcms-2.6:2 )
+ libass? (
+ >=media-libs/libass-0.12.1:=[fontconfig,harfbuzz]
+ virtual/ttf-fonts
+ )
+ libcaca? ( >=media-libs/libcaca-0.99_beta18 )
+ lua? (
+ !luajit? ( <dev-lang/lua-5.3:= )
+ luajit? ( dev-lang/luajit:2 )
+ )
+ openal? ( >=media-libs/openal-1.13 )
+ opengl? ( !aqua? ( virtual/opengl ) )
+ pulseaudio? ( media-sound/pulseaudio )
+ raspberry-pi? (
+ >=media-libs/raspberrypi-userland-0_pre20160305-r1
+ media-libs/mesa[egl,gles2]
+ )
+ rubberband? ( >=media-libs/rubberband-1.8.0 )
+ samba? ( net-fs/samba )
+ sdl? ( media-libs/libsdl2[sound,threads,video,X?,wayland?] )
+ v4l? ( media-libs/libv4l )
+ vaapi? ( >=x11-libs/libva-1.4.0[drm?,X?,wayland?] )
+ wayland? (
+ >=dev-libs/wayland-1.6.0
+ >=x11-libs/libxkbcommon-0.3.0
+ )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ >=x11-libs/libXrandr-1.2.0
+ opengl? ( x11-libs/libXdamage )
+ vdpau? ( >=x11-libs/libvdpau-0.2 )
+ xinerama? ( x11-libs/libXinerama )
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ xv? ( x11-libs/libXv )
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-lang/perl-5.8
+ dev-python/docutils
+ virtual/pkgconfig
+ doc? ( dev-python/rst2pdf )
+ test? ( >=dev-util/cmocka-1.0.0 )
+"
+RDEPEND="${COMMON_DEPEND}
+ selinux? ( sec-policy/selinux-mplayer )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PV}/${P}-fix-height-alignment-on-xv.patch"
+ "${FILESDIR}/${PV}/${P}-fix-initial-av-sync.patch"
+ "${FILESDIR}/${PV}/${P}-fix-fbo-resize-memleak.patch"
+ "${FILESDIR}/${PV}/${P}-fix-doc-build.patch"
+)
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && ! tc-has-tls && use vaapi && use egl; then
+ die "Your compiler lacks C++11 TLS support. Use GCC>=4.8.0 or Clang>=3.3."
+ fi
+}
+
+src_prepare() {
+ cp "${DISTDIR}/waf-${WAF_PV}" "${S}"/waf || die
+ chmod +x "${S}"/waf || die
+ default_src_prepare
+}
+
+src_configure() {
+ local mywafargs=(
+ --confdir="${EPREFIX}/etc/${PN}"
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+
+ $(usex cli '' '--disable-cplayer')
+ $(use_enable libmpv libmpv-shared)
+
+ # See deep down below for build-date.
+ --disable-libmpv-static
+ --disable-static-build
+ --disable-optimize # Don't add '-O2' to CFLAGS.
+ --disable-debug-build # Don't add '-g' to CFLAGS.
+
+ $(use_enable doc html-build)
+ $(use_enable doc pdf-build)
+ $(use_enable vf-dlopen vf-dlopen-filters)
+ $(use_enable zsh-completion zsh-comp)
+ $(use_enable test)
+
+ $(use_enable iconv)
+ $(use_enable samba libsmbclient)
+ $(use_enable lua)
+ $(usex luajit '--lua=luajit' '')
+ $(use_enable libass)
+ $(use_enable libass libass-osd)
+ $(use_enable encode encoding)
+ $(use_enable bluray libbluray)
+ $(use_enable dvd dvdread)
+ $(use_enable dvd dvdnav)
+ $(use_enable cdda)
+ $(use_enable enca)
+ $(use_enable libguess)
+ $(use_enable uchardet)
+ $(use_enable rubberband)
+ $(use_enable lcms lcms2)
+ --disable-vapoursynth # Only available in overlays.
+ --disable-vapoursynth-lazy
+ $(use_enable archive libarchive)
+
+ --enable-libavdevice
+
+ # Audio outputs:
+ $(use_enable sdl sdl2) # Listed under audio, but also includes video.
+ --disable-sdl1
+ $(use_enable oss oss-audio)
+ --disable-rsound # Only available in overlays.
+ $(use_enable pulseaudio pulse)
+ $(use_enable jack)
+ $(use_enable openal)
+ --disable-opensles
+ $(use_enable alsa)
+ $(use_enable coreaudio)
+
+ # Video outputs:
+ $(use_enable aqua cocoa)
+ $(use_enable drm)
+ $(use_enable gbm)
+ $(use_enable wayland)
+ $(use_enable X x11)
+ $(use_enable xscreensaver xss)
+ $(use_enable X xext)
+ $(use_enable xv)
+ $(use_enable xinerama)
+ $(use_enable X xrandr)
+ $(usex opengl "$(use_enable aqua gl-cocoa)" '--disable-gl-cocoa')
+ $(usex opengl "$(use_enable X gl-x11)" '--disable-gl-x11')
+ $(usex egl "$(use_enable X egl-x11)" '--disable-egl-x11')
+ $(usex egl "$(use_enable gbm egl-drm)" '--disable-egl-drm')
+ $(use_enable wayland gl-wayland)
+ $(use_enable vdpau)
+ $(usex vdpau "$(use_enable opengl vdpau-gl-x11)" '--disable-vdpau-gl-x11')
+ $(use_enable vaapi) # See below for vaapi-glx, vaapi-x-egl.
+ $(usex vaapi "$(use_enable X vaapi-x11)" '--disable-vaapi-x11')
+ $(usex vaapi "$(use_enable wayland vaapi-wayland)" '--disable-vaapi-wayland')
+ $(usex vaapi "$(use_enable gbm vaapi-drm)" '--disable-vaapi-drm')
+ $(use_enable libcaca caca)
+ $(use_enable jpeg)
+ --disable-android
+ $(use_enable raspberry-pi rpi)
+ $(usex libmpv "$(use_enable opengl plain-gl)" '--disable-plain-gl')
+
+ # HWaccels:
+ # Automagic Video Toolbox HW acceleration. See Gentoo bug 577332.
+ $(use_enable vaapi vaapi-hwaccel)
+ # Automagic VDPAU HW acceleration. See Gentoo bug 558870.
+
+ # TV features:
+ $(use_enable v4l tv)
+ $(use_enable v4l tv-v4l2)
+ $(use_enable v4l libv4l2)
+ $(use_enable v4l audio-input)
+ $(use_enable dvb dvbin)
+
+ # Miscellaneous features:
+ --disable-apple-remote # Needs testing first. See Gentoo bug 577332.
+ )
+
+ if use vaapi && use X; then
+ mywafargs+=(
+ $(use_enable opengl vaapi-glx)
+ $(use_enable egl vaapi-x-egl)
+ )
+ fi
+
+ if ! use egl && ! use opengl && ! use raspberry-pi; then
+ mywafargs+=(--disable-gl)
+ fi
+
+ # Create reproducible non-live builds.
+ [[ ${PV} != *9999* ]] && mywafargs+=(--disable-build-date)
+
+ waf-utils_src_configure "${mywafargs[@]}"
+}
+
+src_install() {
+ waf-utils_src_install
+
+ if use cli && use luajit; then
+ pax-mark -m "${ED}"usr/bin/${PN}
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+
+ # bash-completion < 2.3-r1 already installs (mostly broken) mpv completion.
+ if use cli && ! has_version '<app-shells/bash-completion-2.3-r1' && \
+ ! has_version 'app-shells/mpv-bash-completion'; then
+ elog "If you want to have command-line completion via bash-completion,"
+ elog "please install app-shells/mpv-bash-completion."
+ fi
+
+ if use cli && [[ -n ${REPLACING_VERSIONS} ]] && \
+ has_version 'app-shells/mpv-bash-completion'; then
+ elog "If command-line completion doesn't work after mpv update,"
+ elog "please rebuild app-shells/mpv-bash-completion."
+ fi
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+src_test() {
+ cd "${S}"/build/test || die
+ for test in *; do
+ if [[ -x ${test} ]]; then
+ ./"${test}" || die "Test suite failed"
+ fi
+ done
+}