summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-08 00:41:29 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-08 00:42:17 +0200
commit39adcf5f9da1a7353317cb4c1f447a0d0b17a072 (patch)
treef2aa6d1730eb4e9469ef65cd75170ad16bafcccc
parentdev-perl/Module-Versions-Report: EAPI=8 bump (diff)
downloadgentoo-39adcf5f.tar.gz
gentoo-39adcf5f.tar.bz2
gentoo-39adcf5f.zip
dev-perl/MogileFS-Client-Async: version bump 0.031
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--dev-perl/MogileFS-Client-Async/Manifest1
-rw-r--r--dev-perl/MogileFS-Client-Async/MogileFS-Client-Async-0.031.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/MogileFS-Client-Async/Manifest b/dev-perl/MogileFS-Client-Async/Manifest
index c1d35baf267e..083deb658381 100644
--- a/dev-perl/MogileFS-Client-Async/Manifest
+++ b/dev-perl/MogileFS-Client-Async/Manifest
@@ -1 +1,2 @@
DIST MogileFS-Client-Async-0.030.tar.gz 24988 BLAKE2B b5b6ed607df8404114bd5e2a9e75171c3d126211564bbcb332d8264d80f9306b3a44f42ff10051f2812d16215e54353b723f0ea4fdee7ecf87ad637e042e6b5f SHA512 32746207f12723171815cdc2e8b401b594b7de34b30a4bc1315575e20cd908ec7ff85b79c9bb501c6f343ed6469ffb80192ae1bdb08c7d76ed53e8d2ef40fcb2
+DIST MogileFS-Client-Async-0.031.tar.gz 19503 BLAKE2B ff009f33b38c6ca28f745da2cb0cab594457098297d4a9978b8fafbfc7e6425444e1c2ad55724ffccdbf92d83221bfa07e5d07b34ef8552d69f2aa0657131801 SHA512 1de89701de5884490656ac9f18de63f3bdb595d100542978b3a22123a0e7c66570d1133f14098b83ff06e86f27373b5b21c0e364a48217defc742a8933e89a6c
diff --git a/dev-perl/MogileFS-Client-Async/MogileFS-Client-Async-0.031.0.ebuild b/dev-perl/MogileFS-Client-Async/MogileFS-Client-Async-0.031.0.ebuild
new file mode 100644
index 000000000000..23146aaf8f95
--- /dev/null
+++ b/dev-perl/MogileFS-Client-Async/MogileFS-Client-Async-0.031.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=DLAMBLEY
+DIST_VERSION=${PV%.0}
+inherit perl-module
+
+DESCRIPTION="MogileFS Client using AnyEvent non-blocking IO"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-perl/AnyEvent
+ dev-perl/AnyEvent-HTTP
+ dev-perl/File-Slurp
+ dev-perl/IO-AIO
+ dev-perl/libwww-perl
+ >=dev-perl/Linux-PipeMagic-0.30.0
+ >=dev-perl/MogileFS-Client-1.160.0
+ dev-perl/Try-Tiny
+ dev-perl/namespace-clean
+"
+BDEPEND="${RDEPEND}
+ test? (
+ >=dev-perl/Test-Exception-0.310.0
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+# Tests only available if you have a local mogilefsd on 127.0.0.1:7001
+DIST_TEST=skip