summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-08-11 23:35:50 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-08-12 01:12:28 -0400
commit39bdd7d511b051099cd7bee3fd1910d6458ebb36 (patch)
treef75a5da0960681ccb50f48e9600302a35042c8cf
parentmate-extra/mate-power-manager: 1.12.x vbump, add gtk3, import from project repo (diff)
downloadgentoo-39bdd7d511b051099cd7bee3fd1910d6458ebb36.tar.gz
gentoo-39bdd7d511b051099cd7bee3fd1910d6458ebb36.tar.bz2
gentoo-39bdd7d511b051099cd7bee3fd1910d6458ebb36.zip
mate-extra/mate-system-monitor: 1.12.x vbump, add gtk3, import from project repo
Package-Manager: portage-2.3.0
-rw-r--r--mate-extra/mate-system-monitor/Manifest1
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.12.2.ebuild54
-rw-r--r--mate-extra/mate-system-monitor/metadata.xml3
3 files changed, 58 insertions, 0 deletions
diff --git a/mate-extra/mate-system-monitor/Manifest b/mate-extra/mate-system-monitor/Manifest
index d02b24dbf6eb..c2c5cd22a34a 100644
--- a/mate-extra/mate-system-monitor/Manifest
+++ b/mate-extra/mate-system-monitor/Manifest
@@ -1 +1,2 @@
DIST mate-system-monitor-1.10.1.tar.xz 2129620 SHA256 d5428990f9ba2a864a9c4af74c626c3e8f46f0b0468925209ad51f2d09304774 SHA512 a80922315d387eda99223ecc6f44a7608a3ef2d300ef80f10e35aede83783407f996935f7e106d342dcd91b8681158b587a5c1d1192724040e6bd99409cae6ec WHIRLPOOL 0e2f4d2e8884d3f6e4dcd1caf3b81866d2e7d0cd2dad679c3201ebd37afcb038c14df1a2245aa4b5e3fcade08243c2ad7a4a9d1745b758c4d57ba6f8ce55f4b4
+DIST mate-system-monitor-1.12.2.tar.xz 2114504 SHA256 78b91ae43fd0f06e0577d71d3b92b9c03ff2dc8809ba2b06dc0c4dc9e93683f5 SHA512 f001d36b7a343cba68bf76094abad4e07cc89537c71dba873bb5ffc61045f440a319e3db8d5ee55ff301f52dbdad8b275ca71a4ab6c5fbe34d75c2e65edd7c23 WHIRLPOOL 7270766f4434cb0e489f3f1ef805586987751fbea6a0a020df8fa7fa38dbbf264d0d1f3694fbba8e9d14cf2ddaee217ac562a391b4b87f1033cf2850067ae1a0
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.12.2.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.12.2.ebuild
new file mode 100644
index 000000000000..3304a90976b9
--- /dev/null
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.12.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="The MATE System Monitor"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="gtk3 systemd"
+
+RDEPEND="
+ >=dev-cpp/glibmm-2.26:2
+ >=dev-libs/dbus-glib-0.70:0
+ >=dev-libs/glib-2.36:2
+ dev-libs/libsigc++:2
+ >=dev-libs/libxml2-2:2
+ >=gnome-base/libgtop-2.23.1:2=
+ >=gnome-base/librsvg-2.35:2
+ >=sys-apps/dbus-0.7:0
+ x11-libs/cairo:0
+ x11-libs/gdk-pixbuf:2
+ virtual/libintl:0
+ !gtk3? (
+ >=dev-cpp/gtkmm-2.22:2.4
+ >=x11-libs/gtk+-2.20:2
+ >=x11-libs/libwnck-2.5:1
+ )
+ gtk3? (
+ >=dev-cpp/gtkmm-3.0:3.0
+ >=x11-libs/gtk+-3.0:3
+ >=x11-libs/libwnck-2.91:3
+ )
+ systemd? ( sys-apps/systemd )"
+
+DEPEND="${RDEPEND}
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.50.1:*
+ sys-devel/gettext:*
+ >=sys-devel/autoconf-2.63:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ --with-gtk=$(usex gtk3 3.0 2.0) \
+ $(use_enable systemd)
+}
diff --git a/mate-extra/mate-system-monitor/metadata.xml b/mate-extra/mate-system-monitor/metadata.xml
index d013f2f53d9a..8016e53ab1f3 100644
--- a/mate-extra/mate-system-monitor/metadata.xml
+++ b/mate-extra/mate-system-monitor/metadata.xml
@@ -5,6 +5,9 @@
<email>mate@gentoo.org</email>
<name>Gentoo MATE Desktop</name>
</maintainer>
+ <use>
+ <flag name="gtk3">Build with GTK+3 instead of GTK+2</flag>
+ </use>
<upstream>
<remote-id type="github">mate-desktop/mate-system-monitor</remote-id>
</upstream>