summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-10-25 17:53:54 -0400
committerMatt Turner <mattst88@gentoo.org>2020-10-25 17:56:36 -0400
commit39d84c6bc0772a2f84567b00098c540becb956c1 (patch)
treeeff95da60d09fc913ef3bc060c45b8681fa029df
parentx11-apps/fonttosfnt: Version bump to 1.2.0 (diff)
downloadgentoo-39d84c6bc0772a2f84567b00098c540becb956c1.tar.gz
gentoo-39d84c6bc0772a2f84567b00098c540becb956c1.tar.bz2
gentoo-39d84c6bc0772a2f84567b00098c540becb956c1.zip
x11-base/xcb-proto: Version bump to 1.14.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-base/xcb-proto/Manifest1
-rw-r--r--x11-base/xcb-proto/xcb-proto-1.14.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/x11-base/xcb-proto/Manifest b/x11-base/xcb-proto/Manifest
index 47e7fa482af7..b49c3f1b654a 100644
--- a/x11-base/xcb-proto/Manifest
+++ b/x11-base/xcb-proto/Manifest
@@ -1 +1,2 @@
+DIST xcb-proto-1.14.1.tar.xz 143588 BLAKE2B 24983ec26632e93ef2d0c854cd41272925b6f3aab2642701232b73bc37d200d794c46f438e4a4102484e6ac9723e78c923b99cc78ada3541f43eaf0ad7ebc863 SHA512 140fbf48483bacc7f6b70fdcf76f9e4ff0e87df9cb3a071cea47d8fe4574407cdefcfbd674099014d297e5fc010748e71d8609fca4cc32e8b25c634f928b727d
DIST xcb-proto-1.14.tar.xz 143384 BLAKE2B 60212b0f0ce039a64a2e6cbbc78564eeffc57cff20987b37dc780d8d97ae888a7dbfbbaadc6e0e4bedfc5d1e360f16318e3825ad8406de668d9c7c66cf7f4b5d SHA512 de66d568163b6da2be9d6c59984f3afa3acd119a781378638045fd68018665ef5c9af98f024e9962ba3eb7c7a4d85c27ba70ffafceb2324ccc6940f34de16690
diff --git a/x11-base/xcb-proto/xcb-proto-1.14.1.ebuild b/x11-base/xcb-proto/xcb-proto-1.14.1.ebuild
new file mode 100644
index 000000000000..911a6583b181
--- /dev/null
+++ b/x11-base/xcb-proto/xcb-proto-1.14.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+XORG_TARBALL_SUFFIX="xz"
+XORG_MODULE=proto/
+XORG_MULTILIB=yes
+XORG_STATIC=no
+
+inherit python-r1 xorg-3
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/proto/xcbproto"
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/xcbproto.git"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2
+"
+
+ECONF_SOURCE="${S}"
+
+multilib_src_configure() {
+ # Don't use Python to find sitedir here.
+ PYTHON=true default
+}
+
+src_compile() {
+ :
+}
+
+xcbgen_install() {
+ # Use eclass to find sitedir instead.
+ emake -C xcbgen install DESTDIR="${D}" pythondir="$(python_get_sitedir)"
+ python_optimize
+}
+
+multilib_src_install() {
+ # Restrict SUBDIRS to prevent xcbgen with empty sitedir.
+ emake install DESTDIR="${D}" SUBDIRS=src
+ multilib_is_native_abi && python_foreach_impl xcbgen_install
+}