summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-07 22:07:50 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-08 00:15:24 +0100
commit39e31a8102bed0989b6fb38867ca41242eb62b21 (patch)
tree7c17ba643ac6e30b549c3d57a0fa33356597f0f4
parentapp-portage/gentoopm: Remove old (diff)
downloadgentoo-39e31a8102bed0989b6fb38867ca41242eb62b21.tar.gz
gentoo-39e31a8102bed0989b6fb38867ca41242eb62b21.tar.bz2
gentoo-39e31a8102bed0989b6fb38867ca41242eb62b21.zip
app-portage/gentoopm: Limit to py3.8+ due to pkgcore
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-portage/gentoopm/gentoopm-0.3.2-r1.ebuild28
-rw-r--r--app-portage/gentoopm/gentoopm-9999.ebuild6
2 files changed, 31 insertions, 3 deletions
diff --git a/app-portage/gentoopm/gentoopm-0.3.2-r1.ebuild b/app-portage/gentoopm/gentoopm-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..9cd209e62733
--- /dev/null
+++ b/app-portage/gentoopm/gentoopm-0.3.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A common interface to Gentoo package managers"
+HOMEPAGE="https://github.com/mgorny/gentoopm/"
+SRC_URI="https://github.com/mgorny/gentoopm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+IUSE=""
+
+RDEPEND="
+ || (
+ >=sys-apps/pkgcore-0.9.4[${PYTHON_USEDEP}]
+ >=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}] )"
+PDEPEND="app-eselect/eselect-package-manager"
+
+python_test() {
+ esetup.py test
+}
diff --git a/app-portage/gentoopm/gentoopm-9999.ebuild b/app-portage/gentoopm/gentoopm-9999.ebuild
index 2dc9a2c3f698..787c12954d99 100644
--- a/app-portage/gentoopm/gentoopm-9999.ebuild
+++ b/app-portage/gentoopm/gentoopm-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_COMPAT=( python3_{8..9} )
EGIT_REPO_URI="https://github.com/mgorny/gentoopm.git"
inherit distutils-r1 git-r3