summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-25 09:50:30 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-25 10:39:42 +0100
commit3b4a75d0a12e1056b200878914842fb11f27683e (patch)
tree9ee091302efe6fe10e7f13ff858882c581f8cb51
parentdev-python/slimit: Set DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-3b4a75d0.tar.gz
gentoo-3b4a75d0.tar.bz2
gentoo-3b4a75d0.zip
dev-python/slimit: Call pytest directly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/slimit/slimit-0.8.1-r1.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/dev-python/slimit/slimit-0.8.1-r1.ebuild b/dev-python/slimit/slimit-0.8.1-r1.ebuild
index ca7d58331ceb..b5af60f39209 100644
--- a/dev-python/slimit/slimit-0.8.1-r1.ebuild
+++ b/dev-python/slimit/slimit-0.8.1-r1.ebuild
@@ -15,18 +15,13 @@ SRC_URI="https://github.com/rspivak/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/ply:=[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )"
PATCHES=( "${FILESDIR}/${P}-fix-python3.patch" )
+distutils_enable_tests pytest
+
python_compile() {
distutils-r1_python_compile
@@ -39,5 +34,5 @@ python_compile() {
}
python_test() {
- esetup.py pytest --addopts "${BUILD_DIR}" || die "Testing failed with ${EPYTHON}"
+ pytest -vv "${BUILD_DIR}" || die "Tests failed with ${EPYTHON}"
}