summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2021-01-26 22:41:18 -0500
committerJoonas Niilola <juippis@gentoo.org>2021-03-01 15:02:44 +0200
commit3b4b9adf10a07cabab2446b31aca597314763f73 (patch)
tree4c76002ec6b15dcdb72c828511b341a0abea8298
parentx11-libs/xapps: Fix meson script shebangs (diff)
downloadgentoo-3b4b9adf10a07cabab2446b31aca597314763f73.tar.gz
gentoo-3b4b9adf10a07cabab2446b31aca597314763f73.tar.bz2
gentoo-3b4b9adf10a07cabab2446b31aca597314763f73.zip
gnome-extra/cjs: Fix meson script shebangs
Bug: https://bugs.gentoo.org/766935 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--gnome-extra/cjs/cjs-4.8.2.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnome-extra/cjs/cjs-4.8.2.ebuild b/gnome-extra/cjs/cjs-4.8.2.ebuild
index 2daead9e520a..59ef8a7d5a6c 100644
--- a/gnome-extra/cjs/cjs-4.8.2.ebuild
+++ b/gnome-extra/cjs/cjs-4.8.2.ebuild
@@ -3,7 +3,9 @@
EAPI=7
-inherit meson pax-utils virtualx
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit meson pax-utils python-any-r1 virtualx
DESCRIPTION="Linux Mint's fork of gjs for Cinnamon"
HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cjs"
@@ -33,9 +35,15 @@ DEPEND="
)
"
BDEPEND="
+ ${PYTHON_DEPS}
virtual/pkgconfig
"
+src_prepare() {
+ default
+ python_fix_shebang build
+}
+
src_configure() {
local emesonargs=(
$(meson_feature cairo)