summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2020-09-17 08:30:28 -0400
committerMike Pagano <mpagano@gentoo.org>2020-09-17 08:30:28 -0400
commit3b918d8556cf803bb979f68652f43529bd0fc47b (patch)
treea7575d592075b36b838f4c9cf3bfeeb7ff92a0b6
parentdev-perl/Crypt-SMIME: Cleanup old 0.250.0-r1 (diff)
downloadgentoo-3b918d8556cf803bb979f68652f43529bd0fc47b.tar.gz
gentoo-3b918d8556cf803bb979f68652f43529bd0fc47b.tar.bz2
gentoo-3b918d8556cf803bb979f68652f43529bd0fc47b.zip
dev-util/idea-community: Version bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--dev-util/idea-community/Manifest1
-rw-r--r--dev-util/idea-community/idea-community-2020.2.2.202.7319.50.ebuild142
2 files changed, 143 insertions, 0 deletions
diff --git a/dev-util/idea-community/Manifest b/dev-util/idea-community/Manifest
index 1a1f40518d43..b14e2ee30e8e 100644
--- a/dev-util/idea-community/Manifest
+++ b/dev-util/idea-community/Manifest
@@ -1,4 +1,5 @@
DIST ideaIC-2.1.202.6948.69.tar.gz 529563846 BLAKE2B df3771c8ca85a276a1ed9db5e9483f922a98f25ab82061cc54dee791f84d44dcd7d813180d587a3a9f3cd91d10b83881a3d42da11ecee3be77dccbe2ee7e98c5 SHA512 bc32e01297785bfcf2a57f97e697b7ec8f894f49c5f27959ed3fd5bab6ade0cff8f0091847809f7ee5f7b7299c2bda3e4bdb83cadc68a7a3056242dd83c1c4b9
+DIST ideaIC-2.2.202.7319.50.tar.gz 529375561 BLAKE2B 08a77a1326b81e9d6299779bf48fb0b9be389572143bd92591bcdf6ede79ecf86b725dde634e1b8bd412dc0b886bde29169bb236fbc902ba509b468e79073e90 SHA512 f68fe18a824fd47b3b21f0a3dcd172652858aafa9f81d1db908b3adc82f925677d2ce48d0a06ad58354c06b30e01c36fff910b4eb7d5ec89c408a6a1ff017e8e
DIST jbr-11_0_2-linux-x64-b164.tar.gz 131483925 BLAKE2B fb9c55094aeb4a9e6b89ef41699252355895fa4bf55eaa0d3c0a637b6485b5a91a0445b5f4af1872b62cd67b639f7354e05770970d41dcfa58ffeda7ae43c5b6 SHA512 4f32940166cc8ad5a138866e18d4cbfcd07f4326a85c051b7a622c9dcb8ee4b6d493331ef24d0c01999134fa2a9bad901f026982c16780fdc5e6b9308821db34
DIST jbrx-8u202-linux-i586-b1483.37.tar.gz 80726147 BLAKE2B e4e5a076a541fd7153e861193ff4247c02ecbc144396ed28737afa7440f7771569b8d968b7c67b3dac333a89ff0b54cc9e5e76d1651b174cc7c0c21b1deb033c SHA512 53693f2ce994f4891807873ae3fe46ce60bee000b78be03c5d3df06b436328abe5b5d7e75d43e57f35f24187f49915187d034b39589e29806f55deeb14a029f2
DIST jbrx-8u202-linux-x64-b1483.37.tar.gz 81812743 BLAKE2B 86ddf0c8dc992a27e680caa821f54fa4d647a8bff78b9fdbef82996bfbba828a2f68f1a00ed64bd92ce24a62bfc6c0240837c396644c6e91244cb0d980b6c704 SHA512 cd31a3c4da7b8c65e9ae89326c2c8b260b51890258d30f64b1e8a7c6c1442bb2cb68ea2aa80387ce0c1a8f50e3533e8231f72c5935b639e3cf82bc1ffedee8e9
diff --git a/dev-util/idea-community/idea-community-2020.2.2.202.7319.50.ebuild b/dev-util/idea-community/idea-community-2020.2.2.202.7319.50.ebuild
new file mode 100644
index 000000000000..97ec35a8801d
--- /dev/null
+++ b/dev-util/idea-community/idea-community-2020.2.2.202.7319.50.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils desktop
+
+SLOT="0"
+PV_STRING="$(ver_cut 2-6)"
+MY_PV="$(ver_cut 1-3)"
+MY_PN="idea"
+# Using the most recent Jetbrains Runtime binaries available at the time of writing
+# As the exact bundled versions ( jre 11 build 159.30 and jre 8 build 1483.39 ) aren't
+# available separately
+JRE11_BASE="11_0_2"
+JRE11_VER="164"
+JRE_BASE="8u202"
+JRE_VER="1483.37"
+
+# distinguish settings for official stable releases and EAP-version releases
+if [[ "$(ver_cut 7)"x = "prex" ]]
+then
+ # upstream EAP
+ KEYWORDS="~arm64"
+ SRC_URI="https://download.jetbrains.com/idea/${MY_PN}IC-${PV_STRING}.tar.gz"
+else
+ # upstream stable
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ SRC_URI="https://download.jetbrains.com/idea/${MY_PN}IC-${MY_PV}-no-jbr.tar.gz -> ${MY_PN}IC-${PV_STRING}.tar.gz
+ jbr8? ( x86? ( https://bintray.com/jetbrains/intellij-jdk/download_file?file_path=jbrx-${JRE_BASE}-linux-i586-b${JRE_VER}.tar.gz -> jbrx-${JRE_BASE}-linux-i586-b${JRE_VER}.tar.gz )
+ amd64? ( https://bintray.com/jetbrains/intellij-jdk/download_file?file_path=jbrx-${JRE_BASE}-linux-x64-b${JRE_VER}.tar.gz -> jbrx-${JRE_BASE}-linux-x64-b${JRE_VER}.tar.gz ) )
+ jbr11? ( amd64? ( https://bintray.com/jetbrains/intellij-jdk/download_file?file_path=jbr-${JRE11_BASE}-linux-x64-b${JRE11_VER}.tar.gz -> jbr-${JRE11_BASE}-linux-x64-b${JRE11_VER}.tar.gz ) )"
+fi
+
+DESCRIPTION="A complete toolset for web, mobile and enterprise development"
+HOMEPAGE="https://www.jetbrains.com/idea"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 CC-BY-2.5 CDDL-1.1
+ codehaus-classworlds CPL-1.0 EPL-1.0 EPL-2.0 jbr8? ( GPL-2 )
+ jbr11? ( GPL-2 ) GPL-2 GPL-2-with-classpath-exception ISC
+ JDOM LGPL-2.1 LGPL-2.1+ LGPL-3-with-linking-exception MIT
+ MPL-1.0 MPL-1.1 OFL ZLIB"
+
+#Splitting custom-jdk into jbr8 and jbr11 as upstream now offers downloads with
+#either (or neither) bundled
+#Defaulting to jbr8 to match upstream
+IUSE="+jbr8 -jbr11"
+REQUIRED_USE="jbr8? ( !jbr11 )"
+
+DEPEND="!dev-util/${PN}:14
+ !dev-util/${PN}:15"
+RDEPEND="${DEPEND}
+ >=virtual/jdk-1.7:*
+ dev-java/jansi-native
+ dev-libs/libdbusmenu
+ =dev-util/lldb-9*"
+BDEPEND="dev-util/patchelf"
+RESTRICT="splitdebug"
+S="${WORKDIR}/${MY_PN}-IC-$(ver_cut 4-6)"
+
+QA_PREBUILT="opt/${PN}-${MY_PV}/*"
+
+# jbr11 binary doesn't unpack nicely into a single folder
+src_unpack() {
+ default_src_unpack
+ if use jbr11 ; then
+ mkdir jre64 && cd jre64 && unpack jbr-${JRE11_BASE}-linux-x64-b${JRE11_VER}.tar.gz
+ fi
+}
+
+src_prepare() {
+ if use amd64; then
+ JRE_DIR=jre64
+ else
+ JRE_DIR=jre
+ fi
+
+ if use jbr8; then
+ mv "${WORKDIR}/jre" ./"${JRE_DIR}"
+ PLUGIN_DIR="${S}/${JRE_DIR}/lib/${ARCH}"
+ else
+ PLUGIN_DIR="${S}/${JRE_DIR}/lib/"
+ fi
+
+ rm -vf ${PLUGIN_DIR}/libavplugin*
+ rm -vf "${S}"/plugins/maven/lib/maven3/lib/jansi-native/*/libjansi*
+ rm -vrf "${S}"/lib/pty4j-native/linux/ppc64le
+ rm -vf "${S}"/bin/libdbm64*
+
+ if [[ -d "${S}"/"${JRE_DIR}" ]]; then
+ for file in "${PLUGIN_DIR}"/{libfxplugins.so,libjfxmedia.so}
+ do
+ if [[ -f "$file" ]]; then
+ patchelf --set-rpath '$ORIGIN' $file || die
+ fi
+ done
+ fi
+
+ patchelf --replace-needed liblldb.so liblldb.so.9 "${S}"/plugins/Kotlin/bin/linux/LLDBFrontend || die "Unable to patch LLDBFrontend for lldb"
+
+ sed -i \
+ -e "\$a\\\\" \
+ -e "\$a#-----------------------------------------------------------------------" \
+ -e "\$a# Disable automatic updates as these are handled through Gentoo's" \
+ -e "\$a# package manager. See bug #704494" \
+ -e "\$a#-----------------------------------------------------------------------" \
+ -e "\$aide.no.platform.update=Gentoo" bin/idea.properties
+
+ eapply_user
+}
+
+src_install() {
+ local dir="/opt/${PN}-${MY_PV}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{format.sh,idea.sh,inspect.sh,printenv.py,restart.py,fsnotifier{,64}}
+ if use amd64; then
+ JRE_DIR=jre64
+ else
+ JRE_DIR=jre
+ fi
+ if use jbr8 || use jbr11 ; then
+ if use jbr8; then
+ JRE_BINARIES="java jjs keytool orbd pack200 policytool rmid rmiregistry servertool tnameserv unpack200"
+ else
+ JRE_BINARIES="jaotc java javapackager jjs jrunscript keytool pack200 rmid rmiregistry unpack200"
+ fi
+ if [[ -d ${JRE_DIR} ]]; then
+ for jrebin in $JRE_BINARIES; do
+ fperms 755 "${dir}"/"${JRE_DIR}"/bin/"${jrebin}"
+ done
+ fi
+ fi
+
+ make_wrapper "${PN}" "${dir}/bin/${MY_PN}.sh"
+ newicon "bin/${MY_PN}.png" "${PN}.png"
+ make_desktop_entry "${PN}" "IntelliJ Idea Community" "${PN}" "Development;IDE;"
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ mkdir -p "${D}/etc/sysctl.d/" || die
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
+}