summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-09-30 11:07:28 -0400
committerCraig Andrews <candrews@gentoo.org>2019-09-30 11:07:28 -0400
commit3b9ae6bac044f6115bf35f42c44cc9f7b2fe0344 (patch)
treeba249b6da9212417db47a94de39f281114313baf
parentdev-libs/rocm-device-libs: 2.8.0 version bump (diff)
downloadgentoo-3b9ae6ba.tar.gz
gentoo-3b9ae6ba.tar.bz2
gentoo-3b9ae6ba.zip
dev-libs/rocm-comgr: 2.8.0 version bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--dev-libs/rocm-comgr/Manifest1
-rw-r--r--dev-libs/rocm-comgr/files/rocm-comgr-2.8.0-dependencies.patch84
-rw-r--r--dev-libs/rocm-comgr/rocm-comgr-2.8.0.ebuild42
3 files changed, 127 insertions, 0 deletions
diff --git a/dev-libs/rocm-comgr/Manifest b/dev-libs/rocm-comgr/Manifest
index 0133d5015d71..d53d3bee1147 100644
--- a/dev-libs/rocm-comgr/Manifest
+++ b/dev-libs/rocm-comgr/Manifest
@@ -1,2 +1,3 @@
DIST rocm-comgr-2.6.0.tar.gz 1484343 BLAKE2B fcb496b4997d672640e3f75622e74085eeb9dfe83c88ae025530389d3cdca7628155168060e71f7a3ff915e933ffe70c7026720dc124d128d16ef4df397525e7 SHA512 b14e90603d2b6e17f6b0335ea35da2e5d7e31710f301d7a7f7751a45d996e3dbbfbf84a03e2e911e8798e72e77b87b5cd88317e897cb4de3ee5cf0e7c3222d68
DIST rocm-comgr-2.7.0.tar.gz 1500771 BLAKE2B 275ad4cab34d554f8a131101eda474926f7270a44a0af9941d8f1233c29b44b3efb3ba83c6b541d501a3e2fc751c591c0f6a993563bbacf539b5bcd04b23963b SHA512 afb4a7318c2e137db6ac0502041ed53e63783ec1ab458962b1b16f0f2f28e09ce2ae70d048b858740eca8bf06328858400a68bed4e91d7cfc4b7714a66d85bc9
+DIST rocm-comgr-2.8.0.tar.gz 85502 BLAKE2B 14e18191a475c3d05e324f15e3b2d0829eed56bfa625b48e217e6540836e005675a4ffdd0813664c7f61177431d0987499eb9a75ec83acfa0e554e954770fbc9 SHA512 516832f2a1be5e66d93dddfd1275861605afcb6e3410cb518e6d8647a25c18da058e37cbce8434d5b7133a2147c8c84dc48a485f7b855b74a3b49c9f7dae4a0e
diff --git a/dev-libs/rocm-comgr/files/rocm-comgr-2.8.0-dependencies.patch b/dev-libs/rocm-comgr/files/rocm-comgr-2.8.0-dependencies.patch
new file mode 100644
index 000000000000..3a0af258c054
--- /dev/null
+++ b/dev-libs/rocm-comgr/files/rocm-comgr-2.8.0-dependencies.patch
@@ -0,0 +1,84 @@
+https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/pull/19
+
+From 5f872ae4a059ac6a09669e301b8a60b11a25eb42 Mon Sep 17 00:00:00 2001
+From: Craig Andrews <candrews@integralblue.com>
+Date: Wed, 31 Jul 2019 11:51:17 -0400
+Subject: [PATCH 1/2] Link additional required LLVM libraries
+
+Without these additional required dependencies, linking fails with errors such as:
+`undefined reference to `llvm::errs()'`
+---
+ CMakeLists.txt | 19 +++++++++++++++++--
+ 1 file changed, 17 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 454b830..95e5799 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -185,7 +185,11 @@ add_subdirectory(yaml-cpp EXCLUDE_FROM_ALL)
+ include_directories(./yaml-cpp/include)
+
+ set(CLANG_LIBS
+- clangFrontendTool)
++ clangFrontendTool
++ clangFrontend
++ clangBasic
++ clangDriver
++ clangSerialization)
+
+ set(LLD_LIBS
+ lldELF
+@@ -193,8 +197,19 @@ set(LLD_LIBS
+
+ llvm_map_components_to_libnames(LLVM_LIBS
+ ${LLVM_TARGETS_TO_BUILD}
++ Option
+ DebugInfoDWARF
+- Symbolize)
++ Symbolize
++ Support
++ Object
++ BitWriter
++ MC
++ MCParser
++ MCDisassembler
++ Core
++ IRReader
++ CodeGen
++ Linker)
+
+ target_link_libraries(amd_comgr
+ PUBLIC
+
+From ffc4d18a7ae1fbd5c8807eec4ca8aed043524811 Mon Sep 17 00:00:00 2001
+From: Craig Andrews <candrews@integralblue.com>
+Date: Mon, 30 Sep 2019 10:52:12 -0400
+Subject: [PATCH 2/2] Link more required LLVM libraries
+
+Without these additional required dependencies, linking fails with errors such as:
+```
+in function `amd_comgr_index_list_metadata':
+<artificial>:(.text+0x4d4c): undefined reference to `llvm::msgpack::ArrayDocNode::operator[](unsigned long)'
+```
+and
+```
+undefined reference to `llvm::msgpack::Document::fromYAML(llvm::StringRef)'
+```
+---
+ CMakeLists.txt | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 95e5799..b6123a6 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -209,7 +209,8 @@ llvm_map_components_to_libnames(LLVM_LIBS
+ Core
+ IRReader
+ CodeGen
+- Linker)
++ Linker
++ BinaryFormat)
+
+ target_link_libraries(amd_comgr
+ PUBLIC
diff --git a/dev-libs/rocm-comgr/rocm-comgr-2.8.0.ebuild b/dev-libs/rocm-comgr/rocm-comgr-2.8.0.ebuild
new file mode 100644
index 000000000000..ff0ede91ae21
--- /dev/null
+++ b/dev-libs/rocm-comgr/rocm-comgr-2.8.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/"
+ inherit git-r3
+ S="${WORKDIR}/${P}/lib/comgr"
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/archive/roc-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCm-CompilerSupport-roc-${PV}/lib/comgr"
+ KEYWORDS="~amd64"
+fi
+PATCHES=(
+ "${FILESDIR}/${PN}-2.6.0-find-clang.patch"
+ "${FILESDIR}/${PN}-2.6.0-find-lld-includes.patch"
+ "${FILESDIR}/${PN}-2.8.0-dependencies.patch"
+)
+
+DESCRIPTION="Radeon Open Compute Code Object Manager"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport"
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND=">=dev-libs/rocm-device-libs-${PV}
+ >=sys-devel/llvm-roc-${PV}:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLLVM_DIR="${EPREFIX}/usr/lib/llvm/roc/"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/"
+ )
+ cmake-utils_src_configure
+}