summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-09-04 21:50:59 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-09-04 21:50:59 -0400
commit3c1b2ede04fd5a8bc278ca8c25be4aa837f02f91 (patch)
tree89b6a54af8ed283bd7d7b854fb2a2014d8d00fc1
parentnet-wireless/gr-iio: mostly import from pentoo (diff)
downloadgentoo-3c1b2ede04fd5a8bc278ca8c25be4aa837f02f91.tar.gz
gentoo-3c1b2ede04fd5a8bc278ca8c25be4aa837f02f91.tar.bz2
gentoo-3c1b2ede04fd5a8bc278ca8c25be4aa837f02f91.zip
net-misc/ntpsec: version bump to 1.1.2, bug #665188
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--net-misc/ntpsec/Manifest1
-rw-r--r--net-misc/ntpsec/ntpsec-1.1.2.ebuild154
2 files changed, 155 insertions, 0 deletions
diff --git a/net-misc/ntpsec/Manifest b/net-misc/ntpsec/Manifest
index c6ff344b44b5..b5913390c2d5 100644
--- a/net-misc/ntpsec/Manifest
+++ b/net-misc/ntpsec/Manifest
@@ -1,2 +1,3 @@
DIST ntpsec-1.0.0.tar.gz 2405862 BLAKE2B b1631491500cafa5d41761fe6cb2db523450ed7801d06678048d6b8878d93dbd1e9d7cb2081a8400421213cf78a6724220236149a7f719896d1e8e48f5337d85 SHA512 9fb06310508b30d2ae2d66212d7d87b00e8eea294cebc27eb70435d764bd639fcec234b66e78deafb700476c88e47afe2d1b463563008c32efbb0644dd611f43
DIST ntpsec-1.1.1.tar.gz 2451415 BLAKE2B 516c87f0710ecacfde27f801a5fc4a492e7871eb35cc3afb8a107e0c381cd9787a4af2d0b01e2cf5d4f43043afe042321e5bbd2299578723e870b2fa502646d2 SHA512 838ed81c94e14a3d8588670ce63a1c4f6216d2f79be5149ad6a845cec00bdf6d7fe77310ce9c33c4675d3db54e59c3d9d02ae4351913ffbd9a3883716c443f83
+DIST ntpsec-1.1.2.tar.gz 2458805 BLAKE2B e9ab493f60179ce94a5995287423c3a0038298b622b0dcffd5a299261a7b42fc8d0d04256726e049c625c0789882f601615eaa7169047e984a274f62e0cf40d2 SHA512 83d2d3bc59202f1e5f3e76eeb6810e575e24c6f392f20c25732a6881a0a0a9f72453b76b294399351ec4baf88bc64da089dc1340aee38576021659f81bcd0e19
diff --git a/net-misc/ntpsec/ntpsec-1.1.2.ebuild b/net-misc/ntpsec/ntpsec-1.1.2.ebuild
new file mode 100644
index 000000000000..680e3dcba1d5
--- /dev/null
+++ b/net-misc/ntpsec/ntpsec-1.1.2.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit flag-o-matic python-r1 waf-utils systemd user
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/NTPsec/ntpsec.git"
+ BDEPEND=""
+ KEYWORDS=""
+else
+ SRC_URI="ftp://ftp.ntpsec.org/pub/releases/${PN}-${PV}.tar.gz"
+ RESTRICT="mirror"
+ BDEPEND=""
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="The NTP reference implementation, refactored"
+HOMEPAGE="https://www.ntpsec.org/"
+
+NTPSEC_REFCLOCK=(
+ oncore trimble truetime gpsd jjy generic spectracom
+ shm pps hpgps zyfer arbiter nmea neoclock modem
+ local)
+
+IUSE_NTPSEC_REFCLOCK=${NTPSEC_REFCLOCK[@]/#/rclock_}
+
+LICENSE="HPND MIT BSD-2 BSD CC-BY-SA-4.0"
+SLOT="0"
+IUSE="${IUSE_NTPSEC_REFCLOCK} debug doc early gdb heat libressl nist ntpviz samba seccomp smear tests" #ionice
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# net-misc/pps-tools oncore,pps
+CDEPEND="${PYTHON_DEPS}
+ ${BDEPEND}
+ sys-libs/libcap
+ dev-python/psutil[${PYTHON_USEDEP}]
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( dev-libs/openssl:0= )
+ seccomp? ( sys-libs/libseccomp )
+"
+RDEPEND="${CDEPEND}
+ ntpviz? ( sci-visualization/gnuplot media-fonts/liberation-fonts )
+ !net-misc/ntp
+ !net-misc/openntpd
+"
+DEPEND="${CDEPEND}
+ app-text/asciidoc
+ app-text/docbook-xsl-stylesheets
+ sys-devel/bison
+ rclock_oncore? ( net-misc/pps-tools )
+ rclock_pps? ( net-misc/pps-tools )
+"
+
+WAF_BINARY="${S}/waf"
+
+pkg_setup() {
+ enewgroup ntp 123
+ enewuser ntp 123 -1 /dev/null ntp
+}
+
+src_prepare() {
+ default
+ # Remove autostripping of binaries
+ sed -i -e '/Strip binaries/d' wscript
+ python_copy_sources
+}
+
+src_configure() {
+ is-flagq -flto* && filter-flags -flto* -fuse-linker-plugin
+
+ local string_127=""
+ local rclocks="";
+ local CLOCKSTRING=""
+
+ for refclock in ${NTPSEC_REFCLOCK[@]} ; do
+ if use rclock_${refclock} ; then
+ string_127+="$refclock,"
+ fi
+ done
+ CLOCKSTRING="`echo ${string_127}|sed 's|,$||'`"
+
+ local myconf=(
+ --nopyc
+ --nopyo
+ --refclock="${CLOCKSTRING}"
+ $(use doc && echo "--enable-doc")
+ $(use early && echo "--enable-early-droproot")
+ $(use gdb && echo "--enable-debug-gdb")
+ $(use nist && echo "--enable-lockclock")
+ $(use samba && echo "--enable-mssntp")
+ $(use seccomp && echo "--enable-seccomp")
+ $(use smear && echo "--enable-leap-smear")
+ $(use tests && echo "--alltests")
+ $(use debug && echo "--enable-debug")
+ )
+
+ python_configure() {
+ waf-utils_src_configure "${myconf[@]}"
+ }
+ python_foreach_impl run_in_build_dir python_configure
+}
+
+src_compile() {
+ unset MAKEOPTS
+ python_compile() {
+ waf-utils_src_compile
+ }
+ python_foreach_impl run_in_build_dir python_compile
+}
+
+src_install() {
+ python_install() {
+ waf-utils_src_install
+ }
+ python_foreach_impl run_in_build_dir python_install
+
+ # Install heat generating scripts
+ use heat && dosbin "${S}"/contrib/ntpheat{,usb}
+
+ # Install the openrc files
+ newinitd "${FILESDIR}"/ntpd.rc-r2 ntp
+ newconfd "${FILESDIR}"/ntpd.confd ntp
+
+ # Install the systemd unit file
+ systemd_newunit "${FILESDIR}"/ntpd.service ntpd.service
+
+ # Prepare a directory for the ntp.drift file
+ mkdir -pv "${ED}"/var/lib/ntp
+ chown ntp:ntp "${ED}"/var/lib/ntp
+ chmod 770 "${ED}"/var/lib/ntp
+ keepdir /var/lib/ntp
+
+ # Install a log rotate script
+ mkdir -pv "${ED}"/etc/logrotate.d
+ cp -v "${S}"/etc/logrotate-config.ntpd "${ED}"/etc/logrotate.d/ntpd
+
+ # Install the configuration file and sample configuration
+ cp -v "${FILESDIR}"/ntp.conf "${ED}"/etc/ntp.conf
+ cp -Rv "${S}"/etc/ntp.d/ "${ED}"/etc/
+}
+
+pkg_postinst() {
+ einfo "If you want to serve time on your local network, then"
+ einfo "you should disable all the ref_clocks unless you have"
+ einfo "one and can get stable time from it. Feel free to try"
+ einfo "it but PPS probably won't work unless you have a UART"
+ einfo "GPS that actually provides PPS messages."
+}