summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-07-19 15:20:50 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-07-19 15:20:50 +0200
commit3c4b080c3be104d392547da48767776e343f23c0 (patch)
treefab2d85c09a467a5f7f454dfbaae17c05ddfd6be
parentdev-db/sqlcipher: stable on amd64/x86 (diff)
downloadgentoo-3c4b080c3be104d392547da48767776e343f23c0.tar.gz
gentoo-3c4b080c3be104d392547da48767776e343f23c0.tar.bz2
gentoo-3c4b080c3be104d392547da48767776e343f23c0.zip
app-emulation/docker-proxy: Update snapshot for docker 18.06.0
Package-Manager: Portage-2.3.43, Repoman-2.3.10
-rw-r--r--app-emulation/docker-proxy/Manifest1
-rw-r--r--app-emulation/docker-proxy/docker-proxy-0.8.0_p20180626.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-emulation/docker-proxy/Manifest b/app-emulation/docker-proxy/Manifest
index 57bdbe3d214a..e44463a6d140 100644
--- a/app-emulation/docker-proxy/Manifest
+++ b/app-emulation/docker-proxy/Manifest
@@ -1,2 +1,3 @@
DIST docker-proxy-0.8.0_p20170917.tar.gz 2177045 BLAKE2B 0fed1328e8216ab83b23e8e1fe1793da6e874eced7ad18d101b0b7757f1de4fa7d321fb78620a349a4ed492abb4d85c3ecbf49311698b6af156a6255dec5740e SHA512 673ea638fa5c560d8238d7c1d88f114430f9d8efe701804bfe30044d0c059a688cbf6b62922be50834e16ee055ef6cf015f6232f76f0d942768f9e84e95496cd
DIST docker-proxy-0.8.0_p20180411.tar.gz 2695069 BLAKE2B 5205d5700ad116bb457dc7a57f2624f9efa46f1dbf3f5fe9215077655cddba8e1e1301bc555fb43a22cba4d74423123953a67994bf8974b114350e64be601299 SHA512 300e197313017536f91768ba675f2ab773eb1914f8e5908f4ff5b6fc8c4f0fa5ba1653cd9f8ca26e7c466f1623716aa45a2746f862e47ca9fe9136010085f600
+DIST docker-proxy-0.8.0_p20180626.tar.gz 2718698 BLAKE2B 6214ba714ba8b01214168171f465dfaee4d8ff791db7a219a3fb92fade3e4207d36d90090790c0a3059e6fb209f3cd8bb0082ca75496108ebffb7c9b0c5092a4 SHA512 21d3d1bd8aafeab51a3e0a14ada4d559b5b113a48d315e91f7d70e4fa839f5c92d4068b38c28bf6929da9c11cfc61703bafc7148f64b784208d61fa14ee4545d
diff --git a/app-emulation/docker-proxy/docker-proxy-0.8.0_p20180626.ebuild b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20180626.ebuild
new file mode 100644
index 000000000000..b48125951938
--- /dev/null
+++ b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20180626.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/docker/libnetwork"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ EGIT_COMMIT="3ac297bc7fd0afec9051bbb47024c9bc1d75bf5b"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="Docker container networking"
+HOMEPAGE="https://github.com/docker/libnetwork"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RDEPEND="!<app-emulation/docker-1.13.0_rc1"
+
+RESTRICT="test" # needs dockerd
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}" go build -o "bin/docker-proxy" ./cmd/proxy || die
+}
+
+src_install() {
+ dodoc ROADMAP.md README.md CHANGELOG.md
+ dobin bin/docker-proxy
+}