summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-11-21 21:30:54 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-11-21 21:30:54 -0500
commit3c6d7d70210f4d1c4300e6dd3a9c9fe98c3d9936 (patch)
tree7ec967ba56d8aebd69ea68227029cf2a9bee4f9e
parentuse epatch to apply patch (diff)
downloadgentoo-3c6d7d70210f4d1c4300e6dd3a9c9fe98c3d9936.tar.gz
gentoo-3c6d7d70210f4d1c4300e6dd3a9c9fe98c3d9936.tar.bz2
gentoo-3c6d7d70210f4d1c4300e6dd3a9c9fe98c3d9936.zip
use epatch to apply patch
Package-Manager: portage-2.2.20.1
-rw-r--r--games-puzzle/tint/tint-0.03b.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/games-puzzle/tint/tint-0.03b.ebuild b/games-puzzle/tint/tint-0.03b.ebuild
index 0c5d6923dd1b..e87d7166627e 100644
--- a/games-puzzle/tint/tint-0.03b.ebuild
+++ b/games-puzzle/tint/tint-0.03b.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI=5
-inherit games
+inherit eutils games
MY_P=${P/-/_}
DESCRIPTION="Tint Is Not Tetris, a ncurses based clone of the original Tetris(tm) game"
@@ -15,10 +15,12 @@ SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
IUSE=""
-DEPEND=">=sys-libs/ncurses-5.4-r1"
-RDEPEND="${DEPEND}"
+DEPEND=">=sys-libs/ncurses-5.4-r1:0"
+RDEPEND=${DEPEND}
-PATCHES=( "${FILESDIR}"/${P}-ovflfix.patch )
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ovflfix.patch
+}
src_compile() {
emake \