summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-05-03 18:35:39 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-05 17:27:50 +0200
commit3d0ba05e8d384a742ecf87fdafbb9c5e5b4eec19 (patch)
treef9026c6c624629119b6e653c397deab3d6f497c3
parentsys-libs/libomp: Bump to 5.0.2 (diff)
downloadgentoo-3d0ba05e8d384a742ecf87fdafbb9c5e5b4eec19.tar.gz
gentoo-3d0ba05e8d384a742ecf87fdafbb9c5e5b4eec19.tar.bz2
gentoo-3d0ba05e8d384a742ecf87fdafbb9c5e5b4eec19.zip
sys-devel/clang-runtime: Bump to 5.0.2
-rw-r--r--sys-devel/clang-runtime/clang-runtime-5.0.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-5.0.2.ebuild b/sys-devel/clang-runtime/clang-runtime-5.0.2.ebuild
new file mode 100644
index 000000000000..8732a1022ce2
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-5.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="${PV%_*}"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"