summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2016-06-27 23:45:13 -0400
committerAlexandre Rostovtsev <tetromino@gentoo.org>2016-06-27 23:46:50 -0400
commit3d0c339f4bb4f152f645503c2d12facbc2274f0c (patch)
tree1e85a10f8b01d3d0d0801f6d1aaa01fa17cc6d09
parentapp-editors/gedit: bump to 3.20.2 for gnome-3.20 (diff)
downloadgentoo-3d0c339f4bb4f152f645503c2d12facbc2274f0c.tar.gz
gentoo-3d0c339f4bb4f152f645503c2d12facbc2274f0c.tar.bz2
gentoo-3d0c339f4bb4f152f645503c2d12facbc2274f0c.zip
app-editors/gedit-plugins: bump to 3.20.0 for gnome-3.20
Package-Manager: portage-2.3.0
-rw-r--r--app-editors/gedit-plugins/Manifest1
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-3.20.0.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/app-editors/gedit-plugins/Manifest b/app-editors/gedit-plugins/Manifest
index 89092dbb9c2d..3abf1c622818 100644
--- a/app-editors/gedit-plugins/Manifest
+++ b/app-editors/gedit-plugins/Manifest
@@ -1,2 +1,3 @@
DIST gedit-plugins-3.16.0.tar.xz 1280064 SHA256 b685b84ada8ca04f6aa201e402a0208591be4a37b874595a0a85d0a14b52f191 SHA512 336d57bf9a25bb70cf63bb4ea6e81215381e91a04126429fd4f930596ed1731ceb8ed36b091757fb6729ba032bd8af083a3ec056a2e91f7abddc505282e511e2 WHIRLPOOL a5ef32695c8b7bbe0fd19a53496d7390d306e9587a0228cfb0151ff59eb0d127ba85e7c481403fb6fb3aaf14fb95428c6b60d5b65cafcecab230edc2733bc918
DIST gedit-plugins-3.18.0.tar.xz 1366868 SHA256 e25249c0c2a057827bb4d4755a2359e1f9b4de288e0c4e201c6ef4f0e0e8c580 SHA512 8ce705c3263492c699f2504c178f81760e0d3d153dff0bdadbf39c240d77951e887534f586a3b340904dc11c9bf55424861dd43395a3ae8eadfa5752a4d168ca WHIRLPOOL de69a801e7b68ca42a2b2dd588452ba8a3e62bf39199e4662a10c4d557173f4ec8b7f145f1530de7a607740bf3c06ddd942af85e0d27a3fc7e4b013433a1e9e0
+DIST gedit-plugins-3.20.0.tar.xz 1344188 SHA256 d4902af5f9f728e0d692ca8c2f7a9f88f6c2ab8c9be037238ffb7d3aebe757bf SHA512 de0466c8031ed9cfa95487e9ff67dc45f1110c47d5b7655a1aef8a84d896184e062dfd9177325b2221d9e2d6ad04c1fa4368a74c07a2257aa548ea2a5b958f17 WHIRLPOOL 3c949864a7b3fb8d30adc0e0cda56d0ccbae46b0711f02b7c45050247b597963cbd2d3b38db187204d85f51eb33c95eacc1bf35eb502b1e572b80cb03f7ee50f
diff --git a/app-editors/gedit-plugins/gedit-plugins-3.20.0.ebuild b/app-editors/gedit-plugins/gedit-plugins-3.20.0.ebuild
new file mode 100644
index 000000000000..91fdfc7a4dbe
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-3.20.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+GNOME2_LA_PUNT="yes" # plugins are dlopened
+PYTHON_COMPAT=( python3_{3,4,5} )
+PYTHON_REQ_USE="xml"
+VALA_MIN_API_VERSION="0.28"
+
+inherit eutils gnome2 multilib python-r1 vala
+
+DESCRIPTION="Official plugins for gedit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ShippedPlugins"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+IUSE_plugins="charmap git terminal vala zeitgeist"
+IUSE="+python ${IUSE_plugins}"
+# python-single-r1 would request disabling PYTHON_TARGETS on libpeas
+REQUIRED_USE="
+ charmap? ( python )
+ git? ( python )
+ python? ( ^^ ( $(python_gen_useflags '*') ) )
+ terminal? ( python )
+ zeitgeist? ( python )
+"
+
+RDEPEND="
+ >=app-editors/gedit-3.16[python?]
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libpeas-1.7.0[gtk,python?]
+ >=x11-libs/gtk+-3.9:3
+ >=x11-libs/gtksourceview-3.17.3:3.0
+ python? (
+ ${PYTHON_DEPS}
+ >=app-editors/gedit-3.16[introspection,${PYTHON_USEDEP}]
+ dev-libs/libpeas[${PYTHON_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.9:3[introspection]
+ >=x11-libs/gtksourceview-3.14:3.0[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ )
+ charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
+ git? ( >=dev-libs/libgit2-glib-0.0.6 )
+ terminal? ( x11-libs/vte:2.91[introspection] )
+ vala? ( $(vala_depend) )
+ zeitgeist? ( >=gnome-extra/zeitgeist-0.9.12[introspection] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40.0
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+}
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable python) \
+ $(use_enable vala) \
+ $(use_enable zeitgeist)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # FIXME: crazy !!!
+ if use python; then
+ find "${ED}"/usr/share/gedit -name "*.py*" -delete || die
+ find "${ED}"/usr/share/gedit -type d -empty -delete || die
+ fi
+
+ # FIXME: upstream made this automagic...
+ clean_plugin charmap
+ clean_plugin git
+ clean_plugin terminal
+}
+
+clean_plugin() {
+ if use !${1} ; then
+ rm -rf "${ED}"/usr/share/gedit/plugins/${1}*
+ rm -rf "${ED}"/usr/$(get_libdir)/gedit/plugins/${1}*
+ fi
+}