summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-29 06:21:49 +0200
committerMichał Górny <mgorny@gentoo.org>2023-03-29 06:23:17 +0200
commit3d6229be5823dabff5bd50c8b63ab2053da0bc9c (patch)
tree54c21a3ea9a42ea839fd5150172fbf0f4e25d67c
parentdev-python/botocore: Bump to 1.29.101 (diff)
downloadgentoo-3d6229be5823dabff5bd50c8b63ab2053da0bc9c.tar.gz
gentoo-3d6229be5823dabff5bd50c8b63ab2053da0bc9c.tar.bz2
gentoo-3d6229be5823dabff5bd50c8b63ab2053da0bc9c.zip
dev-python/boto3: Bump to 1.26.101
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.101.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index f0bc150eef54..90065c146afd 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,4 +1,5 @@
DIST boto3-1.26.100.gh.tar.gz 627269 BLAKE2B 1481e456b73794a4f371e5ac935d3d777c5315c1da39f8565631f62e05bd218e85409d5e5e095057af2c05c4bbcd9c1c5a56b4d1b8d2ef8e97ec567bfdd959a3 SHA512 45fdbb31c7e39ac1775e89755f88d426bdd17be002a13c1c517f2ec4b7ce1fcf0df7d1ff6c6d678fab5a7a1d656f9f609a6d4b3ab779464ea14a3e52eb7e4771
+DIST boto3-1.26.101.gh.tar.gz 627662 BLAKE2B 322a6e723851464409512e9d8dd17b5f2aa9717d97b8fc349c22e95db09bd8b8554631cd3afe52d31e34f4972ae0e5642762bf2ba13e8e5c5d56a05c3013c218 SHA512 7a1b9a089946dcb609a8c446b4c40f4f8861770b6592b6a11992573f7281a8fec0e3ae9d77abee542a88c588dfa23102110312d969f8aa63b3b0ffaf968a8e86
DIST boto3-1.26.89.gh.tar.gz 615718 BLAKE2B 3257e6efafaf139daf935385c252c10929be2a4277a8f0f192afc6dbd7cc32fa8f940a4e59ebbe25931c399dedb926a3c1848bd9cc0a7f0d377acb302eabe3b0 SHA512 02ee02b05023e9184f779ab8ff21afa6f7e56f7d2e883d021b2567676c5fc57cad6b475d55316a2017c2a837c41d2f5604824f440060e2f96804c5a61ccdd143
DIST boto3-1.26.94.gh.tar.gz 617861 BLAKE2B 908b40868735038810cf75c903bbc8bad00a6ea8776b2a5a236683f18f2185971f8a13db5349086b1aef2c4d51361c8ebf30f2d671cea7f4101c9882a59b6acf SHA512 036278668afa33dfdaab9cc2e02c2c3e0596ec1c1b407767f22bc6a4cd87913f883f85430ff6a120c5e0fdd2194b70c911fe7a207bc26ed5fcd415f3754cde35
DIST boto3-1.26.99.gh.tar.gz 625932 BLAKE2B 961a640995abdafbf2cd73f83ed5af0e1314cebbc5dc154771204e7c16532ad4a84aed08cbd7789af30de518bf2e8bd5204e9a540a2d3a08e75222c2eeb9a68a SHA512 ff726483a83a11a8c088905998af0a1a791e87503b39422811d82b3122275a24eb955636407422af7552908eee22d4c1369779a7798f09f958a8af5234c0c11d
diff --git a/dev-python/boto3/boto3-1.26.101.ebuild b/dev-python/boto3/boto3-1.26.101.ebuild
new file mode 100644
index 000000000000..2a4a7643203e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.101.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}