summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-07-19 17:36:55 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-07-19 17:51:33 +0200
commit3dae50fef8ae6e03cdeef601fd82d9629d3c838f (patch)
tree1662697b4890e3b8a2a029c7c2af9ecf128b66f4
parentdev-lang/gprolog: apply upstream patch for PIC-aware GPLC. Closes #403693 (diff)
downloadgentoo-3dae50fef8ae6e03cdeef601fd82d9629d3c838f.tar.gz
gentoo-3dae50fef8ae6e03cdeef601fd82d9629d3c838f.tar.bz2
gentoo-3dae50fef8ae6e03cdeef601fd82d9629d3c838f.zip
app-misc/recoll: version bump.
Gentoo-Bug: https://bugs.gentoo.org/625262 Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--app-misc/recoll/Manifest1
-rw-r--r--app-misc/recoll/recoll-1.23.2.ebuild133
2 files changed, 134 insertions, 0 deletions
diff --git a/app-misc/recoll/Manifest b/app-misc/recoll/Manifest
index 55e40de60102..665fd5c00b3f 100644
--- a/app-misc/recoll/Manifest
+++ b/app-misc/recoll/Manifest
@@ -1 +1,2 @@
DIST recoll-1.22.4.tar.gz 2511949 SHA256 8211e1ccc6e576b0c21e5bfb4f49a0b69990a44bd5a3ce6eae4ff16aaf23412f SHA512 90d258c854972a41adbb3eef71b08d25c5aea24ed6fc830245d19e273112c016b66b0359e1d83143992d07b5a67226216e8f406ac135c21da6b86c7ffde31225 WHIRLPOOL 2dac2936e4c13448b6f8cb0c6d9d0d6d1d7c14b47a6761b6115762d734f91cfd8652186627b8ab55149c14ff5b00260838b0e62962f32ecbd4d2bef1f25e44ba
+DIST recoll-1.23.2.tar.gz 2546793 SHA256 0e93e6be0dc2225b03a4850887bd29da47a61e07652fde51be254ef9f8310048 SHA512 0f3d6bae73da066e92e328f963129979f43a12a622120c26d66debde66e569e19e3e8b61154ee77386ad93e968d88262d3e22a679b618bcb8bf468fa16a46769 WHIRLPOOL fec47a74d48c2ae0f93e56964bbfa53b62a0be7d57d602ddb36bb03cc2eb7293c4ffa589a967bc70a76e2478fb315f189cfdab72618a32439c357c1a440e9ff6
diff --git a/app-misc/recoll/recoll-1.23.2.ebuild b/app-misc/recoll/recoll-1.23.2.ebuild
new file mode 100644
index 000000000000..c17511e06209
--- /dev/null
+++ b/app-misc/recoll/recoll-1.23.2.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit linux-info python-single-r1 qmake-utils
+
+DESCRIPTION="A personal full text search package"
+HOMEPAGE="http://www.lesbonscomptes.com/recoll/"
+SRC_URI="http://www.lesbonscomptes.com/recoll/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="camelcase doc +inotify qt4 qt5 session +spell"
+REQUIRED_USE="session? ( inotify ) ${PYTHON_REQUIRED_USE}"
+
+CDEPEND="
+ dev-libs/xapian:=
+ sys-libs/zlib
+ virtual/libiconv
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwebkit:5
+ )
+ !qt5? ( qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ ) )
+ session? (
+ inotify? ( x11-libs/libSM x11-libs/libICE )
+ )
+ spell? ( app-text/aspell )
+ ${PYTHON_DEPS}
+"
+
+DEPEND="
+ ${CDEPEND}
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+
+RDEPEND="
+ ${CDEPEND}
+ app-arch/unzip
+ sys-apps/sed
+ virtual/awk
+"
+
+pkg_setup() {
+ if has_version "<app-misc/recoll-1.20"; then
+ einfo "Installing ${PV} over an 1.19 index is possible,"
+ einfo "but there have been small changes in the way"
+ einfo "compound words are indexed. So it is best to reset"
+ einfo "the index. The best method to reset the index is to"
+ einfo "quit all recoll programs and delete the index directory"
+ einfo "rm -rf ~/.recoll/xapiandb, then start recoll or recollindex."
+ fi
+ if use inotify; then
+ CONFIG_CHECK="~INOTIFY_USER"
+ check_extra_config
+ fi
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang filters
+ default
+}
+
+src_configure() {
+ local qtconf
+ if use qt4 || use qt5; then
+ qtconf="--enable-qtgui"
+ if use qt5; then
+ export QT_SELECT=qt5
+ qtconf+=" --enable-webkit"
+ elif use qt4; then
+ export QT_SELECT=qt4
+ qtconf+=" --disable-webkit"
+ fi
+ else
+ qtconf="--disable-qtgui --disable-webkit"
+ fi
+
+ econf \
+ $(use_enable camelcase) \
+ $(use_enable session x11mon) \
+ $(use_with inotify) \
+ $(use_with spell aspell) \
+ ${qtconf} \
+ --without-fam \
+ --enable-recollq
+}
+
+src_install() {
+ emake STRIP="$(type -P true)" DESTDIR="${D}" install
+ prune_libtool_files
+
+ # html docs should be placed in /usr/share/doc/${PN}/html
+ use doc && dodoc "${ED}"/usr/share/recoll/doc/*
+ rm -r "${ED}/usr/share/recoll/doc" || die
+}
+
+pkg_postinst() {
+ einfo "In order to extract the full functionality of "
+ einfo "recoll, the following packages should be installed "
+ einfo "to get the corresponding document support."
+
+ optfeature "XML based documents support" "dev-libs/libxslt[python] dev-libs/libxml2[python]"
+ optfeature "PDF files support" app-text/poppler
+ optfeature "PDF files with OCR support" app-text/tesseract
+ optfeature "MS Word files support" app-text/antiword
+ optfeature "Wordperfect files support" "app-text/libwpd[tools]"
+ optfeature "Lyx files support" app-office/lyx
+ optfeature "CHM files support" dev-python/pychm
+ optfeature "GNU Info files support" sys-apps/texinfo
+ optfeature "RAR archives support" dev-python/rarfile
+ optfeature "7zip archives support" dev-python/pylzma
+ optfeature "iCalendar files support" dev-python/icalendar
+ optfeature "Postscript files support" app-text/pstotext
+ optfeature "RTF files support" app-text/unrtf
+ optfeature "TeX files support" dev-text/detex
+ optfeature "DVI files support" virtual/tex-base
+ optfeature "DJVU files support" app-text/djvu
+ optfeature "tags in audio files support" media-libs/mutagen
+ optfeature "tags in image files support" media-libs/exiftool
+ optfeature "Midi karaoke files support" dev-python/chardet
+}